Betriebssystem für Maximum Warp PC 2017

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Betriebssystem für Maximum Warp PC 2017

Beitragvon Sigurd » Do 13. Jul 2017, 14:18

So, ArcaOS 5.0 ließ sich "out of the box" ohne irgendwelche Probleme auf dem System installieren. Daumen hoch - Sehr gut! :!:

Aber - wie ich so bin - mir gefällt immer noch das "alte" Warp 4 am besten - insoweit wohl keine Überraschung :lol: . Ich habe also beschlossen, einen neuen Klon aufzubauen und habe dies jetzt in den letzten drei Tagen erfolgreich abgeschlossen. Und erstmalig habe ich das auch Schritt für Schritt dokumentiert. Auch die Misserfolge dabei.

Für Interessierte füge ich das Protokoll hier einmal ein. Das ganze baut auf dem WSeB 4.52 auf und ist Treibertechnisch auf dem Stand von ArcaOS 5.01 (im wesentlichen). Einige Teile fehlen noch, andere sind rein aus Nostalgiegründen dabei, machen eigentlich keinen praktischen Sinn, aber darum geht es mir ja auch nicht. Genauso sind vermutlich manche meiner Schritte von Euch nur mit einem Kopfschütteln nach zu vollziehen, aber manchmal will ich gleich zu Anfang mit dem Kopf durch die Wand. :roll: 8-) . Gemacht wurde das alles auf dem Surface Pro 4 innerhalb von Virtualbox unter Windows 10. Dadurch kann ich den Klon auch auf jedem x-beliebigen Rechner mitnehmen und dort bearbeiten. Virtualbox OS/2 Additions wurden NICHT installiert, da der Klon ja hauptsächlich für "echte Hardware" gedacht ist.

Der Klon wird später noch von 2 auf 4 GB vergrößert und es werden weiter Dinge hinzugefügt (Smartsuite, Office, Cups, DOSBOX usw. usw.)

Ja - ich besitze ALLE Lizenzen ;)

Am Ende gibt es auch noch ein paar Bilder dazu.

Fragen dazu beantworte ich gerne!

So, hier beginnt die Beschreibung:

****************************************************************************************************************************************

2017-07-10


- Basisinstallation
===================


Virtualbox:

- 2 Prozessoren, 8GB HDD, COM, USB, Soundblaster 16, Grafik 128MB


Installation:
-------------

Basissystem:

- Warp Server for e-business 4.52 (ACP 2)
- Kernelrevision 14.089 UNI
- Partition C, Primär, 2GB angelegt
- HPFS formatiert lang
- Maximalinstallation: alle Installationsoptionen ausgewaehlt inklusive SMP
- MaximalNetzwerkinstallation: alle Programme und Optionen ausgewaehlt
- Generic VESA Gradd statt SVGA
- Netzwerkkarte: automatisch IBM PCI Ethernet Adapter (AMD)
- Benutzer Kennwort
- TCPIP und Fernzugriff (nur ETHERNET ausgewaehlt) nicht administriert
- Domaenensteuereinheit, Servername:

1. Neustart:

- Kernelrevision 14.089 SMP
- crash in Doscall1.dll bei erstem Neustart vor Installationsphase 2

Aenderungen:

VM:

- Vtx ausgeschaltet
- Nested Paging aktiviert
- IO APIC aktiviert

2. Neustartversuch

- Kernelrevision 14.089 SMP
- crash in Doscall1.dll bei erstem Neustart vor Installationsphase 2

3. Neustartversuch

- VM umgestellt auf 1 Prozessor
- Kernelrevision 14.089 SMP
- VM hangt sich auf

-> Abbruch

- Neustart Installation von CD
- Einziger Unterschied: nur 1 Prozessor
- Alle anderen Einstellungen wie gehabt
- SMP Unterstuetzung trotzdem ausgewaehlt
- crash in Doscall1.dll bei erstem Neustart vor Installationsphase 2

-> Abbruch

- Neustart Installation von CD
- Nur 1 Prozessor
- SMP Unterstuetzung NICHT ausgewaehlt
- crash in Doscall1.dll bei erstem Neustart vor Installationsphase 2

-> Abbruch

- Erleuchtung: Fehler liegt in der Auswahl des Grafiktreibers!
- nicht GRADD sondern SNAPse verwenden
- Neustart mit 1 Prozessor
- Installation erfolgreich inklusive Nachinstalltion Extras von CD1 (Webbrowser, Tookit, etc.)

-> Basisinstallation erfolgreich abgeschlossen!
---------------------------------------------------------------------------------------------------


- Programminstallation mit 2GB Grenze
-------------------------------------


- Microsoft Excel 5.0
- Microsoft Word 6.0a
- Microsoft Video fuer Windows
- Microsoft Works 2.0
- Norton Commander fuer DOS 4.0
- Seagate Backup Exec fuer OS/2 Version 3.0
- IMPOS/2 Bildbearbeitung

- IBM Feature Installer Programme:
- IBM Bonuspak
- IBM Voice Type
- Faxworks usw.
-> mittels dieser Anleitung:
First, you need to grab a copy of \OS2\INSTALL\FIBASE.RSP off an installed
Warp 4 box. (Or from the Warp 4 CD, if you know which file it's PACKed
inside, but I don't.) MCP2 has its own FIBASE.RSP, but you need the Warp
4 one. Copy it onto your system to some temporary directory.
Next, open a command prompt and run 'CLIFI /A:T'. This will create an
'Install Object' on the desktop.
Right-click on the Install Object and from the context menu choose
'Response file' --> 'Read'. Select the FIBASE.RSP you just retrieved.
Create a text file called e.g. OPTIONS.RSP and put the following into it:
FIBASE.TargetDrive=D:  # substitute D: with the install drive you want
If you want VoiceType and the BonusPak on separate drives, you could
alternatively put in the following:
VT.TarDrv=D: # substitute D: with the install drive you want
OS2BONUSPAK.TarDrv=E: # substitute E: with the install drive you want
Right-click on the Install Object and, once again, from the context menu
choose 'Response file' --> 'Read'. Select the OPTIONS.RSP file you just
created.
Right-click on the Install Object and choose 'Properties'. Verify that
'TargetDrive' and 'SourcePath' are showing the correct values (as you
specified in OPTIONS.RSP).
Insert your Warp 4 CD.
Double-click on the Install Object and make sure you DESELECT EVERYTHING
EXCEPT 'VT' and 'OS2BONUSPAK'.
Under 'OS2BONUSPAK' you can select whatever components you want.
BPASKPSP is AskPSP, an obsolete support tool. Don't select this.
BPCIM is CompuServe Information Manager.
BPFAXWORKS is FaxWorks.
BPHAL is HyperAccess Lite, some sort of terminal program?
BPHPCOMMON, BPHPJETCLIENT and BPHPJETSERVER
are all part of HP JetAdmin.
BPIBMWORKS is IBM Works, I guess you want this one.
BPMARKCOMMON, BPMARKNET and BPMARKVIS
are all part of Lexmark MarkVision.
BPRS2 is the old IBM Remote Support Tool.
BPVIDEOIN is VideoIn.
When you've made your selections, press 'Install'.
When it prompts you for the media path (it defaults to x:\FI where x: is
your first CD-ROM drive), change it to x:\OS2IMAGE\FI, where x: is the
CD-ROM drive with the Warp 4 CD.
The install should then run. Reboot when done.

-> In meinem Fall wird die CD nich benoetigt, alle Dateien liegen im Verzeichnis
\APPS\FI auf Laufwerk C:

---------------------------------------------------------------------------------------------------------

- Diverse Nacharbeiten 1. Tag
-----------------------------

- Diverse Hintergrundbilder nach \OS2\BITMAPS kopiert
- Diverse Startlogobildschirme nach \APPS\LOGO kopiert
- OS/2 Warp Lernprogramm in \APPS\TUTORIAL erstellt und der Programmgruppe "Unterstuetzung" hinzugefuegt
- Design auf Warp 4 umgestellt
- Neustart mit aktivierter Archivierung
- Sicherungspunkt erstellt

=========================================================================================================

2017-07-11


ZWEITER TAG
===========


- Diverse config.sys Einstellungen:
-----------------------------------

-> DOS=HIGH,UMB
-> FILES=100
-> AusgeREMte USB Unterstuetzung aktiviert (USBEHCI fehlt noch!)


- Installation von Zusatzprogrammen:
------------------------------------

-> Warpin 1.0.22 nach \APPS\WARPIN
-> Archive Viewer 2.1 nach \APPS\ARC
-> LibC 0.6.5
-> GCC4 Runtime
-> FreeType 2 Version 1.33 nach \APPS\FT2V133
-> VisproRexx 3.1 Gold nach \APPS\VISPRORX Registriernummer: VPR1561390
-> xWorkplace 1.0.11 Deutsch nach \APPS\XWORKPLACE
-> DFSEE 14.3 in \APPS\DFSEE
-> OS2Commander in \APPS\OS2COMM
-> Ways 2.1 fuer Windows in \APPS\WAYS2
-> Corel Draw 4.0 fuer Windows in \APPS\COREL40
-> Lucide 1.35 in \APPS\LUCIDE
-> Voicelearn in \APPS\Voicelearn
-> BlueCAD in \APPS\Bluecad
-> GMB fuer OS/2 in \APPS\GBM
-> True Spectra Photographics 2.02 Pro in \APPS\TRUESPEC
-> Easy Sync Version 3.1 in \APPS\SYNC


- Treiberaktualisierung und Installation:
-----------------------------------------

-> HPFS386 von Support CD Warp Server for e-business installiert inkl. Fehlertoleranz
-> Warpsans von Alex Taylor
-> Multimac 20161204 Netzwerkkartentreiber
-> USB 1114 Treiber von ArcaNoae
-> USB CFG 082
-> USB Treiber im System angepasst mit USBCFG
-> Fixpac Installation via Update Prozedur Alex Taylor:
Fixpac XRGC005 (Basissystem nun auf Kernel Level 14.103 UNI)
Fixpac XR_D0031 Treiberpaket
Fixpac UNG2334 TCPIP
Fixpac WRG8708 MPTS
-> manueller Kernelaustausch auf Version 14.104a UNI
inklusive os2ldr
inklusive doscall1.dll
-> ACPI Version 3.23.05
-> Amouse Version 3.1.02
-> JFS Version 1.9.7
-> Uniaud 20170625
-> Danis506.ADD Version 1.08.15
-> AHCI Version 1.32

-> Zwischenergebnis: soweit stabil aber kein CD Laufwerk mehr!
Fehlerursache: DANIS und AHCI in config.sys ausgeREMt, Laufwerk wieder da!


- weitere Programminstallationen
--------------------------------

-> EMT4PM nach \OS2\APPS\EMT
-> IBM Webbrowser auf Version 2.0.5 upgedated
-> Netscape Navigator 2.02 in \APPS\NAV202
-> Netscape Communicator 4.61 PluginPac
-> Mozilla Runtime 2.5.4
-> ODIN 0.8.9 inklusive ODINTool und ODINGUI in APPS\ODIN
-> QT 4.73 in \APPS\QT473
-> Virtual PC fuer OS/2 Version 5.1 in \APPS\VIRTUALPC
-> Virtualbox fuer OS/2 Version 1.6 in \APPS\VIRTUALBOX
-> PMVIEWPRO 3.71 in \APPS\PMVWPRO
-> Configtoll 1.30 in \APPS\CFGTOOL
-> Diverse Symbole nach \APPS\SYMBOLE kopiert
-> OS/2 WseB Startlogo gegen eigenes getauscht


- Abschlussarbeiten Tag 2:
--------------------------

-> Sichern der VBox nach Archivierungsfunktion, noch ca. 563 MB Platz

==================================================================================================


2017-07-12


DRITTER TAG
===========


- weitere Treiber- und Programminstallationen
---------------------------------------------

-> Austausch des SNP704se -> SNAP 3.18 in \APPS\SNAP
-> Ergaenzung /MAXCPU=4 bei acpi.psd in config.sys wegen SNAP
-> Altverzeichnis \SDD geloescht
-> OS2 Bamba Plugin in \APPS\BAMBA
-> UDF Dateisystem aktualisiert auf 2.1.6 inklusive
UUDF.DLL
IBMIDECD.FLT
OS2CDRM.DMD
UDF.IFS
-> Innotek Flash Version 7.07.9 (Flash 7 Fake 9) installiert, dabei als Standardpfad angegeben:
C:\APPS\OS2WEB\PLUGINS
und Flash 5 npswf2.dll in ndpswf25.dll umbenannt
-> Papyrus Version 13.10P von 2008 in \APPS\PAPYRUS
-> IBM OpenGL Update, das Tookit in \APPS\OPENGL\TOOLKIT
-> RSJ CD Writer Version 6.03 inklusive Handbuch in \APPS\CDWFS
-> Watchcat Version 2.10 in \APPS\WHCAT, Aktivierung mit SHIFT+W
-> IBM Desktop on Call Version 4 in APPS\DTOC
-> IBM Person to Person P2P/2 Version 1.0.3 aus Warp 3 Bonuspak in \APPS\P2P
Konfiguration: IBM TCP/IP, Softwarevideoemulation
-> Novell Netware 2.12 fuer OS/2 in \APPS\NETWARE
-> Folge: Bootvorgang bleibt stehen
-> Abhilfe: in config.sys Netware bezogene Einstellungen mit rem (klein) ausgeREMt
-> AnPoCodec 1.2 Multimedia Codec von Andreas Portele
-> QuickMoton 1.1. Multimedia Codec von Andreas Portele
-> MP3 0.4.3/Vorbis 0.3.2/FLAC 0.3.0 Multimedia Codecs
-> PNG 0.7.0 Unterstuetzung fuer die WPS
-> PM123 Version 1.3.5 inklusive Skins in \APPS\PM123
-> Tame Version 1.05 Scannerprogramm in \APPS\TAME
-> Netdrive für OS/2 Version 3.1.5.840 in \APPS\NETDRIVE
-> WPIViewer in \APPS\WPIVIEW
-> USB Druckertreiberanschluss nachinstalliert 11.14
-> USB Monitor und USB Printermonitor nachinstalliert
-> IFS FAT32 Version 0.9.13
-> IBM Antivirus fuer OS/2 Version 3.02 in \APPS\IBMAV
-> Allianz Bildschirmschoner in \APPS\FISCHE
-> Moneyplexx fuer OS/2 Version 4.03 in \APPS\MONEYPLX
-> ISDNPM Version 3.02 in \APPS\ISDNPM

- Unterverzeichnis \TREIBER angelegt, dort sind abgelegt:

-> IBM Joysticktreiber
-> Panorama Vesa Treiber Version 1.08


- Abschlussarbeiten Tag 3:
--------------------------

-> Sichern der VBox nach Archivierungsfunktion, noch ca. 375 MB Platz

==================================================================================================


2017-07-13


VIERTER TAG
===========


- Umstellung der VM auf 2 Prozessoren


- weitere Treiberinstallationen
-------------------------------

-> Installation des QSINIT Loaders 17032017, Paket gespeichert in \TREIBER
-> Umstellung Watchcat Aufruf von SHIFT+W auf SHIFT+CTRL+W
-> Anlegen neuer Verzeichnisse:
\DATEIEN\
\DATEIEN\Dokumente
\DATEIEN\Downloads
\DATEIEN\Medien
\DATEIEN\Symbole
\DATEIEN\System
\DATEIEN\Treiber
-> die bisherigen Verzeichnisse Logo (nach System) und Symbole hierhin verschoben
-> Befuellen des Treiberverzeichnisses mit diversen Treibern (WLAN, CMEDIA usw.)


- Vorbereitung auf das Dualboot System
--------------------------------------

-> Airboot Manager Version 1.08 installiert
-> mit DFSEE eine logische 4GB Partition am Ende der 8GB virtuellen Disk erstellt
-> VM Sicherungspunkt erstellt


- Installation von ArcaOS 5.01 als Parallel- und Klonsystem in der VM
---------------------------------------------------------------------

-> ArcaOS 5.0.1 auf JFS Laufwerk O: installiert
-> dort DFSEE Version 14.3 installiert


- zurueck zur OS/2 Partition
----------------------------

-> OS2AHCI von ArcaOS 5.01 nach \DATEIEN\TREIBER kopiert und im System in \OS2\BOOT ersetzt
-> VM Sicherungspunkt und VM Kopie erstellt
-> Hexedit/2 installiert in \APPS\HEXEDIT\
-> Kernelupdates etc. von Holger Veith abgespeicher in \DATEIEN\TREIBER\HOLGER


- zurueck zur ArcaOS Partition
------------------------------

-> Umstellung der OS/2 Partition auf SMP

-> doscall1.dll von ArcaOS5.01
-> OS2KRNL Version 14.112 von Holger Veith
-> Aenderung des acpi Schalters in der config.sys auf /MAXCPU=1


- zurueck zur OS/2 Partition
----------------------------

-> Start des Systems funktioniert einwandfrei! :-)
-> Versuch: Umstellung auf /MAXCPU=2
-> Start des Systems dauert etwas länger, funktioniert aber einwandfrei :-)
-> Versuch: Umstellung auf /MAXCPU=4 -> WPS Haenger, zurueck auf /MAXCPU=2
-> noch ca. 265 MB frei
-> SIcherungspunkt und Sicherungskopie erstellt


-> Klonen des Systems und heraus damit aus der VM:
==================================================

-> zurueck zur ArcaOS Partition
-> USB Stick angeschlossen und an die VM durchgereicht
-> mit DFSEE ein Image der OS/2 Partition erzeugt
-> nach Abshcluss: auf den durchgereichten USB Stick kopiert


-> FERTIG!!
===========

-> Den kann ich nun auf "echte Hardware" zurueckspielen und noch "feintunen".

*******************************************************************************************************************************

Nun die Bilder:

Die fertige VM (OS/2 Teil):
-> BEACHTE: 2 Prozessorkerne aktiviert, keine Probleme mit DOS oder WINOS2!

VM Fertig 1.png


Im in der VM parallel installierten ArcaOS wird der Klon der OS/2 Partition erzeugt:

VM Fertig 2.png


Der Klon wird vom ARcaOS Laufwerk O: auf das USB Laufwerk D: kopiert:

VM Fertig 3.png


Der Klon auf dem USB Stick:

VM Fertig 4.png
Zuletzt geändert von Sigurd am Fr 14. Jul 2017, 08:48, insgesamt 1-mal geändert.
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » Fr 14. Jul 2017, 10:41

Heute habe ich noch schnell die 2GB OS/2 Partition auf 4GB innerhalb der VM vergrößert. Hierzu füge ich auch meine Schritte dazu ein.

Natürlich wäre auch die Vergrößerung auf jede weitere (Limit bei HPFS = 64GB) möglich, vorausgesetzt man dimensioniert die VM von vorneherien groß genug. Dies geht so natürlich auch auf "echter Hardware" :-)



2017-07-14


FUENFTER TAG
============


- weiteres Feintuning


-> weitere Programm- und Treiberinstallationen
----------------------------------------------

-> VLC 2.2.4 in APPS\VLC
-> KLIBC 1.0.2.0 (Hinweis: VLC 2.2.4 laeuft trotzdem noch nicht - Problem verschoben!)
-> UCLIB 0.3.0, Readme nach \APPS\UCLIP verschoben
-> Aktuelle USB.IDS von linux.org heruntergeladen nach \OS2 kopiert
-> Taskmanager (wxtask.dll) fuer Xworkplace XCenter in \APPS\XORKPLACE\PLUGINS\XCENTER kopiert
-> USB Resource Manager in \APPS\USBRESM, Programmobjekt erstellt, USB.IDS hinein kopiert
-> USBECD Version 2.0 in \APPS\USBECD kopiert, Usbecd.sys nach \OS2\BOOT kopiert, config.sys ergaenzt
-> Clock Syncronisation Version 1.1.0 wpi in APPS\TIMESET installiert, Umbenennung in Zeit Syncronisation
-> WPTOOLS.DLL nach \OS2\DLL kopiert
-> Freier Speicherplatz noch 146 MB
-> Arbeitsoberflaeche archiviert und Sicherungspunkt der VM erstellt


-> Vergroeßerung der OS/2 Partition von 2 auf 4 GB
--------------------------------------------------

-> Neustart, Auswahl ArcaOS 5
-> Image der OS/2 Partition mit DFSEE in O:\KLON erstellt
-> Imagegroesse: 1.327 MB
-> Mit DFSEE die 2GB Partition C geloescht
-> Mit DFSEE neue 4GB Partition C angelegt (deshalb wurde die ArcaOS Partition zu Anfang AM ENDE der 8GB erstellt!)
-> Primaere Partition
-> Type IFS HPFS
-> Groesse 4188 MB
-> Drive Letter = C:
-> Neustart von ArcaOS 5
-> mit F10 in Airboot Manager Menue und Bezeichnung der Partition C geaendert
-> Start von ArcaOS 5
-> Image mit DFSEE in die OS/2 Partition zurueck gespielt (Image, Restore, to a Partition)
-> Warnungen dabei ignorieren (3 minor warnings)
-> Nach Abschluss: Image an die neue Groesse anpassen:
-> in DFSEE mit "Partition to work with" die OS/2 Partition auswaehlen (nicht notwendig wenn dies hier DIREKT durchgefuehrt wird)
-> Actions
-> Rezise Partition and Filesystem
-> Adjust FS to Partition Size
-> Nach Abschluss: Reselect whole disk
-> mit File , Open Partition to work on, wieder Laufwerk C auswaehlen
-> mit F10 in Befehlszeile unten im Programmfenster springen
-> FIXBOOT eingeben und Enter, Abfrage bestaetigen
-> FIXPBR eingeben und Enter,
-> Nach ABschluss: Neustart der VM
-> Test = funktioniert!

*************************************************************************************************************************************

VM Fertig 5.png
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » Mi 2. Aug 2017, 22:46

So, ich habe den Urlaub genutzt, den ersten - hier bisher geschilderten - Versuch zu verbessern bzw. zu ändern und aus den Fehlern dieses Versuchs zu lernen.

Ich habe also noch einmal bei "Null" angefangen und bin zum Beispiel folgende Dinge anders angegangen:

- Die VM ist insgesamt 24 GB groß, davon entfallen 8 GB auf die Partition mit ArcaOS 5.01 und 16 GB auf die für den Warp Server
(zunächst waren davon 2GB genutzt, im weiteren Verlauf habe ich die Partition nun auf 8GB "hochgeklont" am Ende soll sie dann
16GB groß sein)

- Ich habe versucht so viele Ordner vom Startlaufwerk (wie z.B. Bonuspak, Voicetype usw.) in das \APPS Verzeichnis zu
verschieben, das hat im wesentlichen sehr gut geklappt, sodass ich nun ein viel aufgeräumteres und schlankeres
Bootlaufwerk habe

- das läuft alles soweit schon sehr sehr gut, aber es fehlen noch einige Programme und zuvor möchte ich aber am "Feinschliff"
arbeiten.

- Ich verzichte übrigens auf den AN Package Manager, ebenso wie auf Dateien aus ArcaOS - außer selbstverständlich den
ohnehin in der AN Subsription separat erhältlichen Treibern. Ansonsten könnte ich ja gleich ArcaOS verwenden, was
tatsächlich hier auch recht gut seinen Dienst tut.

Wenn Interesse bestehen sollte, füge ich den detaillierten Erstellungsprozess bisher hier gerne ein.

Es haben sich nun mehrere "Probleme" ergeben, bei denen ich Euch gerne um Rat fragen möchte, dies aber in einem separaten Thread, da die Fragen hier evtl. untergehen. Vielen Dank schon einmal für Eure Mühen!
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » Fr 4. Aug 2017, 10:53

Hier mal wieder ein paar Bilder vom aktuellen Stand (4.8.2017) - noch befindet sich das System im Aufbau in der VM :)

Es funktioniert bisher alles im wesentlichen reibungslos, ein paar kleinere Unebenheiten werden ja mit Eurer Hilfe in einem separaten Thread ausgebügelt! Ich bin schon sehr gespannt, wenn ich den Klon das erste Mal dann auf die "reale" Hardware bringe ;)


-> als aktuellstes Internetprogramm (kein YUM/RPM installiert) dient derzeit der Firefox 17 - und macht seine Sache gut:

WSeBFF.png



-> Youtube Videos müssen zwar manuell kurz beim ersten Aufruf gestoppt werden, laufen dann aber flüssig inkl. Ton (Flash 0.4.2 installiert)

WSeBYT.png



-> Die Multimediakomponenten verrichten klaglos ihren Dienst:
-> Internetradio Stream und MP3 mit PM123
-> MP4 Videos mit dem SM Player 0.8.2.1 (neuere Versionen scheitern hier noch)

WSeBMM.png


-> Die Netzwerkunterstützung ist sehr weit:
-> Der Warp Server startet klaglos
-> Es steht auch der Novell Netware Client 2.12 zur Auswahl
-> der Samba Client ist ebenfalls installiert
-> ebenso das NDFS Plugin
-> hier soll dann noch der Samba Server ergänzt werden

WSeBNETZ.png


-> Das System an sich macht insgesamt eine Riesenfreude, schnell und (bisher) wenig absturzfreudig (= gar nicht)

WSeBDIV.png


Ich werde weiter berichten ;)
Zuletzt geändert von Sigurd am Fr 4. Aug 2017, 10:59, insgesamt 2-mal geändert.
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » Fr 11. Aug 2017, 08:18

Auch hier bin ich im wesentlichen fertig. Jetzt steht die Verknüpfung der beiden Hard-und Software an :)

Eingefangen001a.png


Eingefangen002.png
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » So 12. Nov 2017, 18:01

So, es hat zwar etwas gedauert, aber nun ist er drauf :lol:

Heute war der Umzug meines "30 Jahre Klons" auf den Maximum Warp PC 2017. An diesem Klon habe ich genau drei Wochen gebastelt, auf dem X200T konnte ich mit Hilfe der zugehörigen Dockingstation und einiger BIOS Einstellungen den Warp Server for e-Business nativ installieren und habe diesen dann danach Schritt für Schritt upgedated bzw. ergänzt.

Insbesondere die Kernel und PM Dateien von Holger Veith erlauben einige schöne Sachen:

Zum Beispiel : SNAP und 8 Kerne... Seht selbst:
Meine Oberfläche:

MaximumWarp1.png


SNAP und die 8 Kerne:

MaximumWarp2.png


Ein Haufen Programme und Dienstprogramme:

MaximumWarp3.png


Ein Haufen "System"

MaximumWarp5.png


Trotzdem ein geordnetes Laufwerk C sowie eine geordnete config.sys:

MaximumWarp6.png


Noch etwas Feintuning ist notwendig und dann schaue ich mal nach dem Rest 8-)

EDIT: Sorgen bereitet im Moment noch WINOS2, DOS läuft ohne Probleme.
Zuletzt geändert von Sigurd am So 12. Nov 2017, 19:55, insgesamt 1-mal geändert.
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » So 12. Nov 2017, 20:21

An Netzwerkfunktionen mangelt es momentan auch nicht, auch wenn noch nicht alles perfekt eingerichtet ist.

MaximumWarp4.png


Es bleibt zu tun:

- Firefoxy und Thunderbird von Version 17 auf aktuellere Versionen erhöhen
- CUPS installieren
- WINOS2 ans Laufen bringen
- Feintuning
- zu vermeiden versuche ich YUM/RPM - nicht aus Überzeugung sondern Nostalgie ;)

Bis demnächst mal wieder.
Zuletzt geändert von Sigurd am So 12. Nov 2017, 20:23, insgesamt 1-mal geändert.
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
wilfried
Beiträge: 538
Registriert: Mo 23. Dez 2013, 18:26
Wohnort: Barsinghausen
Kontaktdaten:

Beitragvon wilfried » Mo 13. Nov 2017, 19:45

Hallo Sigurd,

SUPER!
Da fehlt ja nur noch DB2/2 ;)
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » Mi 15. Nov 2017, 08:04

Vielen Dank, Wilfried!

Ein weiteres Problem konnte gelöst werden: WINOS2 funktioniert sowohl im Vollbild als auch im Fenster. Mit dem SNAP und er X600 wunderbar flüssig und schnell.

Ursache für den Absturz war wohl eine Zeile in der System.ini, die auf dem X200T Klon auf das Laufwerk D: verwies (für die Datei SWAP386 (oder so ähnlich) und ich dann auf Laufwerk C geändert habe.

Wie dem Bild zu entnehmen ist, habe ich auch weitere Anpassungen des Klons an die tatsächliche Hardware des PCs vorgenommen:

- die CMedia Soundkartentreiber von Sander van Leuwen sind für die PCI Soundkarte installiert. Schon ein "geiler" Klang bei 5.1 Boxen, auch wenn "nur" 4.1 angeboten werden :)

- die OnBoardnetzwerkarte ist eingebunden und funktioniert tadellos (mit MMRE Treiber aus dem Arca Noae Paket - alle Treiber sind ja im Klon selbst mit vorhanden)

MaximumWarp7.png


WINOS2 mit 8 Kernen - das ist schon witzig.

Nun geht es noch an die weiteren Details.
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
Sigurd
Beiträge: 483
Registriert: Mo 23. Dez 2013, 08:35
Kontaktdaten:

Beitragvon Sigurd » Sa 18. Nov 2017, 20:21

Es ist einfach schön, wenn endlich mal alles wieder funktioniert, zwar nicht hundertprozentig fehlerfrei, aber schon nahe dran.

VirtualPC MIT "Gemeinsamen Ordnern", Ton, Netzwerk und OHNE Grafikfehler....

MaximumWarp10.png


Und VoiceType Navigation und Dictation....

MaximumWarp11.png


Wird Zeit den Klon auf 16Gb zu erweitern.... 8-) :lol:
OS/2 versus Hardware - Maximum Warp!
Benutzeravatar
ak120
Beiträge: 719
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Mo 20. Nov 2017, 13:14

Sigurd hat geschrieben:Ein Haufen Programme und Dienstprogramme:

Notes 4.1 ist nicht gerade das Maximum oder Optimum. Für verbreitete Anwendungen stellt Version 4.5 m.E. schon das absolute Minimum dar. Die Optimierung für Mehrprozessorsysteme kam erst mit Version 4.6 oder dem späteren Domino R5 serverseitig zur Geltung. Trotzdem war's eine der wenigen Killerapplikationen (siehe www.killerapplikation.de) für OS/2.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste