Probleme mit hoher IRQ-Last an CPU

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
mmolthagen
Beiträge: 2
Registriert: Sa 5. Mär 2016, 09:30

Probleme mit hoher IRQ-Last an CPU

Beitragvon mmolthagen » Fr 8. Sep 2017, 10:59

Hallo,

eigentlich von dem Moment an, seitdem ich ArcaOS 5.01 auf meinem Notebook installiert habe, habe ich (unter anderem...) ein Problem, das recht schwerwiegend ist:

Immer wieder kommt es vor, dass die IRQ-Last von CPU0 (von CPU1-3 wird keine IRQ-Last in XWPs Pulse-Widget angezeigt, nur die jeweilige Benutzerlast) dauerhaft auf mindestens 85 % steigt und bis zu einem Neustart bleibt. Das geschieht immer nach einigem Netzwerkverkehr (egal ob mit Firefox, Thunderbird, ArcaMapper oder was sonst).

Zuerst tauchte das Phänomen auf, als ich recht bald nach der Installation von ArcaOS 5.01 NetDrive 3.1.6 installiert habe. Nach einer Deinstallation und der Wiederherstellung eines Archivs vor der ND-Installation war Ruhe. Weil ich aber ND verwenden wollte, habe ich kurzerhand die Einträge von ArcaMapper (das keine Probleme verursachte) in C:\Programs\NDFS gesichert und nach der Installation von ND 3.1.6 zurückgespielt. So (und nach einem Zurücksetzen auf das jüngste Archiv) lief dann auch NetDrive ohne Probleme.

Jedoch kommt es immer wieder vor, meist nach irgend einer Änderung am System (gestern nach der Verkleinerung einer Linux-Parition, um dafür unter ArcaOS eine weitere JFS-Partition für Daten einzurichten), dass nach einigem Netzwerkverkehr die IRQ-Last der CPU ansteigt und nur durch einen Reboot korrigiert werden kann. Bisher half es immer, das System einfach auf das jüngste Archiv zurückzusetzen - bis ich heute morgen das neue ACPI-Update von Arca Noae installiert habe (3.23.07). Seitdem bringt das Zurücksetzen auf das jüngste Archiv nichts mehr; nach etwas Netzwerkverkehr (es reicht der Aufruf einer Website in Firefox oder eines SMB-Verzeichnisses in ArcaMapper) steigt die IRQ-Last auf mindestens 85 %, und es fließen kaum noch Daten durch das Netzwerk (kein Aufruf einer zweiten Seite im Firefox mehr möglich), das System wird etwas träger.

Irgend eine Idee, was die hohe IRQ-Lust bei der CPU verursacht? Installiert ist wie gesagt ArcaOS 5.0.1 mit allen bisher veröffentlichten Updates, außerdem NetDrive 3.1.6 (allerdings mit den bei ArcaOS 5.0.1 mitgelieferten Dateien von ArcaMapper in C:\Programs\NDFS) zzgl. Plugins für SMB (ArcaMapper), SFTP und WebDAV), Firefox, Thunderbird, SeaMonkey (jeweils in den bei ArcaOS 5.0.1 mitgelieferten Versionen).

Es ist ein etwas älteres Sony-Vaio-Notebook mit 4 Kernen, die ArcaOS auch beim Starten initialisiert und die im Pulse-Widget angezeigt werden, wobei die IRQ-Last nur für CPU0 angezeigt wird. Für die Grafik wird Panorama verwendet.

Was ich gerade gesehen habe: Auch ohne Netzwerkverkehr im Vordergrund ist vor einer Weile die IRQ-Last stark angestiegen. Als ich den "OS/2 SMP Monitor" (CPU Monitor) gestartet habe, um mir dessen Ausgaben näher anzusehen, ist die Last allerdings kurz auf wenige % gesunken - und dann, als ich im Monitor auf BAR-Anzeige umschalten wollte, ist OS/2 eingefroren. Auch STRG-ALT-ENTF blieben ohne Reaktion.

Update: Ich habe BASEDEV=APM.ADD in der CONFIG.SYS auskommentiert, und seitdem läuft ArcaOS, ohne dass bei Netzwerkverkehr die IRQ-Last ansteigt.

Update 10.09.: Leider hat diese Lösung nur bis zum nächsten Tag gehalten - seitdem wieder die gleichen Probleme. Ich habe daraufhin ArcaOS gestern neu installiert, dazu nur die Updates und die nötigsten Programme. Bisher noch keine Probleme.


Danke schon einmal für alle Hinweise,

Grüßle

Michael Molthagen
Zuletzt geändert von mmolthagen am So 10. Sep 2017, 09:24, insgesamt 3-mal geändert.

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste