BS_Info von Rolf Gachnang

(DE) Neuigkeiten zu den Themen OS/2, eCS, und dem OS/2-Forum
(EN) News about OS/2, eCS and the OS/2 Forum
Benutzeravatar
ARoederer
Beiträge: 268
Registriert: Fr 27. Dez 2013, 17:25
Wohnort: Hamburg / Germany
Kontaktdaten:

BS_Info von Rolf Gachnang

Beitragvon ARoederer » Di 14. Jan 2014, 21:44

Moin

Rolf hat am 14.01.2014 die Version 1.5 seines Tools BS_Info freigegeben.

BS_Info zeigt Infos über euer OS/2-, oder eCS-System und ermöglicht den direkten Zugriff auf einige Konfigurationsprogramme.

Neu in dieser Version:
  • Infos zu Festplatten, CD/DVD... nun auch via OS2AHCI und nicht nur S506
  • Dialog-Grösse lässt sich verändern (inkl. Speicherung letzter Zustand)
  • Kapazitäten von Laufwerke mit Dateisystem UNKNOWN werden nicht mehr angezeigt.
  • Papierkorb löschen verbessert
  • PSTAT Schriftgrösse erhöht
  • Verbessung beim Ermitteln der temp-Grösse inkl. Anzeige Anz Files
  • neue Infos zu Datum/Zeit, CPU...
  • Falsche Infos zum Desktop-Hintergrund entfernt (da in EAs definiert)
  • Info Archives: Probleme wenn System nicht auf Drive C: behoben
  • diverse optische Anpassungen / Erweiterungen (u.a. schnellere Darstellung, Übersetzung...)
Download

Andreas
Benutzeravatar
hanno
Beiträge: 55
Registriert: Do 9. Jan 2014, 22:20

Beitragvon hanno » Mi 15. Jan 2014, 09:05

Coole Änderungen, cooles Programm. :D
Es ersetzt bei mir SysInfo (und natürlich auch "Hardware Manager etc.)
rbm
Beiträge: 20
Registriert: Do 2. Jan 2014, 16:45

Beitragvon rbm » Mi 15. Jan 2014, 16:31

Ich habe das mal unter MCP2 ausprobieren wollen.
BS_Info startete und zeigte die erste Karteiseite.
Dann poppte ein Fenster auf mit der Meldung

Ini-File kann nicht geöffnet werden. at $0001050A !
Programm beenden?

Nach Bestätigen mit Ja kam noch

Exception occurred: Ini-File kann nicht geöffnet werden. at $0005B9B3 !
Programm is terminated.

Funktioniert das Programm nur unter eCS oder fehlt bei meiner Konfiguration etwas?

Eine Untersuchung der BS_Info.exe mittels PMDLL2.11 zeigte nichts ungewöhnliches.
Benutzeravatar
ARoederer
Beiträge: 268
Registriert: Fr 27. Dez 2013, 17:25
Wohnort: Hamburg / Germany
Kontaktdaten:

Beitragvon ARoederer » Mi 15. Jan 2014, 17:33

Moin

Funktioniert auch unter MC2.
Ich leite das mal an Rolf weiter.

Andreas
Benutzeravatar
Frank Wochatz
Beiträge: 777
Registriert: So 22. Dez 2013, 22:04
Wohnort: Berlin
Kontaktdaten:

Beitragvon Frank Wochatz » Mi 15. Jan 2014, 17:50

Schön gemacht, das Programm! (Fast) alles unter einer Haube. Danke @Rolf, falls Du hier mitliest.
Werner.S
Beiträge: 76
Registriert: Mo 23. Dez 2013, 11:29
Wohnort: Nürnberg

Beitragvon Werner.S » Mi 15. Jan 2014, 21:07

Bei mir läufts wunderbar, danke
Benutzeravatar
ARoederer
Beiträge: 268
Registriert: Fr 27. Dez 2013, 17:25
Wohnort: Hamburg / Germany
Kontaktdaten:

Beitragvon ARoederer » Do 16. Jan 2014, 01:07

Moin
rbm hat geschrieben:Ini-File kann nicht geöffnet werden. at $0001050A !
Programm beenden?

Rolf Gachnang hat geschrieben:Betr. Fehlermeldung hab ich mal nachgeschaut.
Ich hab da keinen Einfluss, da dies beim autom. Laden von os2.ini, os2sys.ini oder bs_info.ini geschehen muss.
Irgendwie wird die ini nicht gefunden... ?
Werd das wohl schwerlich nachvollziehen können.
Ich könnt höchstens noch im Source den Filenamen bei der Error-Msg einbauen, damit das Problem eingeschränkt wird.

Andreas
rbm
Beiträge: 20
Registriert: Do 2. Jan 2014, 16:45

Beitragvon rbm » Do 16. Jan 2014, 12:02

Ergänzung zu meiner Fehlermeldung:

Ich verwende Wechselplatten; bei Verwendung von eCS 2.2 beta II statt MCP2/ACP2 funktioniert BS_Info 1.5 einwandfrei.
Benutzeravatar
Rolf
Beiträge: 18
Registriert: Mi 15. Jan 2014, 21:58
Wohnort: Rapperswil / Jona (Switzerland)

Beitragvon Rolf » Do 16. Jan 2014, 15:59

Betreffend Fehlermeldung

Ich hab das Pgm so angepasst, dass zur Fehlermeldung noch das entsprechende File angezeigt wird.
So lässt sich das Ganze eingrenzen bzw. ggf lösen.
http://www.bausys.ch/files/bs_info_1_6_beta.wpi

Mit Gruss aus der Schweiz
...und vielem Dank für all die Blumen ;)

Rolf
GerhardB
Beiträge: 7
Registriert: Fr 24. Jan 2014, 12:22

Beitragvon GerhardB » Fr 24. Jan 2014, 12:42

Ich habe das Programm von Rolf Gachnang unter ECS Beta 1 installiert, wo es hervorragend läuft.
Der Versuch die Version 1.5 als auch 1.6 unter ECS 2.1 zu betreiben schlägt fehl. Das Programm baut den Startbildschirm auf und stürzt nach ca. 5 Sekunden mit der folgenden Fehlermeldung ab.

ACCESS VIOLATION EXCEPTION EGP Fault occured at CS:EIP=$0000005B:$2054532D at $2054531

Nach dem Beenden des Programms kommt noch die Meldung:

EXCEPTION occured; Access violation exception (EPGFault) occured
at CS:EIP=$0000005B:$2054532D at $0005B9E2
Program is terminated

Ich kann mit diesen Meldungen leider nichts anfangen. Vielleicht sagt es dem Author mehr.

Vielen Dank und Mfg
Benutzeravatar
Rolf
Beiträge: 18
Registriert: Mi 15. Jan 2014, 21:58
Wohnort: Rapperswil / Jona (Switzerland)

Beitragvon Rolf » Sa 25. Jan 2014, 12:22

Starte das Programm mit dem Parameter -debug
Es wird dann im Programmverzeichnis ein bs_info.err erzeugt.
Maile mir das Ding nach roga24@bausys.ch und ich kann dann besser versuchen herauszufinden wo es klemmt.

mit Gruss
Rolf
Benutzeravatar
ARoederer
Beiträge: 268
Registriert: Fr 27. Dez 2013, 17:25
Wohnort: Hamburg / Germany
Kontaktdaten:

Beitragvon ARoederer » Mi 9. Sep 2015, 02:07

Moin

Rolf hat am 07.09.2015 die Version 1.6 seines Tools BS_Info freigegeben.

BS_Info zeigt Infos über euer OS/2-, oder eCS-System und ermöglicht den direkten Zugriff auf einige Konfigurationsprogramme.

Neu in dieser Version:
  • Zusätzliche Infos zu diversen installierten Applikationen und/oder Treibern
    (ACPI, ArcView, Audio, cups, DaniS506, Flash Plugin, gcc, java, libc, odin, Samba, WarpIN,Yum)
  • Speichern von Infos in die Zwischenablage
  • diverse optische Verbesserungen

Download

Andreas
Benutzeravatar
ARoederer
Beiträge: 268
Registriert: Fr 27. Dez 2013, 17:25
Wohnort: Hamburg / Germany
Kontaktdaten:

Beitragvon ARoederer » Do 14. Jul 2016, 03:26

Moin

Rolf hat am 13.07.2016 die Version 1.7 seines Tools BS_Info freigegeben.

Neu in dieser Version:
  • optische Anpassungen
  • Erweiterungen
  • zusätzlich Programmaufrufe

Download
Benutzeravatar
ARoederer
Beiträge: 268
Registriert: Fr 27. Dez 2013, 17:25
Wohnort: Hamburg / Germany
Kontaktdaten:

Beitragvon ARoederer » Do 12. Okt 2017, 21:08

Moin

Rolf hat am 05.10.2017 die Version 2.0 seines Tools BS_Info freigegeben.

Neu in dieser Version:

  • Anpassung an ArcaOS
  • zusätzliche Infos
  • Auslagerung diverser Routinen in eine dll
  • kleinere Fehlerbereinigungen
  • verbesserte Suche

Download
Zuletzt geändert von ARoederer am Do 12. Okt 2017, 21:08, insgesamt 1-mal geändert.
Benutzeravatar
ak120
Beiträge: 703
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Fr 13. Okt 2017, 14:16

ARoederer hat geschrieben:Neu in dieser Version:

Schön wäre es gewesen, wenn es auch noch funktionieren würde und sich nicht gleich reproduzierbar nach dem Start verabschieden würde. Dabei sind die sinnlosen Systemfehler durch das Abklappern von Wechseldatenträgern noch das kleinere Problem.
Dateianhänge
bsinfo20.png
bsinfo20.png (7.88 KiB) 269 mal betrachtet
Werner.S
Beiträge: 76
Registriert: Mo 23. Dez 2013, 11:29
Wohnort: Nürnberg

Beitragvon Werner.S » Fr 13. Okt 2017, 15:50

Danke Rolf
Läuft super unter ArcaOs
Benutzeravatar
Rolf
Beiträge: 18
Registriert: Mi 15. Jan 2014, 21:58
Wohnort: Rapperswil / Jona (Switzerland)

Beitragvon Rolf » Sa 14. Okt 2017, 10:59

ak120 hat geschrieben:Schön wäre es gewesen, wenn es auch noch funktionieren würde und sich nicht gleich reproduzierbar nach dem Start verabschieden würde. Dabei sind die sinnlosen Systemfehler durch das Abklappern von Wechseldatenträgern noch das kleinere Problem.

Auf Grund dieser Angaben ist für mich ein Nachvollziehen nicht möglich.
Du könntest aber das Programm mit der Option -debug starten und mir die bs_info.err mailen.
Ich vermute bei Dir mal ein Problem bei der Suche nach lucide.exe (she Statuszeile)
Ich lese zuerst mal den Eintrag \HINI_USER_PROFILE\Lucide\Path. Falls sich lucide.exe dort nicht befindet, suche ich in den Verzeichnissen gemäss config-Definitionen (SET PROGRAMS, SET OSDIR...).
Benutzeravatar
Rolf
Beiträge: 18
Registriert: Mi 15. Jan 2014, 21:58
Wohnort: Rapperswil / Jona (Switzerland)

Beitragvon Rolf » Sa 14. Okt 2017, 11:01

Werner.S hat geschrieben:Danke Rolf
Läuft super unter ArcaOs

bitte, gerne geschehen Werner

Möchte mich an dieser Stelle bei allen bedanken, die mir aktiv in den letzten Wochen entsprechende Infos zukommen liessen um es ArcaOS-tauglich (bzw. AHCI unter AMD) zu machen.
Benutzeravatar
ak120
Beiträge: 703
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Mo 16. Okt 2017, 14:39

Rolf hat geschrieben:
ak120 hat geschrieben:Schön wäre es gewesen, wenn es auch noch funktionieren würde und sich nicht gleich reproduzierbar nach dem Start verabschieden würde. Dabei sind die sinnlosen Systemfehler durch das Abklappern von Wechseldatenträgern noch das kleinere Problem.

Auf Grund dieser Angaben ist für mich ein Nachvollziehen nicht möglich.
Du könntest aber das Programm mit der Option -debug starten und mir die bs_info.err mailen.

Leider ist in der beigefügten Textdatei keine E-Mail-Adresse angegeben, daher kann ich die besagte Datei hier nur anhängen.

Ich vermute bei Dir mal ein Problem bei der Suche nach lucide.exe (she Statuszeile)
Ich lese zuerst mal den Eintrag \HINI_USER_PROFILE\Lucide\Path. Falls sich lucide.exe dort nicht befindet, suche ich in den Verzeichnissen gemäss config-Definitionen (SET PROGRAMS, SET OSDIR...).

Das klingt nachvollziehbar. Die Umgebungsvariablen PROGRAMS und OSDIR sind auf keinem meiner Systeme deklariert. Folglich kann diesen auch kein Ausdruck zugewiesen sein. Mir ist nicht bekannt, welche Drittprogramme diese Variablen verwenden oder benötigen. Falls BS_INFO darauf angewiesen sein sollte, wäre es hilfreich, einen ensprechenden Hinweis in der Info-Textdatei zu geben oder diese Voraussetzung durch das Installationsskript zu schaffen.
Dateianhänge
BS_Info.err.txt
(4.6 KiB) 17-mal heruntergeladen

Zurück zu „OS/2 & eCS - News“



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast