Xcenter und Tame

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Xcenter und Tame

Beitragvon Damon » Mo 19. Jun 2017, 11:30

Ich bin dabei, meine alten OS/2 Programme und ArcaOS einzurichten. Dabei habe ich mit Tame/2 folgendes Problem:

Zunächst viel mir auf, daß ArcaOS nicht über emx verfügt, also letzte Version nachinstalliert. Tame installiert: Funktioniert! Aber nach dem nächsten Start von ArcaOS fehlten alle am rechten Rand von XCenter plazierten Widgets, also das usb-widget und das Datums-widget. Wiederherstellen ließen sie sich nicht. Also Wps-Sicherung eingespielt - Widgets wieder da. Tame nochmals installiert - Widgets wieder weg.

Ich vermute, daß es am usbresmg.sys, der ja von Tame mitinstalliert wird, liegt. Weiß jemand eine Lösung?
Benutzeravatar
ak120
Beiträge: 687
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Mo 19. Jun 2017, 13:28

Damon hat geschrieben:Ich vermute, daß es am usbresmg.sys, der ja von Tame mitinstalliert wird, liegt. Weiß jemand eine Lösung?


Das ist höchstwahrscheinlich unwahrscheinlich. Aber wenn man wirklich meint, daß es am USBRESMG.SYS liegen würde, braucht man es doch überhaupt nicht erst zu installieren. Die von SANE u.U. genutzte Bibliothek USBCALLS.DLL früheren Datums wäre m.E. schon deutlich verdächtiger. Ansonsten die üblichen Prozeduren anwenden, also CONFIG.SYS auf hinzugefügte Einträge prüfen und Pfadangaben ggf. korrigieren.
Werner.S
Beiträge: 73
Registriert: Mo 23. Dez 2013, 11:29
Wohnort: Nürnberg

Beitragvon Werner.S » Mo 19. Jun 2017, 21:34

Du solltest nur EINE USBCALLS.DLL im Pfad haben.
Bei mir im d:\os2\dll Verzeichnis.
usbcalls.jpg
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » Mo 19. Jun 2017, 23:43

Hallo zusammen!

Ja, die usbcalls.dll ist im Pfad OS2/dll, aber im Tame-Verzeichnis ist auch eine, und zwar älteren Datum. Werde diese also aktualisieren.

Danke für den Tipp!
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » So 25. Jun 2017, 16:38

Nun habe ich alles versucht: dlls von Tame durch die von ArcaOS ersetzt. Tame reagiert nicht, killt aber die widgets für usb und Zeit am rechten xcenter-Rand.

Mache ich etwas falsch oder läuft Tame eben nicht unter ArcaOS? Hat es jemand zum Laufen gebracht?

Die Version ist übrigens tame101c.
Benutzeravatar
ak120
Beiträge: 687
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » So 25. Jun 2017, 17:41

Damon hat geschrieben:Mache ich etwas falsch oder läuft Tame eben nicht unter ArcaOS? Hat es jemand zum Laufen gebracht?

Die Version ist übrigens tame101c.


Wenn irgendetwas unter ArcaOS nicht läuft, sollte es wohl besser bei Arca Noae behandelt werden.

Aber da es wohl dort null Unterstützung geben wird:
Vielleicht sollte man nicht unbedingt mit solchen historischen Versionen von TAME/2 operieren, wenn es dafür keinen triftigen Grund gibt. Es wäre keine schlechte Idee, vorher mit einer weitaus aktuelleren Version (bspw. 1.05) das geschilderte Verhalten zu prüfen.
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » So 25. Jun 2017, 19:50

Würde ich ja gern, aber wo bekommt man die aktuellere Version (bspw. 1.05) ?
Werner.S
Beiträge: 73
Registriert: Mo 23. Dez 2013, 11:29
Wohnort: Nürnberg

Beitragvon Werner.S » So 25. Jun 2017, 20:26

Ich hab hier TAME/2 103 mit ARCAOS
Läuft!

Tame.jpg
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » So 25. Jun 2017, 20:36

Hallo Werner,

wo bekommt man es? Auf Hobbes finde ich nur Tame 101c?

Ich habe übrigens großen Ärger mit ArcaNoa. Heute will sogar Seamonkey nicht mehr starten: Can't load xpcom!

Gruß Damnon
Benutzeravatar
ak120
Beiträge: 687
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » So 25. Jun 2017, 21:33

Damon hat geschrieben:Würde ich ja gern, aber wo bekommt man die aktuellere Version (bspw. 1.05) ?


Die übliche Quelle:
http://os2ports.smedley.id.au/index.php?page=sane-for-os-2

Ich verwende zwar nur SANE, aber wenn es um USB-angeschlossene Geräte geht, wäre es einen Versuch wert.
Werner.S
Beiträge: 73
Registriert: Mo 23. Dez 2013, 11:29
Wohnort: Nürnberg

Beitragvon Werner.S » So 25. Jun 2017, 21:35

Hier:
http://hobbes.nmsu.edu/download/pub/os2 ... 16-os2.zip

Hab ich aber noch nicht probiert.
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » Mo 26. Jun 2017, 15:32

Danke für den Link zu Netlabs. Die Version 1.05 läuft! Allerdings killt auch sie die widgets am rechten Rand des XCenters. Time und IP-Monitor konnte ich wieder nachinstallieren, nicht aber das Remove-usb widget. Die zugehörige RemMedia. Dll ist im Verzeichnis aber noch vorhanden!

Weiß jemand Rat?
aschn
Beiträge: 553
Registriert: Mi 25. Dez 2013, 22:47
Kontaktdaten:

Beitragvon aschn » Mo 26. Jun 2017, 16:58

Damon hat geschrieben:Allerdings killt auch sie die widgets am rechten Rand des XCenters.

Das ist nicht normal. Dann ist es wohl an der Zeit die Inis zu bereinigen, am besten mit Checkini und Cleanini. Du kannst natürlich auch irgendwann, wenn alles einigermaßen läuft, neu installieren.
Andreas Schnellbacher
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » Mo 26. Jun 2017, 17:37

Ja, normal finde ich das auch nicht! Allerdings passiert das auf einem neu installierten System! Ich habe erst alle anderen Programme mit ArcaOS eingerichtet, eine WPS-Sicherung gemacht und dann erst Tame/2 installiert.
aschn
Beiträge: 553
Registriert: Mi 25. Dez 2013, 22:47
Kontaktdaten:

Beitragvon aschn » Mo 26. Jun 2017, 18:51

Du "eierst" doch schon eine ganze Weile mit dem System herum. Das kann so nicht sauber sein.
Andreas Schnellbacher
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » Mo 26. Jun 2017, 21:14

Hallo Andreas,

ja, was ArcaNoa verspricht, daß man nämlich mit den vorhandenen OS/2 Programmen einfach so weiterarbeiten könne, ist eine schöne Illusion.

Eigentlich wollte ich mit ArcaOS mein altes ecs2.1 ersetzen. Die erste Installation von ArcaOs habe ich mir dabei völlig zerschossen. Zuletzt startete nicht einmal mehr Seamonkey, wegen dem ich die ganze Aktion eigentlich unternommen hatte (ich kam mit dem dll-Chaos nicht zurecht!

Heute habe ich daher ArcaOS neu installiert. Jetzt läuft tatsächlich fast alles - eben bis auf das Remove-Widget, welches ich auch nach einem checkini nicht wieder habe zum Leben erwecken können.

Wenn man nur wüßte, wie dieses widget funktioniert, d. h. wovon es abhängig ist!
aschn
Beiträge: 553
Registriert: Mi 25. Dez 2013, 22:47
Kontaktdaten:

Beitragvon aschn » Mo 26. Jun 2017, 21:29

Wenn sich das reproduzieren lässt, dann wär das 'n Eintrag im AN-Bugtracker wert.
Andreas Schnellbacher
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » Di 27. Jun 2017, 08:43

Ja, ist es! Ich habe bei der ersten Installation Tame/2 mehrmals installiert und deinstalliert. Dabei jedesmal eine WPS-Sicherung eingespielt und immer wieder verschwanden die rechten Widgets. Ich werde es also mal an ArcaNoa melden. Vielleicht gibt es doch Abhilfe.
Andi B.
Beiträge: 365
Registriert: Di 24. Dez 2013, 16:40
Kontaktdaten:

Beitragvon Andi B. » Di 27. Jun 2017, 09:13

Ja, ist es! Ich habe bei der ersten Installation Tame/2 mehrmals installiert und deinstalliert.

Und welche dlls überschreibt die Tame Installation? Bzw. welche installiert Tame die dann vor den richtigen (in %UNIXROOT%/usr/lib) geladen werden? Den Punkt ( .; ) im Libpath schon mal hinter die UNIXROOT Verzeichnisse verschoben? Das Ganze stinkt doch nach falschen DLLs die, soweit ich deinen Erläuterungen folgen kann, nur durch das Tame Paket verursacht werden. Welche DLLs sind alle bei deiner Tame Installation dabei?
Benutzeravatar
ak120
Beiträge: 687
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Di 27. Jun 2017, 11:00

Andi B. hat geschrieben:Und welche dlls überschreibt die Tame Installation?

Gar keine.

Bzw. welche installiert Tame die dann vor den richtigen (in %UNIXROOT%/usr/lib) geladen werden? Den Punkt ( .; ) im Libpath schon mal hinter die UNIXROOT Verzeichnisse verschoben? Das Ganze stinkt doch nach falschen DLLs die, soweit ich deinen Erläuterungen folgen kann, nur durch das Tame Paket verursacht werden. Welche DLLs sind alle bei deiner Tame Installation dabei?

Ob das etwas in diesem Fall bringen würde? Ich verstehe nicht, was das Programm TAME.EXE mit dem XCenter zu tun haben soll. Es ist eine Anwendung welche mit Dr. Dialog erstellt wurde. Außer REXX, einigen zusätzlichen REXX-Funktionsbibliotheken wird nur der normale Präsentations-Manager und etwas SOM verwendet. Wo bitte werden die WPS oder daraus abgeleitete Objekte (abgesehen vom Leuchttisch-Ordner) überhaupt genutzt?
Andi B.
Beiträge: 365
Registriert: Di 24. Dez 2013, 16:40
Kontaktdaten:

Beitragvon Andi B. » Di 27. Jun 2017, 11:31

ak120 hat geschrieben:
Andi B. hat geschrieben:Und welche dlls überschreibt die Tame Installation?

Gar keine.


Und warum schreibt dann Damon oben "Ja, die usbcalls.dll ist im Pfad OS2/dll, aber im Tame-Verzeichnis ist auch eine,"? Ergo ist bei Damon's Tame Installation, und um diese geht es ja hier, zumindest eine alte/falsche dabei.

Ich bleib dabei, er hat ein dll durcheinander welches von der Ferne kaum nachvollziehbar ist. Er weiß aber ziemlich genau was er machen muss, damit er seine ArcaOS Installation zerschießt. Also sollte es für ihn relativ leicht sein, den Fehler (die falschen dlls) zu finden. Mein Posting sollte für Damon hilfreich sein die falschen dlls zu finden, oder zumindest unschädlich zu machen ( .; im Libpath). Erst wenn er dll Probleme ausgeschlossen hat, denk ich über andere nicht so naheliegende Fehlermöglichkeiten nach. Aber auch seine Aussage "Heute will sogar Seamonkey nicht mehr starten: Can't load xpcom!" ist ein weiteres starkes Indiz für ein dll Problem.
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » Di 27. Jun 2017, 11:48

Hallo Andy,

gewiß ist es ein dll-Problem. Das Zerschießen der Installation war sicher eine Folge der wiederholten WPS-Wiederherstellung. Danach waren die Widgets ja wieder da.

Jetzt habe ich die offenbar letzte Version von Tame (105) installiert und natürlich hat auch sie eine ältere usbcalls.dll. Nun habe ich diese einmal probeweise umbenannt, in der Hoffnung, Tame würde dann auf die usbcalls.dll von ArcaNoa im Verzeichnis OS2\dll zugreifen, aber da funktionierte Tame nicht mehr und die Widgets kamen auch nicht zurück.

Übrigens wird usb seitdem auch nicht mehr automatisch erkannt. Ich muß Refresh remouvable Media benutzen. Dafür dürfte ja wohl die usbcalls.dll verantwortlich sein - oder?

Nach der Neuinstallation von ArcaOS habe ich alle verfügbaren Paket-updates eingespielt. Doppelte dlls gibt es - außer - der usbcalls.dll von tame keine.

Übrigens steht tame nicht im path. Was ist also zu tun - ich bin ratlos.
Damon
Beiträge: 114
Registriert: So 27. Jul 2014, 16:50

Beitragvon Damon » Di 27. Jun 2017, 12:00

Nachtrag:

Ja, natürlich sind noch weitere dlls im Tame-Verzeichnis:

epkowa.dll
FastIni.dll
mehrere fax.dlls
jpeg.dll
libsane.dll
pcmaspi.dll
rexxutil.dll (davon existiert eine sogar ältere im OS2\dll - Verzeichnis
scanbmp.dll
tamebmp.dll
tiff.dll
usbcalls.dll
z.dll (auch diese existiert unter usr\lib

Also ich werde nochmals den Tipp mit dem Punkt im libpath ausprobieren!
Benutzeravatar
Wimpie
Beiträge: 49
Registriert: Sa 10. Jan 2015, 21:58
Wohnort: Uithoorn
Kontaktdaten:

Beitragvon Wimpie » Di 27. Jun 2017, 12:13

Hallo Damon,

I have eComStation 2.0 that comes with TAME version 1.0.5 installed an I can scan with my CanoScan LiDE210 USB scanner.

In D:\PROGRAMS\TAME there was a SCANIMAGE.EXE that is not compatible anymore with the latest USBCALLS interface.

I replaced it with SCANIMAGE.EXE from scanimage-20130525.zip.
Benutzeravatar
ak120
Beiträge: 687
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Di 27. Jun 2017, 17:49

Andi B. hat geschrieben:Und warum schreibt dann Damon oben "Ja, die usbcalls.dll ist im Pfad OS2/dll, aber im Tame-Verzeichnis ist auch eine,"? Ergo ist bei Damon's Tame Installation, und um diese geht es ja hier, zumindest eine alte/falsche dabei.

Das ist absolut nicht nachvollziehbar, weder TAME noch SANE installieren eine Datei namens USBCALLS.DLL. Man muß schon absichtlich die ältere USBCALLS-Komponente in WarpIN ausgewählt haben und installieren, wovon ich bereits zuvor abgeraten habe.

Ich bleib dabei, er hat ein dll durcheinander welches von der Ferne kaum nachvollziehbar ist. Er weiß aber ziemlich genau was er machen muss, damit er seine ArcaOS Installation zerschießt. Also sollte es für ihn relativ leicht sein, den Fehler (die falschen dlls) zu finden. Mein Posting sollte für Damon hilfreich sein die falschen dlls zu finden, oder zumindest unschädlich zu machen ( .; im Libpath). Erst wenn er dll Probleme ausgeschlossen hat, denk ich über andere nicht so naheliegende Fehlermöglichkeiten nach. Aber auch seine Aussage "Heute will sogar Seamonkey nicht mehr starten: Can't load xpcom!" ist ein weiteres starkes Indiz für ein dll Problem.

Letzteres kann auch daran liegen, daß noch ein Prozeß irgendeiner Mozilla-Anwendung aktiv ist, welchen man evtl. töten sollte.

Zurück zu „OS/2 & eCS - Apps“



Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste