Probleme mit QT4-Browsern: Dooble & Qupzilla

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
Benutzeravatar
Helmut Bu
Beiträge: 38
Registriert: Mo 6. Jan 2014, 14:02
Wohnort: Reutlingen

Probleme mit QT4-Browsern: Dooble & Qupzilla

Beitragvon Helmut Bu » Di 8. Dez 2015, 19:28

Obwohl ich genau nach Anleitung bei der Installation vorgegangen bin und via YUM die vollständige RPM Installation durchgeführt habe, gibt es leider Probleme:
  • Dooble startet nicht, sondern es kommt nur die Fehlermeldung: SYS0002: The system cannot find the file specified. "GCRYPT20".
  • Qupzilla behauptet bei einigen verschlüsselten Seiten "Keine vertrauenswürdige Verbindung" und kann die Seite dann nicht laden. Beispielsweise: https://meinaccount.gmx.net/
Kann mir da jemand einen Tipp geben...?!?
Helmut
_diver
Beiträge: 113
Registriert: Fr 27. Jun 2014, 10:57

Beitragvon _diver » Di 8. Dez 2015, 19:44

Helmut Bu » Di 8. Dez 2015, 19:28 hat geschrieben:Obwohl ich genau nach Anleitung bei der Installation vorgegangen bin und via YUM die vollständige RPM Installation durchgeführt habe, gibt es leider Probleme:
  • Dooble startet nicht, sondern es kommt nur die Fehlermeldung: SYS0002: The system cannot find the file specified. "GCRYPT20".
  • Qupzilla behauptet bei einigen verschlüsselten Seiten "Keine vertrauenswürdige Verbindung" und kann die Seite dann nicht laden. Beispielsweise: https://meinaccount.gmx.net/
Kann mir da jemand einen Tipp geben...?!?
Helmut

für den Qupzilla schau mal hier. http://trac.netlabs.org/qtapps/ticket/98

Gruss
Silvan
Benutzeravatar
ak120
Beiträge: 741
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Di 8. Dez 2015, 21:18

Die "Dokumentation" ist bei fast allen portierten Qt-Anwendungen unvollständig bis irreführend. Sicherlich benötigt man die von Silvan erwähnte DLL zum Austausch. Hier frage ich mich allerdings, wieso diese Datei auf dem FTP-Server im Unterverzeichnis qtapps versteckt wird, obwohl es sich hier um einen Teil der QT4-Laufzeitumgebung handelt? Aber darüber hinaus sind noch zusätzliche DLL-Dateien erforderlich: GPG-ERR0.DLL und wie der Meldung zu entnehmen ist GCRYPT20.DLL. Am besten also auf http://hobbes.nmsu.edu nach "gcrypt" suchen, dann bekommt man die entsprechenden ZIP-Archive libgcrypt-1.6.3.zip und libgpg-error-1.18.zip zum Herunterladen angezeigt. Man benötigt aus diesen Archiven nur die zuvor genannten Dateien welche sich im Pfad /usr/lib finden lassen sollten und kopiert diese am besten direkt ins Programmverzeichnis oder eine sonstige LIBPATH-Position.
_diver
Beiträge: 113
Registriert: Fr 27. Jun 2014, 10:57

Beitragvon _diver » Mi 9. Dez 2015, 15:02

ak120 » Di 8. Dez 2015, 21:18 hat geschrieben:Die "Dokumentation" ist bei fast allen portierten Qt-Anwendungen unvollständig bis irreführend. Sicherlich benötigt man die von Silvan erwähnte DLL zum Austausch. Hier frage ich mich allerdings, wieso diese Datei auf dem FTP-Server im Unterverzeichnis qtapps versteckt wird, obwohl es sich hier um einen Teil der QT4-Laufzeitumgebung handelt?

Ich habe die DLL nun im wiki der QT Apps auch hinzugefügt. Also sollte sie nicht mehr versteckt sein.

Gruss
Silvan
Benutzeravatar
Helmut Bu
Beiträge: 38
Registriert: Mo 6. Jan 2014, 14:02
Wohnort: Reutlingen

Beitragvon Helmut Bu » Mi 9. Dez 2015, 21:28

Prima, so klappt es! Dooble & Qupzilla laufen jetzt bei mir.

Vielen Dank für die schnelle Hilfe!!!
Helmut
Benutzeravatar
Prof. Knox
Beiträge: 47
Registriert: Mi 6. Aug 2014, 16:34

Beitragvon Prof. Knox » Fr 11. Dez 2015, 11:16

Helmut Bu » Di 8. Dez 2015, 19:28 hat geschrieben:Obwohl ich genau nach Anleitung bei der Installation vorgegangen bin und via YUM die vollständige RPM Installation durchgeführt habe, gibt es leider Probleme...

Bedauerlicherweise bekomme ich Qupzilla auch nicht zum Starten. Das ganze "geYUMe" ist installiert. System ist eCS 2.1 nativ. Andere QT-Anwendungen laufen. Leider bekomme ich weder eine Fehlermeldung noch finde ich einen Protokolleintrag. Es passiert einfach nichts.

Hat jemand eine Idee wo ich weitersuchen könnte?
Mit freundlichen Grüßen

Prof. Knox
Benutzeravatar
ak120
Beiträge: 741
Registriert: Do 8. Mai 2014, 12:50
Wohnort: Demmin
Kontaktdaten:

Beitragvon ak120 » Fr 11. Dez 2015, 16:27

Einstellungen LIBPATH überprüfen und einfach mal von der Befehlszeile aus starten, und sehen was passiert! YUM und RPM machen unter OS/2 letztlich nichts als Ärger, oder zumindest nicht das wofür diese Programme ursprünglich gedacht waren. Würde man nicht nur die Abkürzungen gebrauchen, sondern vom "Yellowdog Update Manager" und "Redhat Package Manager" sprechen, könnte fast jeder Benutzer die Fadenscheinigkeit bereits erahnen.

Kleiner Nachtrag:
Um Adblock auch für deutsche Seiten nutzbar zu machen, sollte man unter Optionen - Abonnement hinzufügen - Andere... aus der Liste wählen und dann "https://easylist-downloads.adblockplus.org/easylist.txt" eintragen.
Benutzeravatar
Prof. Knox
Beiträge: 47
Registriert: Mi 6. Aug 2014, 16:34

Beitragvon Prof. Knox » Mo 18. Jan 2016, 16:59

Hallo/2 Leute,

nachdem alles Suchen nichts gebracht hat, habe ich gestern mal YUM komplett neu aufgesetzt. Jetzt klappts auch mit Qupzilla. Weiß der Fuchs was ihm gefehlt hat.

Es scheint mir auch beinahe so, als ob wir Freunde werden könnten. Aber nur beinahe. Ich bekomme keine https-Seiten geöffnet. Noch nicht einmal eine Wikisuche bringt mehr als "keine vertrauenswürdige Verbindung". Hat jemand eine Ahnung was da im Argen sein könnte? Tatsächlich nicht vertrauenswürdige Seiten werden dagegen sofort geöffnet ;-(.

Noch eine Frage in anderer Sache. Ich suche ein Programm welches gespeicherte *.eml öffnet und nur diese Datei allein anzeigt. Der Donnervogel kann das natürlich, aber ich hätte gern etwas kleineres, schnelleres und vor allem stabileres. YUM ist ja mittlerweile drauf.

PS: der neue Arche-Noah-Paketmanager ging hier zum Clean-Install gut.
Mit freundlichen Grüßen

Prof. Knox
ajunra
Beiträge: 313
Registriert: Mo 23. Dez 2013, 06:40
Wohnort: Insel Rügen

Beitragvon ajunra » Mo 18. Jan 2016, 17:38

Hallo Prof.Knox,

Sieh Dir mal diesen Beitag hier im Faden an. Qupzilla ist nunmal eine QT4-Anwendung und die wird wohl den QTNet4-Fix-SSL benötigen.
Schöne Grüße von Deutschlands größter Insel
ajunra
Benutzeravatar
Prof. Knox
Beiträge: 47
Registriert: Mi 6. Aug 2014, 16:34

Beitragvon Prof. Knox » Mi 20. Jan 2016, 16:53

Hallo/2 Leute,
danke Ajunra,

so klappt es sehr schön. Natürlich hätte ich auch den Strang vom Anfang an lesen können... Ich bessere mich
Mit freundlichen Grüßen

Prof. Knox

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste