Erfahrungsaustausch: OS2 unter VirtualBox

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
User avatar
Frank Wochatz
Posts: 930
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Re: Erfahrungsaustausch: OS2 unter VirtualBox

Post by Frank Wochatz » Thu 31. Jan 2019, 15:25

Ich hab normale Mauszeiger, ohne Kometenschweif, das Verhalten ist genau das gleiche, ob ich nun Mausintegration benutze oder nicht. Und wie gesagt: "full window drag" flackert auch. Natürlich nur beim Ziehen, also während der Bewegung in Ruhe flackert da nichts.

aschn
Posts: 722
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Thu 31. Jan 2019, 18:21

erdmann wrote:
Thu 31. Jan 2019, 14:49
Ich habe hier kein Mausflackern, man sollte allerdings auch den "integrated mouse cursor" nehmen (also keine zwei getrennte Cursor für Host und VM).
Ich kann wie Frank keinen Unterschied zwischen dem VBox- und dem AMouse-Treier feststellen, was das Flackern angeht. Hier ist es auch ein kaum wahrenhmbares Flackern/Zittern/Ruckeln. Man sieht es nur, wenn man genau drauf achtet. Full Window Drag hab ich sowieso immer ausgeschaltet. Das ging bei mir mir in VMs aber noch nie brauchbar und verhält sich so, wie Frank es beschrieben hat. Das ist aber wahrscheinlich zum Testen gut geeignet.
Andreas Schnellbacher

User avatar
Frank Wochatz
Posts: 930
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz » Sat 9. Feb 2019, 10:40

Also als kaum wahrnehmbar würde ich das "Flackern" nicht bezeichnen. Mag sein, dass es andere Leute nicht stört. Ich würde das mal so beschreiben: unter Win oder nativen OS2 hat man das Gefühl, den Mauszeiger tatsächlich zu bewegen. Unter Vbox hat man das Gefühl, der Mauszeiger wird ständig gelöscht und in neuer Position neu gezeichnet, und das in einem sehr engen Raster. Es ist auch etwas schwierig, pixelgenaue Arbeiten mit der Maus durchzuführen. Und Os2 ist offenbar das einzige Gastsystem, bei dem das Problem auftritt.



Ein Detail, dass mir noch aufgefallen ist: der Beep (an den kleinen internen PC Speaker) wird nicht an den Host durchgereicht. Das ist aber soweit ich das recherchieren kann kein Bug, sondern schlichtweg nicht implementiert. Ist nicht ganz so wichtig, ist mir nur aufgefallen, weil ich sowas in Rexxscripten manchmal verwendet habe...


Ansonsten bin ich bislang sehr positiv überrascht, wie gut OS2 bzw. hier in dem Fall AN in der VBox läuft.

User avatar
thorolf
Posts: 366
Joined: Wed 25. Dec 2013, 16:14
Location: Rhein-Main

Post by thorolf » Mon 11. Feb 2019, 20:22

Frank Wochatz wrote:
Sat 9. Feb 2019, 10:40
Ansonsten bin ich bislang sehr positiv überrascht, wie gut OS2 bzw. hier in dem Fall AN in der VBox läuft.
naja, das tut es aber doch schon (fast) immer, früher war einfach wichtig IBMAPM, GRADD und den OS/2-Maustreiber zu verwenden und in jedem Fall auf ACPI, Panorama und AMouse zu verzichten.

Da ACPI in einer VM mit virtualisiertem BIOS, CPU, Chipsatz usw. sowieso keinen Sinn macht und man das auch für keinen Treiber braucht, lässt man es am besten weg. Und weil die virtuelle Hardware vollständig von einem "normalen" MCP2R unterstützt wird, braucht man (un)eigentlich auch kein eCS oder AN um OS/2 virtualisiert zu benutzen.

Für mich eine durchaus vernünftige Lösung, wenn man OS/2 noch für irgendwas braucht ...
Grüße,

Thorolf