Desktop-Problem

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
andreas
Posts: 179
Joined: Mon 30. Dec 2013, 19:55

Desktop-Problem

Post by andreas » Tue 24. Nov 2020, 14:05

Am Ende des Bootvorgangs (AN 5.06) habe ich immer wieder den gleichen Effekt:
Der Desktop baut sich nicht vollständig auf (meist erscheinen nur die Programm-bzw. Ordnersymbole, nicht aber das X-Center und die Toolbar). Dann bricht der Aufbau ab und es erfolgt ein erneuter Versuch,
den Desktop aufzubauen (pmshell.exe wird jedesmal mit einer neuen PID neu gestartet). Oft habe ich am Ende (nach ca. 5 od. 6 Wiederholungen) nur eine leere Fensterliste. Nach einer gewissen Wiederholungsrate (ich denke 5x) stoppt dann der Vorgang und ich muss mit STG-Alt-Entf neu booten. In nur etwa 30% der Fälle gelingt es mir, überhaupt einen Aufbau zu erreichen.
Die Ini-Dateien habe ich wiederholt gereinigt. Daran liegt es offenbar nicht.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Tue 24. Nov 2020, 15:06

andreas wrote:
Tue 24. Nov 2020, 14:05
Die Ini-Dateien habe ich wiederholt gereinigt. Daran liegt es offenbar nicht.
Doch mit Sicherheit. Teste mal mit alter Sicherung. Außerdem muss man bei dem, was checkini - > cleanini (oder unimaint) entfernt, schon Glück haben, den defekten Teil zu erwischen. Auch die anderen Werkzeuge (xfix, fpos, iconomize) können helfen.

Du könntest auch mal cleanini so konfigurieren, dass eher zu viel gelöscht wird. Alle Handles, für die Du Programmobjekte angelegt hast, brauchst aber auf jeden Fall. Ich hab mehrfach die Erfahrung gemacht, dass das Reduziren von 5 - 6 auf 2 - 3 Blöcke die Stabilität verbessern kann.

Wenn Du das nicht relativ schnell hinbekommst, dann ist es einfacher einen alten Desktop wieder herzustellen. Dann nächstes Mal die Inis regelmäßig ausdünnen.
Andreas Schnellbacher

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Tue 24. Nov 2020, 16:41

Vielleicht mag ein Blick zurück in diesen Thread helfen? Jedenfalls hatte mir neulich der dortige Trick mit den "ActiveHandles" (+Unimaint) mal sehr geholfen, die INIs wieder zu reinigen.
Ob obendrein eventuell XWorkplace - bzw. spezielle Einstellungen - querschießt, keine Ahnung...

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Tue 24. Nov 2020, 23:22

Kam mir doch bekannt vor ... Auch 4 Blöcke sind zu viele. Da darf dann ja nichts mehr dazukommen. 2 - 3 sollte das Maximum nach dem Bereinigen sein. Zur Not ausprobieren. Sicherung der Laufwerke sollte natürlich vorhanden sein.

Zum Umstellen der ActiveHandles: Nachdem ich in der Zwischenzeit mal wieder Probleme mit der WPS hatte (regelmäßige Mozilla-Abstürze), hatte ich das noch 2 mal probiert: ohne Erfolg. Ich musste dann tatsächlich alte automatisch gesicherte Inis von IFX (oder dem eCS-Vorgänger) oder XWP wiederherstellen. Die waren noch am neuesten. Seit einigen Monaten hab ich auf anderem System neu installiert. Die Handles sind nach der Bereinigung immer wieder auf 2 Blöcke reduziert worden.

Ich hatte dabei auch den Verdacht, dass XWP den AvtiveHandles-Wert unter bestimmten Umständen umstellt, kann mich aber nicht mehr an Details erinnern. Zum Suchen im Quellcode bin ich zu faul.
Zuletzt geändert von aschn am Tue 24. Nov 2020, 23:32, insgesamt 1-mal geändert.
Andreas Schnellbacher

andreas
Posts: 179
Joined: Mon 30. Dec 2013, 19:55

Post by andreas » Wed 25. Nov 2020, 13:13

Danke für die Antworten. Iconomize hatte ich noch nicht gekannt.
Ich denke, mein Problem ist wohl, dass ich zu viele Dateien und Programmobjekte auf dem Rechner habe.
Ich habe nunmehr mit FPos und xfix alle Ordner- und Dateiverzeichnisse gelöscht und nach nochmaligem
Durchlauf von Checkini und Cleanini mit Arcinstall die verschlankte Ini-Datei gespeichert, um sie so stets wieder einspielen zu können.

Mit Inimaint hatte ich übrigens ein Problem. Das hat mir fast sämtliche Programmsymbole auf dem Desktop zertört. Ich erinnere mich, dass ich vor längerer Zeit mit Inimaint schon Probleme hatte.

Allerdings ist die Pflege der Ini-Dateien schon etwas lästig. Gibt es eine Möglichkeit, zu verhindern, dass Ordner- bzw. Dateipositionen überhaupt jedesmal in der Ini-Datei gespeichert werden?
Zuletzt geändert von andreas am Wed 25. Nov 2020, 13:19, insgesamt 1-mal geändert.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Wed 25. Nov 2020, 14:46

andreas wrote:
Wed 25. Nov 2020, 13:13
Gibt es eine Möglichkeit, zu verhindern, dass Ordner- bzw. Dateipositionen überhaupt jedesmal in der Ini-Datei gespeichert werden?
Klar: Bei XWP ist das auf Desktop -> Prperties -> XShutdown, Save INI files: Do not save INIs at all.
Ohne XWP heißt der Punkt in etwa [x] Save Desktop.
Andreas Schnellbacher

andreas
Posts: 179
Joined: Mon 30. Dec 2013, 19:55

Post by andreas » Wed 25. Nov 2020, 16:45

danke, das hilft mir sehr. Denke, damit bekomme ich mein Problem in den Griff ;-)