Daten auf USB-Stick nicht erkannt

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
User avatar
LotharS
Posts: 479
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Daten auf USB-Stick nicht erkannt

Post by LotharS » Mon 27. Nov 2017, 14:00

Nun habe ich auf eCS 2.1 Lars' Treiber auf v.10.219 upgedated, in der Hoffnung, dass mein 16GB-Stick ebenfalls erkannt wird.

Der Stick ist lt. DFSee "no-LVM", hat 16GB und ist angeblich Fat32 formatiert (ich selbst habe nie daran formatiert o.ä.). Der Stick wandert hier überall erfolgreich umher, ausser nach OS/2ff.
Der Stick selbst wird von eCS erkannt und erhält einen Laufwerksbuchstaben, aber ein "dir"-Kommando darauf zeigt keine Daten an (es sind etliche darauf...). Was mache ich bloß falsch?

erdmann
Posts: 174
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Mon 27. Nov 2017, 15:29

Ganz einfach:

1) der USB Stick ist schon partitioniert (also eben nicht "large floppy")
2) wenn DFSee "no-LVM" meldet bedeutet dies, daß auf dem letzten Sektor des ersten Tracks dieses partitionierten Mediums eben keine LVM Info vorhanden ist.
Und damit sind OS2LVM.DMD/OS2DASD.DMD nicht in der Lage mit dem Stick was anzufangen. Sie vergeben noch einen Laufwerksbuchstaben damit man dann ggf. das Volume formatieren kann, das war es aber auch schon.

Also mittels DFSee LVM Info hinzufügen: im wesentlichen also einen Volume Namen, einen Partitionsnamen, einen Disknamen sowie ein Laufwerksbuchstabe (bzw. * für nächsten verfügbaren Laufwerksbuchstaben). Das gilt auch wenn man das Volume neu formatiert hat (auch das Formatieren fügt keine LVM Info hinzu).

Es ist leider wie es ist: bei einem partitionierten Medium muß OS/2 auf dem Datenträger "rumschreiben" um seine LVM info dauerhaft abzuspeichern. Da dies in einem Sektorbereich passiert der in keiner Datenpartition liegt sollte es keine Proleme mit Windows geben.
Sollte ...

Manchmal ist "large floppy" eben doch einfacher. Dann nämlich erzeugt (mein) USBMSD.ADD LVM info "on the fly" im Speicher und gaukelt dem OS vor es wäre ein partitioniertes Medium ...

User avatar
LotharS
Posts: 479
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Mon 27. Nov 2017, 16:30

erdmann wrote:Ganz einfach:
<...>
Also mittels DFSee LVM Info hinzufügen
Naja, habs gemacht, tat noch immer nicht.
Dann führte mich DFSee noch auf eine Warnung, die ich mit FixPBR reparieren sollte. Das zusätzlich hat offenbar gefahrlos geholfen.
Vielen Dank für Deine schnelle Hilfe :D