Neuer AN USB-Treiber v12.01

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
User avatar
MikeK
Posts: 244
Joined: Mon 23. Dec 2013, 13:51
Location: Potsdam

Neuer AN USB-Treiber v12.01

Post by MikeK » Sun 4. Aug 2019, 18:49

Hallo,
mit AOS5.0.4 ist auch ein neuer USB-Treiber von AN herausgekommen, der auch separat zum Download (bei vorhandener Subscription) steht.
Es soll sich um den ersten 32bittigen USB-Treiber von AN handeln, der später auch USB3 beinhalten soll.
(https://www.arcanoae.com/usb-driver-pac ... ion-12-01/)
Da auf meinem TP X200 Lars seine USB-Treiber die an die Dockingstation angeschlossene Tastatur und Maus nicht sicher erkennen, die von AN aber schon, habe ich heute den neuen 12.01 dort installiert. Vorher lief der 11.17 von AN.
Nach der Installation des neuen Treibers crashte mein FF (firefox-45.9.0.en-US.os2-i686-Sua2.zip), der eigentlich sehr stabil läuft, innerhalb von ca. 10 Minuten mehrmals. Nachdem ich USB zurück auf 11.17 downgraded hatte, läuft FF auch wieder wie gewohnt ohne Abstürze.
Grüße aus Potsdam,
Mike
Zuletzt geändert von MikeK am Sun 4. Aug 2019, 18:50, insgesamt 1-mal geändert.

erdmann
Posts: 288
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Mon 5. Aug 2019, 16:02

Vielen Dank für die Info. Du solltest bei AN einen Problem Report einkippen. Hier lesen die sowieso nicht mit.

User avatar
MikeK
Posts: 244
Joined: Mon 23. Dec 2013, 13:51
Location: Potsdam

Post by MikeK » Mon 5. Aug 2019, 16:56

erdmann wrote:
Mon 5. Aug 2019, 16:02
Vielen Dank für die Info. Du solltest bei AN einen Problem Report einkippen. Hier lesen die sowieso nicht mit.
Hab beim Mantis Bug-Tracker den Report eingestellt.
Mike

Guzzi
Posts: 91
Joined: Sat 20. Dec 2014, 00:26

Post by Guzzi » Wed 7. Aug 2019, 21:55

Vielleicht auch Lars melden wie und was es mit seine Treiber schief geht?

aschn
Posts: 833
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Wed 7. Aug 2019, 22:02

Hier der Link zu Mikes Eintrag.
Andreas Schnellbacher

User avatar
MikeK
Posts: 244
Joined: Mon 23. Dec 2013, 13:51
Location: Potsdam

Post by MikeK » Wed 7. Aug 2019, 22:16

Guzzi wrote:
Wed 7. Aug 2019, 21:55
Vielleicht auch Lars melden wie und was es mit seine Treiber schief geht?
Bin da mit Lars im Kontakt.
Mike

erdmann
Posts: 288
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Thu 8. Aug 2019, 21:44

Ich habe jetzt auch mal den 12.01 testweise probiert. Zuvor habe ich die USB audio Treiber aus der config.sys auskommentiert. Also war lediglich noch USBMSD.ADD als einziger USB Treiber aktiv der nicht in der 12.01 Lieferung dabei ist.
Nach dem Starten von Firefox ist das System zwar nicht abgestürtzt aber dafür kommentarlos eingefroren. Ich hab das zweimal versucht und beide Male war es das gleiche Ergebnis. Ich habe wieder meinen USB Treibersatz installiert und jetzt geht es wieder (inklusive USB audio).

Wenn dieser Treiber mit ArcaOS 5.0.4 problemlos zusammenarbeiten soll kann ich mir nur vorstellen dass es an dem von ArcaNoae modifizierten OS2KRNL version 14.201 liegen könnte weil das dann ja diesbezüglich der einzige Unterschied zwischen eCS 2.1 und ArcaOS wäre.
Zuletzt geändert von erdmann am Thu 8. Aug 2019, 21:45, insgesamt 1-mal geändert.

ehemaliger
Posts: 80
Joined: Wed 22. Nov 2017, 23:46

Post by ehemaliger » Thu 8. Aug 2019, 23:37

Ich kann mir für dieses Verhalten eigentlich nur zwei Ursachen vorstellen:

1.) Ein "Memory Corruption" Problem. Will heißen: der Treiber schreibt auf Speicherbereiche, die ihn nichts angehen.
2.) Der Treiber benötigt signifikant mehr Kernelspeicher. Will heißen: Virtualadresslimit zu hoch.

erdmann
Posts: 288
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Fri 9. Aug 2019, 07:55

Für mich stellt sich das so dar:
entweder man wechselt jetzt zu ArcaOS oder man bleibt auf dem ggw. Stand stehen. Nur wenn man komplett zu ArcaOS wechselt, hat man einen vernünftigen Anspruch auf Support.

User avatar
LotharS
Posts: 574
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Fri 9. Aug 2019, 15:22

erdmann wrote:
Fri 9. Aug 2019, 07:55
Für mich stellt sich das so dar:
entweder man wechselt jetzt zu ArcaOS oder man bleibt auf dem ggw. Stand stehen. Nur wenn man komplett zu ArcaOS wechselt, hat man einen vernünftigen Anspruch auf Support.
Wenn er aber den USB-Treiber mit gültiger OS/2-eCS-Treiber-Subscription einsetzt, müsste er schon daraus vernünftigen Support bekommen.
Für einen Bugreport wäre es jedenfalls sinnvoll, die Ergebnisse eines "testlog.exe usb" (?) für neuen und für vorigen Treiber mitzuliefern. Hatte auch meinem alten USB-Treiber-Report geholfen, damals ließ sich die noch testlog.cmd wenigstens so verfummeln, dass die Lars' Treiber verstand und als korrekt bewies...

Die ersten Unter-Versionen einer neuen Bauart stecken per se noch voller Bugs, egal ob Auto-, Flugzeug- oder Treiber-Software :)
"If it ain't broken don't fix it" ...
Der FF wäre für sich ein anderes Thema...

User avatar
ak120
Posts: 956
Joined: Thu 8. May 2014, 12:50
Location: Demmin

Post by ak120 » Sat 10. Aug 2019, 13:16

LotharS wrote:
Fri 9. Aug 2019, 15:22
Wenn er aber den USB-Treiber mit gültiger OS/2-eCS-Treiber-Subscription einsetzt, müsste er schon daraus vernünftigen Support bekommen.
Wo bekommt man ein ungültiges Abonnement? Ohne funktionierenden Vertrieb auf technische Unterstützung zu hoffen, scheint doch sehr phantasievoll.