Generell: Software und Warp 4.52

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
enchiriadis
Posts: 9
Joined: Mon 23. Sep 2019, 13:07

Generell: Software und Warp 4.52

Post by enchiriadis » Tue 11. Aug 2020, 19:42

Hallo zusammen,

nach etwas OS/2-Abstinenz hab' ich heute nochmal versucht, Firefox (diverse Versionsnummern) zu installieren.
Dann auch Leightweight.
Kurz: Die Programme, die keine Installationsroutine haben (wie z.B. die SmartSuite), bekomm' ich nicht an's Laufen.

- Paketmanager á la ArcaOS gibt's noch keinen,
- die Pfadanpassung in der config.sys bringt nichts, und
- dieses Detail aus mancher ReadMe:
"Create a WPS object for xyz"
hat vermutlich was mit den Datei-Einstellungen /Zuordnung und /Typ zu tun.
Versth's nur halb und komme nicht weiter.

Die Installation von Firefox ab Version 38 wird ohne Paketmanager offenbar gar nicht unterstützt, stand irgendwo?
Gilt das für alle "modernen" Programme?
Lässt sich ohne Port zu einem PM prinzipiell nichts installieren? Oder hab' ich'n Denkfehler?

Schöne Grüße und Dank für jede Idee!
:-)

Thomas

erdmann
Posts: 361
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Wed 12. Aug 2020, 08:33


enchiriadis
Posts: 9
Joined: Mon 23. Sep 2019, 13:07

Post by enchiriadis » Wed 12. Aug 2020, 13:19

Danke!
Werd's probieren!

User avatar
ak120
Posts: 1006
Joined: Thu 8. May 2014, 12:50
Location: Demmin

Post by ak120 » Thu 13. Aug 2020, 10:55

enchiriadis wrote:
Tue 11. Aug 2020, 19:42
Hallo zusammen,

nach etwas OS/2-Abstinenz hab' ich heute nochmal versucht, Firefox (diverse Versionsnummern) zu installieren.
Dann auch Leightweight.
Kurz: Die Programme, die keine Installationsroutine haben (wie z.B. die SmartSuite), bekomm' ich nicht an's Laufen.
Diese Fehleinschätzung kann ich leider nicht nachvollziehen. Sämtliche Versionen von SmartSuite für OS/2 verfügen über ein entsprechendes Installationsprogramm (INSTALL.EXE). Oder geht es hier um eine unbeaufsichtigte Installation?

enchiriadis
Posts: 9
Joined: Mon 23. Sep 2019, 13:07

Post by enchiriadis » Thu 13. Aug 2020, 16:15

enchiriadis wrote:
Tue 11. Aug 2020, 19:42
Diese Fehleinschätzung kann ich leider nicht nachvollziehen. Sämtliche Versionen von SmartSuite für OS/2 verfügen über ein entsprechendes Installationsprogramm (INSTALL.EXE).
Genau.
Darum hab' ich die im ersten Post ausgenommen, dies aber mglw. unglücklich formuliert.
Es geht die Software ohne install.exe.
Der Tipp mit dem ArcaNoae-Manager ist vermutlich der Weg zum Ziel.

Grüße!

t.

enchiriadis
Posts: 9
Joined: Mon 23. Sep 2019, 13:07

Post by enchiriadis » Fri 14. Aug 2020, 17:07

Hallo zusammen,

also..., es bleibt schwierig.
Der Paketmanager von Arca Noae ließ sich in der Tat installieren, ebenso sämtliche Pre-Requisites.

Beim Start meldet die Software, dass das YUM/RPM-Management fehlt (siehe Bild).
Zwar kann ich es nachinstallieren, aber besagte Fehl-Meldung kommt, nach Installation und Neustart, genauso wieder.

Habe noch Ideen, stocher' aber herum.
Service-Pack z.B..., kriege nicht raus, welche Version installiert ist.
Möglich, dass ich nicht das letzte drauf habe.

Hat das jemand von Euch schon hinter sich?

Dank und Grüße und schönes Wochenende!
:-)

t.
Bildschirmfoto 2020-08-14 um 16.48.53.png
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

aschn
Posts: 968
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Fri 14. Aug 2020, 17:53

enchiriadis wrote:
Fri 14. Aug 2020, 17:07
Hat das jemand von Euch schon hinter sich?
Besorg Dir das aktuelle ArcaOS. Warp 4.5, fast genauso wie Warp 4, ist Steinzeit. So ein System auf den heutigen Stand zu bringen ist nur etwas für Geübte.
Andreas Schnellbacher

User avatar
LotharS
Posts: 689
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Fri 14. Aug 2020, 21:51

enchiriadis wrote:
Fri 14. Aug 2020, 17:07
Hat das jemand von Euch schon hinter sich?
Ja, hier. Zwar nachinstalliert auf eCS2.1, aber dürfte keinen Unterschied machen, erinnere mich nicht mehr besonders :)
Der Screenshot könnte m.E. bedeuten, dass zwar die ANPM-GUI installiert ist, aber dann das ganze Innenleben mit den ersten Paketen noch herunterzuladen und zu installieren ist (mit Reboots zwischendurch). Ich weiß nur noch, dass das recht einfach war, nach ein paar Umzügen wegen bereits existierendem "Unixroot". Nur hinterher war gründliches Putzen älterer Duplikate angesagt, stünde Dir auch bevor...
Service-Pack z.B..., kriege nicht raus, welche Version installiert ist.
Möglich, dass ich nicht das letzte drauf habe.

Fixpacks gab es seit Warp4.52 m.W. keine mehr (evtl. noch ein spezielles? FP6). Seit eCS2.1 kamen gegen €€ jedoch Patches und weitere Neuerungen hinzu, und erst recht seit Engagement von ArcaNoae &al. mit ArcaOS u.a. wichtige Treiber-Updates plus Support(!).
Habe noch Ideen, stocher' aber herum.
Am bequemsten und ausführlichsten zu Stochern gibt sicher hier: https://www.arcanoae.com/wiki/ 8-)