VLC Media Player in der virt.Box

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
os2guenni
Posts: 230
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

VLC Media Player in der virt.Box

Post by os2guenni »

Hallo nicht erschrecken, ich habe noch immer das Problem, dass VLC in der virt. Box nicht gestartet wird.
Habe die letzte VLC vers.3.0.11 und alle Prerequisites installiert, es erscheint ganz kurz der Aufruf und das war's. PMDLL hilft mir auch nicht weiter, gibt es noch ein anderes Tool mit dem man eventuell ein wenig mehr sieht. Einen Trace vielleicht? Ich stehe vor einem Rätsel.
Für jeden Tipp bin ich dankbar.

Andi B.
Posts: 566
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

popuplog.os2, chkdll32.exe,

User avatar
LotharS
Posts: 752
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

os2guenni wrote:
Tue 19. Jan 2021, 17:35
Hallo nicht erschrecken, ich habe noch immer das Problem, dass VLC in der virt. Box nicht gestartet wird.
Habe die letzte VLC vers.3.0.11 und alle Prerequisites installiert, es erscheint ganz kurz der Aufruf und das war's.
Erinnert mich an diesen alten Thread. Dass der VLC _hier_ nicht gleich abbricht und sogar naja funktioniert, muss ja nicht repräsentativ sein. Und zugegeben, meine OS/2-VMs nutze ich für alles Multimedia so gut wie nie :oops:
Trotzdem nochmal kleinlich gefragt: Wo genau verabschiedet sich Dein VLC?
- schon beim Aufruf, dh. Fenster geht auf und wieder zu?
- beim Abspielversuch einer Nur-Sound-Datei? (wav, mp3,..)
- beim Abspielversuch einer Videodatei (mp4,...)
- beim Abspielversuch einer CD/DVD/...?
Mittlerweile gibt es sogar VLC3.0.12: https://ecsoft2.org/videolan-vlc-media-player, sh. auch "Prerequesites" (die Du glaub' Dir sowieso mehr- und mehrfach geprüft hattest... ).
Darüber hinaus fallen mir höchstens solche Dinge wie "Grafik" oder "verfügbarer Speicher" ein.

os2guenni
Posts: 230
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni »

Hallo Lothar,
verabschieden tut sich VLC, Fenster auf und sofort wieder zu. In der OS/2 virt. Box läuft es einwandfrei.
Im Popuplog steht absolut gar nichts. Wenn ich die chkdll32 aufrufe sagt er mir, dass alle VLC dll's geladen wurden, "Libc066,doscalls,VLC,TCPIP32".
Muss das noch mal vergleichen mit dem Aufruf in der OS/2 Box.

User avatar
LotharS
Posts: 752
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

Ist der Pfad zu den VLC*.DLL usw. auch im LIBPATH eingetragen? Oder keine Duplikate davon verstreut?

Hier habe ich das komplette "VLC2"-Gesumms aus der heruntergeladenen *zip unter ein (für solche Zwecke) _eigenes Verzeichnis_ "E:\APPS" entpackt, getrennt von der Systempartition bzw. unixroot, sodann LIBPATH und PATH entsprechend ergänzt. Funktioniert und tönt jedenfalls.

os2guenni
Posts: 230
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni »

Hallo Lothar,
man sollte es nicht glauben, eine DLL hat sich verflüchtigt, und zwar die VLCCORE. Jetzt läuft es !!
Danke für den Beistand.

Gruß
Günter