Samba verliert die Connection

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Samba verliert die Connection

Post by DonLucio »

Seit drei Wochen nun habe ich meine NAS (Qnap) am Laufen und per Samba mit meinem ArcaOS-PC verbunden. Nach einigen Anfangsschwierigkeiten läuft es inzwischen eigentlich ganz gut. So habe ich auch schon eine Menge Dateien auf die NAS (Laufwwerk Z:) ausgelagert (nur Daten, keine Programme).

Inzwischen häufen sich jedoch Fälle, wo die Verbindung plötzlich weg ist. Das komplette Netz-Laufwerk Z: ist futsch, damit natürlich auch alle Shares (nur die Verbindung, gottlob nicht die Daten).

Die Fälle sind reproduzierbar:
Bilddatei anschauen mit PMView: Eine Datei öffnen geht noch, wenn ich aber mittels Datei-Öffnen-Dialog versuche, das entsprechende Verzeichnis auf Z: anzusteuern, verschwindet Z: schlagartig. Das gleiche Verhalten gibt's bei FaxView, allen Programmen der IBM-Works-Suite, beim Firefox (45.9). Keinerlei Probleme gibt's mit Embellish, mit Open Office 3.0, und dem WPS-Dateibrowser. Auch das alte XTree-Pro, das zwar gewisse Probleme mit dem Kopieren großer Dateien hat, kann aber gefahrlos in allen (Unter-)Verzeichnissen des Netz-Laufwerks herumnavigieren. Seltsam.

Blöderweise gehören zu den Programmen, wo's nicht funktioniert, alle (selbstgestrickten) VXRexx-Programme. Überall dort, wo der Standard-FileOpen-Dialog angewendet wird, stürzt das Laufwerk Z: ab, wenn man versucht, Unterverzeichnisse darauf zu öffnen.

Ich finde kein vernünftiges Muster, wo's funzt und wo's nicht funzt. Am meisten irritierend finde ich, dass die "hochoffiziellen" IBM-Programme (Works) abstürzen, während selbstgebastelte Shareware-Programme wie ZTreeBold prima laufen.

Hat jemand 'ne Idee?

Danke,
Don Lucio.

aschn
Posts: 1102
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Das Muster könnte sein, dass die Anwendungen, die Du aufgezählt hast, eben nicht den Standarddialog zur Dateiauswahl nutzen, sondern diesen verändert haben. Ich vermute mal, dass die File-Open-Container-Erweiterung hiearan nicht schuld ist. Befehlszeile wird vermutlich immer gehen. Mehr hab ich nicht.
Andreas Schnellbacher

User avatar
Sandra Asja Eickel
Posts: 30
Joined: Sat 30. Dec 2017, 01:00

Post by Sandra Asja Eickel »

Könnte etwas mit EAs zu tun haben, auch wenn die WPS das mitmacht (das QNAP-NAS unterstützt keine Erweiteren Attribute, auch wenn man das über per Shell-Zugriff ändern kann - die kuriosen Probleme sind es aber nicht wert, daher habe ich das wieder deaktiviert).

Da Du die Situation aber sauber reproduzieren kannst, solltest Du ein Ticket erstellen, damit dem Fehler auf den Grund gegangen werden kann.

Liebe Grüße
Sandra Asja Eickel

User avatar
LotharS
Posts: 744
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

1) Solche NAS werden m.W. gern von einem Art Linux gesteuert, und da fällt mir (inzwischen...) als erstes das Stichwort "Berechtigungen" ein: Zugriff vom Client aus Sicht des NAS als root, user,...? , Rechte rekursiv auf Verzeichnisinhalte?

2) Zu einem Samba-Server gehört eine 'smb.conf' (oder vergleichbares auf dem NAS?), manchmal sogar von Hand nachzubessern.

3) Tritt das Problem ähnlich auch von einem anderen Client-Rechner auf?

Nur als "Pfeile ins Dunkle" von weitem :)

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

aschn wrote:
Sat 30. Jan 2021, 20:45
Ich vermute mal, dass die File-Open-Container-Erweiterung hiearan nicht schuld ist.
Inzwischen läßt sich mit ziemlicher Sicherheit feststellen: Doch. Dieser neue FileOpen-Dialog ist die Ursache für die Verbindungsabbrüche (was meinst du mit Container-Erweiterung?).

Angeregt durch die Frage von LotharS:
"3) Tritt das Problem ähnlich auch von einem anderen Client-Rechner auf?"
habe ich mal mein altes IBM-Thinkpad T42 aus der Versenkung geholt. Dort läuft noch eCS 2.1. Und kein ArcaMapper, sondern das alte EVFSGUI, das ich aber auf meinem aktuellen ArcaOS-PC ebenfalls verwende (aus Gründen, die ich hier schon in einem anderen Thread ausgeführt hatte).

Und eCS 2.1 hat noch nicht diesen "neuen" FileOpen-Dialog. Und siehe - dieselben Programme (teils selbstgeschriebene), die auf meinem ArcaOS-PC abstürzen, laufen fehlerfrei auf meinem Samba-Z:-Laufwerk.

Mehr Evidenz geht kaum, oder?

Die Lösung wäre also (ausser auf eCS wieder zurückzufallen, was ich natürlich nicht will): Die alte DLL, die für den FileOpen-Dialog zuständig ist, wieder zurückzuholen. Ich selbst stecke zu wenig drin in den Tiefen des OS/2 bzw. ArcaOS, um sagen zu konnen, welche DLL das ist und ob es da möglicherweise schädliche Nebenwirkungen gibt.

Ich erinnere mich dumpf: Hatte dieser neue Dialog nicht irgendwas mit XWPS zu tun? Gibt es dort irgendwo Settings, mit denen man den FileOpen-Dialog wieder auf "normal" zurücksetzen kann, ohne gleich die ganzen XWPS-Erweiterungen zu verlieren?

Danke,
Don Lucio.

aschn
Posts: 1102
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Sieh dir mal \sys\install\FOC\filedlgtofocdlg.cmd an.

Und hier die Anleitung.
Andreas Schnellbacher

User avatar
LotharS
Posts: 744
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

DonLucio wrote:
Sun 31. Jan 2021, 15:42
Inzwischen läßt sich mit ziemlicher Sicherheit feststellen: Doch. Dieser neue FileOpen-Dialog ist die Ursache für die Verbindungsabbrüche
Konntest Du auch den Vergleich mit PMView machen? Das kommt mit _eigengestricktem_ Datei-Öffnen-Dialog, gleich ob eCS oder ArcaOS.

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

aschn wrote:
Sun 31. Jan 2021, 16:22
Sieh dir mal \sys\install\FOC\filedlgtofocdlg.cmd an.
Respekt vor deinem Insiderwissen :-)

Ich hab das Skript mal angeschaut, dann ausgeführt. Soweit ich die Prompts verstanden habe, hat er etwas installiert, was aber schon installiert war. ("This module not needed to be edited or it is been edited already.")

Insofern wenig überraschend, dass ich keine Besserung feststellen kann.

LotharS wrote: Konntest Du auch den Vergleich mit PMView machen? Das kommt mit _eigengestricktem_ Datei-Öffnen-Dialog, gleich ob eCS oder ArcaOS.
PMView kackt auch ab. Er hat zwar - wie du richtig sagst - einen selbstgestrickten FileOpen-Dialog. Ich kann auch immerhin durch alle meine Z:-Verzeichnisse durchbrowsen und eine beliebige Datei öffnen. Insofern ein anderes Verhalten als bei den Standard-FileOpen-Verfahren. Aber wenn ich "nächstes Bild" ansteuern will, ist schon wieder Schluß. Geräuschlos, aber gründlich verabschiedet sich das Netz-Laufwerk.

Kurioserweise nimmt das Samba-System keinen dauerhaften Schaden. Es läßt sich jederzeit erneut ein Z: mounten und verschiedene Shares hinzubinden.


Ich werde jetzt mal Andreas' Tip mit dem FOC-Installer andersherum probieren: Man kann auch UNINSTALL sagen ... Mal sehen, was passiert.

So, 3 Minuten später...:
Das /UNINSTALL mit dem von Andreas genannten Skript hat tatsächlich die Lösung gebracht. Ich habe meinen alten (häßlichen) FileOpen-Dialog wieder. Unschön, aber die Samba-Verbindung stürzt nicht mehr ab! <freu>. Ich hab's mit Embellish geteset, mit meinen selbstgestrickten VXRexx-Programmen und auch mit den Programmen der IBMWorls-Suite. Alles paletti.

Danke!
Don Lucio

aschn
Posts: 1102
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Na dann is' ja gut.

Faierweise solltest Du das aber melden. Vielleicht am besten gleich an den Entwickler, Dmitry A. Steklenev, sonst auch an AN, weil ist ja eine Komponente, die die installieren. (Bei XWP-Fehlern sehen die von AN das übrigens anders, obwohl Ulrichs xTracker schon ewig nicht mehr erreichbar ist.)
Andreas Schnellbacher

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

aschn wrote:
Sun 31. Jan 2021, 19:53
Na dann is' ja gut.

Faierweise solltest Du das aber melden. Vielleicht am besten gleich an den Entwickler, Dmitry A. Steklenev, sonst auch an AN
Wenn ich eine "ladungsfähige" Adresse wüßte, täte ich es gern.

Mich würde aber noch etwas anderes interessieren:
Bin ich eigentlich der einzige ArcaOS-User (mit dem erweiterten FileOpen-Dialog), der auch Samba nutzt?

Gruß,
Don Lucio.

Andi B.
Posts: 557
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

Ein paar Anmerkungen von mir dazu - ich kenne "Samba verliert immer wieder mal Verbindung" von alten Versionen. Erst mit den relativ neuen Samba Client Versionen kann ich halbwegs arbeiten. Also eher spielen, zum Arbeiten ist das für mich alles noch immer viel zu langsam im Vergleich zum alten OS/2 Netbios. Ich probiere da schon länger mit Samba Server (läuft schon längere Zeit stabil) und den diversen Client Versionen (erst seit einigen Monaten hab ich da eine stabile Version).

Der PMView File Dialog ist sehr speziell - der versucht auf meinem Mount-Point wo neben Samba shares auch zahlreiche FTP Server eingebunden sind, alles für die Vorschaubilder zu scannen. Das dauert nicht nur ewig (Minuten) sondern blockiert auch die WPS. Ist hier also auf meinem F:\ (da liegen meine FTP, Samba, WebDAV, ... shares) absolut unbrauchbar. Ganz einfach weil bei den vielen Zugriffen auf die vielen Server viele Timeouts abgewartet werden müssen..... Das könnte beim FOC (FileOpenContainer) der ja auch die Directory-Struktur einlesen will, ähnlich sein. Übrigens ein ähnliches Verhalten, zeigen auch die QT File Dialoge.

Also was ich damit sagen will, einige unserer File Dialoge sind ungeeignet für unsere heutige Netzwerkverbindungen, auch weil dabei die WPS (scheinbar) blockiert wird. UND alte Samba Clients sind auch bei mir immer wieder abgeschmiert. Also wenn du ein Ticket bei AN bezüglich Samba Client aufmachen willst, den Client hast du wohl von AN, dann installiere auf einer eigenen Partition ein aktuelles ArcaOS mit dem AN network .... (wie heißt der doch gleich) und dem mitgelieferten Netdrive samba client plugin. Und installiere alle AN updates. Da hat sich in den letzten 1-2 Jahren einiges getan. Ich bin gar nicht sicher, wie gut die letzte ArcaOS Version in diesem Punkt ist.

User avatar
LotharS
Posts: 744
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

DonLucio wrote:
Sun 31. Jan 2021, 23:28
Bin ich eigentlich der einzige ArcaOS-User (mit dem erweiterten FileOpen-Dialog), der auch Samba nutzt?
:) Den benutze ich hier mit ArcaOS&Samba öfters. Deshalb schien mir das Problem ja so suspekt...

Bei der Gelegenheit nochmal gegengefragt, sorry soweit erneut:
1) Wie äußert sich der "Absturz der Connection"?
- die Netzwerkverbindung selbst (verifizierbar über die Kommandozeile) oder
- nur Absturz der Desktop-_Anwendung_ bzw. -Dialogs oder
- nur falsche/fehlende _Darstellung_/Aufzählung innerhalb der Anwendung?
2) Wie viele Verzeichnisse/Dateien befinden sich echt im freigegebenen NAS-Verzeichnis bzw. maximal in Unterverzeichnis?
- Mir war mal die magische Zahl 32767 begegnet und bescherte mir stundenlang "Freude" :roll: (Container, Buffer,...): 1 mehr = Überlauf und Aus, außer der Entwickler fährt bremsbereit....
Gemäß Murphy dürften es sowieso mindestens zwei voneinander unabhängige Ursachen sein :ugeek:

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Mon 1. Feb 2021, 10:30
1) Wie äußert sich der "Absturz der Connection"?
Das Netzwerk-Laufwerk (in meinem Fall Z:) verschwindet. Aus dem Laufwerks-Ordner und eben auch physisch als zugreifbares Laufwerks-Objekt.

Die Anwendung selbst bleibt intakt, nur das von mir angesteuerte Laufwerk Z: verschwindet plötzlich aus der Auswahlliste im FileOpen-Dialog.

Aber, wie gesagt: Nur beim neuen FileOpen-Container. Beim alten, aus eCS-Zeiten stammenden FileOpen passiert das nicht, da bleibt die Verbindung bestehen.

LotharS wrote:
Mon 1. Feb 2021, 10:30
2) Wie viele Verzeichnisse/Dateien befinden sich echt im freigegebenen NAS-Verzeichnis bzw. maximal in Unterverzeichnis?
Das könnte ein Indiz sein. Tatsächlich handelt es sich um ein Share mit mehreren tausend Unterverzeichnissen (ist meine MP3-Sammlung und für jeden Artist gibt es ein eigenes Unterverzeichnis, darunter noch für jedes seiner Alben weitere Unterverzeichnisse). Ich hab jetzt mal nachgezählt: Es sind genau 11.324 Unterverzeichnisse. Die Anzahl Dateien ist um den Faktor 4 bis 5 (durchschnittlich Tracks pro Album) höher.

LotharS wrote:
Mon 1. Feb 2021, 10:30
Mir war mal die magische Zahl 32767 begegnet
Hmm... für Dateien oder Verzeichnisse? Mit Dirs liege ich drunter, mit files deutlich drüber.

Wo kann ich denn diese magische Zahl anpassen? Im smb.conf befinden sich insgesamt 445 Parameter, einen Wert 32767 finde ich dort nicht. Aber diesen Parameter:

Code: Select all

max open files = 16384
Das bringt mich zu einem neuen Problem: Die Datei C:\var\temp\smb.conf läßt sich zwar editieren, aber das scheint nur eine Phantom-Datei zu sein: Nach erneutem Verbinden von Z: stehen wieder die alten Werte darin. Es gibt noch eine smb.conf in C:\MPTN\ETC\samba, die ist aber praktisch leer. Alles etwas rätselhaft.

Aber ich bin das Suchen inzwischen leid. Mit dem alten FileOpen-Dialog gibt's keine Probleme, trotz des unveränderten smb.conf mit "nur" 16384 open files. Und auf die Benefits des neuen ArcaOS-FOC kann ich gut verzichten. Und solange ich keine Adresse des Authors Dmitry A. Steklenev habe, werde ich auch kein Ticket schreiben.

Leider schmiert PMView aber immer noch ab, auch mit dem alten FOC. Das scheint aber eine gänzlich andere, PMView-spezifische Baustelle zu sein, denn das alte FaxView funzt. Schade um das gute alte PMView, das ich ansonsten seeeehr schätze. Man kann nicht alles haben.

Danke fürs Zuhören :-)

Gruß,
Don Lucio.

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

Andi B. wrote:
Mon 1. Feb 2021, 10:07
Ein paar Anmerkungen von mir dazu - ich kenne "Samba verliert immer wieder mal Verbindung" von alten Versionen. Erst mit den relativ neuen Samba Client Versionen kann ich halbwegs arbeiten.
Wenn ich dich richtig verstehe, zielst du darauf ab, die Ursache in fehlerhafter Samba-Implementierung zu suchen (und nicht im FileOpen-Dialog). Habe ich zuerst ja auch gedacht, aber ich bringe das nicht in Einklang mit der Tatsache, dass Samba (egal ob ArcaMapper oder EVFSGUI) tadellos funktioniert, auch bei seeeehr großen Shares, wenn ich den alten FOC aus eCS verwende.

Andi B. wrote: Also wenn du ein Ticket bei AN bezüglich Samba Client aufmachen willst, den Client hast du wohl von AN.
Afaik basiert das OS/2-Samba auf der Netdrive-Software von Blueprint Software Works. Korrigiere mich, wenn das falsch ist.

Ich bezweifele, dass diese Leute mir zuhören würden ... :?

Gruß,
Don Lucio.

User avatar
LotharS
Posts: 744
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

DonLucio wrote:
Mon 1. Feb 2021, 15:59
Wo kann ich denn diese magische Zahl anpassen? Im smb.conf befinden sich insgesamt 445 Parameter, einen Wert 32767 finde ich dort nicht.
Mehr als 32767 Zeilen passen von OS/2 aus in keinen Listbox-Container. Ein freundlicher Entwickler würde das Befüllen da stoppen und eventuell eine Nachricht ausgeben... oder weiß wie man irgendwelche graphische Verrenkungen macht.
Das Netzwerk-Laufwerk (in meinem Fall Z:) verschwindet. Aus dem Laufwerks-Ordner und eben auch physisch als zugreifbares Laufwerks-Objekt.
Dann vermute ich, das "Z:" tut auch nicht mehr auf Kommandozeile? Andi schrieb richtig von der auch graphischen Belastung, und wenn aufgrund der Mengen der neue FOC möglicherweise "zu lange" für die (gegenüber alt) umfangreichere Auflistung braucht, mag es zum Timeout kommen. Abgesehen vom Bitstau auf Kabel- oder Luftkanal. Alles nur blind geraten ;)
Die Datei C:\var\temp\smb.conf läßt sich zwar editieren, aber das scheint nur eine Phantom-Datei zu sein: Nach erneutem Verbinden von Z: stehen wieder die alten Werte darin. Es gibt noch eine smb.conf in C:\MPTN\ETC\samba, die ist aber praktisch leer.
Erstere gehört zum Samba-Client (und wird offenbar immer erneuert aus dessen GUI-Einstellungen), letztere steuert den lokalen Samba-Server (und gefüllt wenn konfiguriert). Da hier ja das NAS den Samba-Server darstellt, müsste dort eigentlich auch so etwas Ähnliches vorhanden sein und notfalls editierbar. Prinzipiell finde ich da u.a. Einträge mit "..max.." und "..timeout..." und zigs mehr, ließe sich alles ergoogeln :)
Hier mit meinen überschaubaren Mengen (soweit OS/2 inzwischen betreffend...) scheinen also die vorkonfigurierten Standards (Client,Server) ausreichend. Ansonsten säßen die Samba-Finetuning-Experten eher unter den Linuxern, vielleicht hat Oma Google passende Geheimnisse im Nähkörbchen ;)
Afaik basiert das OS/2-Samba auf der Netdrive-Software von Blueprint Software Works.
Korrekt, aber AN liefert uns ein eigenes Spezial-nur-Samba-NDFS "gratis" mit. Die schlimmste Antwort könnte lauten "Not ours"...
Das Ticket sollte aber tunlichst mit ArcaMapper zu tun haben, denn "EVFS..." würde sicher ungelesen geschlossen.
Mit ArcaOS5.1 soll übrigens ein ganz neuer ArcaMapper kommen. Doch solange Deine Konstruktion brauchbar läuft... :D

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Mon 1. Feb 2021, 17:18
Erstere gehört zum Samba-Client (und wird offenbar immer erneuert aus dessen GUI-Einstellungen), letztere steuert den lokalen Samba-Server.
Ah ja, das macht Sinn.
Das erklärt die (fast) leere Datei unter ...\ETC\...

"...immer erneuert aus dessen GUI-Einstellungen": Du meinst damit die ArcaMapper-GUI? M.a.W.: Die für die jeweilige Samba-Verbindung zuständige .conf-Datei wird aus dem ArcaMapper heraus dynamisch erzeugt? Dann habe ich schlechte Karte, was eine Modifikation der Parameter anbelangt, denn die GUI liefert nicht annähernd soviel Optionen wie in der .conf-Datei stehen. Vor allem sehe ich da keinen Wert für "max open files".

LotharS wrote:Mehr als 32767 Zeilen passen von OS/2 aus in keinen Listbox-Container.
Meine Anzahl von Verzeichnissen liegt bei 3902. Die von mir genannte Gesamt-Anzahl (Unter-) Verzeichnisse von 11324 sollte nicht relevant sein, weil der FO-Dialog öffnet ja immer nur eine Verzeichnisebene zur Zeit. Und ich komme ja schon nicht in die erste Ebene (mit 3902 Einträgen).

LotharS wrote:Da hier ja das NAS den Samba-Server darstellt, müsste dort eigentlich auch so etwas Ähnliches vorhanden sein und notfalls editierbar.
Ok, gute Idee. Da kann ich mal schauen.

LotharS wrote:Mit ArcaOS5.1 soll übrigens ein ganz neuer ArcaMapper kommen.
Wann kommt 5.1? Ist das so wie mit den "ausreichend Impfdosen"? :lol:

Gruß,
Don Lucio.

Andi B.
Posts: 557
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

Ich denke nach wie vor, dass der Samba Client abschmiert. Der Test auf der Kommandozeile, versuchen auf dein Laufwerk Z: zu wechseln, sollte Klarheit bringen.

Das es nur mit manchen File Dialogen passiert, kann leicht sein. Muss aber nichts mit dem FOC zu tun haben. Ich tippe hier auf die EAs bzw. auf die nicht OS/2 korrekte Implementierung dieser auf den meisten (allen?) NAS und ev. als Folgeerscheinung das Abstürzen des nicht perfekten smb plugins.

Und da AN gerade in diesem Bereich einiges testet und uns ja mit ArcaOS ein ndpsmb.dll mitliefert, werden die sich auch um das Problem kümmern. Natürlich nur, wenn du das in richtiger Umgebung (aktuelles AN + ANPM updates) reproduzieren kannst. Kann zwar sein, dass sie "nur" die sourcen von netlabs genommen und neu kompiliert haben und deshalb auf trac.netlabs.org verweisen. Ich denke aber, Paul oder ? hat da für/bei AN daran gearbeitet.

Natürlich kannst an allen möglichen und unmöglichen Stellen schrauben (FOC alt, uralte, steinalt, ....), aber du könntest auch mal klären, ob es nicht doch das simple Samba Client Problem ist welches mich jahrelang geärgert hat.

Übrigens, meine ndpsmb.dll ist gebaut auf "Build Machine: ARCAOS-D0C2" vom Jänner 2019. Und die war soweit ich mich erinnere die erste, die hier nicht mehr regelmäßig abschmiert. Auch wenn sie sich "netlabs:3.5.0" nennt, ist diese eindeutig von AN. Ich weiß aber nicht, welche aktuell bei ArcaOS mitgeliefert wird.

User avatar
LotharS
Posts: 744
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

LotharS wrote:
Mon 1. Feb 2021, 10:30
DonLucio wrote:
Sun 31. Jan 2021, 23:28
Bin ich eigentlich der einzige ArcaOS-User (mit dem erweiterten FileOpen-Dialog), der auch Samba nutzt?
:) Den benutze ich hier mit ArcaOS&Samba öfters. Deshalb schien mir das Problem ja so suspekt...
Hinzufügen muss ich, dass ich das zwar mit Win, Linux und eCS als Servern mache, auf "normalen" Rechnern, nicht jedoch auf NAS.
Ich neige sehr stark zu Andis Vermutung zu EAs, eventuell sogar "einfache Attribute" und/oder zusätzlich zur Datenlast. Ein Google-Input nach "NAS erweiterte attribute" liefert jedenfalls saheitenweise Treffer - nicht unbedingt zu OS/2 als Client, aber Irgendwie scheinen die NAS-BS nicht immer allen (wenigtens offenen Linux-) Standards zu genügen? Würde mich nicht überraschen, kennen wir von anderen Schnittstellen auch.
Ein wenig beruhigend, dass sich AN der Themen Samba und (u.a. Netzwerk-)Treiber annimmt bzw. lässt, mit Support.

Bisher habe ich nur entnommen, dass das Problem in PM-Anwendungen auftritt (FOC, PMView, VXRexx), die ja neben den Pfadnamen weitere Info erfragen und graphisch anzeigen (bis hin zu Icons, Thumbnails,..).
Optional könnte man mit reichchlich Geduld ;) eine Art Zeitlupen-Versuch durchführen, mit Hilfe von _Kommandozeile_ (Z:, cd, dir, xcopy) und einem lokalen Temp-Verzeichnis erst eine Serie von Dateien vom NAS "downloaden" und auf _Kommandozeile_ schauen was davon ankommt. Und erst dann mit PM-Apps aufs Temp-Verzeichnis. Ob das Procedere schlauer macht, null Prognose.. :)
Wann kommt 5.1? Ist das so wie mit den "ausreichend Impfdosen"?
Frag mich bitte nochmal, sobald Stuttgart21 fertig ist :lol:
Bis dahin magst Du ja dem von Dir entdeckten "alten Gleis" weiterfahren. :D

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Tue 2. Feb 2021, 13:10
Ich neige sehr stark zu Andis Vermutung zu EAs,
Hm ... in den ArcaMapper-Settings habe ich EAs angekreuzt. Sollte ich mal "Ohne EAs" probieren ....

LotharS wrote:Bisher habe ich nur entnommen, dass das Problem in PM-Anwendungen auftritt (FOC, PMView, VXRexx),
Das ist zuteffend. Commandline- oder VIO-Programme haben keine Probleme.
LotharS wrote:...die ja neben den Pfadnamen weitere Info erfragen und graphisch anzeigen (bis hin zu Icons, Thumbnails,..).
Ja, das könnte ein Indiz sein.

LotharS wrote:Optional könnte man .... Ob das Procedere schlauer macht, null Prognose.
Der Aufwand würde letztlich das Problem nur lokalisieren (ob FOC oder Samba pder Netdrive), aber nicht lösen. Und solange ich der einzige User bin, der davon betroffen ist, würde wohl auch ein Ticket kaum etwas bewirken.

LotharS wrote:Bis dahin magst Du ja dem von Dir entdeckten "alten Gleis" weiterfahren. :D
Naja, das alte Gleis fährt ja recht gut. Ich entbehre nix, ausser dem hübsch-graphischen Auftritt des neuen FOC.

Gruß,
Don Lucio.

Andi B.
Posts: 557
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

LotharS hat geschrieben:
Optional könnte man .... Ob das Procedere schlauer macht, null Prognose.

Der Aufwand würde letztlich das Problem nur lokalisieren (ob FOC oder Samba pder Netdrive), aber nicht lösen. Und solange ich der einzige User bin, der davon betroffen ist, würde wohl auch ein Ticket kaum etwas bewirken.
Im Moment deutet vieles darauf hin, dass du wirklich der einzige bist, bzw. einer von sehr wenigen. Im Umkehrschluss, du hast ein speziell konfiguriertes System. Oder unfreundlicher formuliert, du hast ev. ein unsauber zusammengeschustertes System. Wenn du das weiß, dann könntest du das auch versuchen zu reparieren. Oder eben auf FOC, PMView, ..... verzichten. Ob du dem auf den Grund gehen willst oder nicht, ist natürlich deine Entscheidung.

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

Andi B. wrote:
Tue 2. Feb 2021, 20:24
Oder unfreundlicher formuliert, du hast ev. ein unsauber zusammengeschustertes System.
Ja, ich weiß. Das Vergewaltigungsopfer war selbst schuld. Warum trägt sie auch so einen kurzen Rock.

Nichts für ungut, aber die Schuld immer bei dem "dummen" User zu suchen, das muß ich zurückweisen.

Es sei denn, jemand verweist auf die OS/2-Usability-Fibel und beweist mir, dass es verboten ist, 50.000 Musiktitel zu verwalten.

Inzwischen mehren sich die Anzeichen, dass die Schuld nicht im Samba selbst liegt, sondern dass in der Gegend um das Öffnen von (großen) Verzeichnissen mittels PM-Dialogen ein Bug im System steckt: Ich bin jetzt mit dem alten FOC unterwegs und habe mich mal bemüht, die fragliche Verzeichnisstruktur von Z: auf eine lokale Platte zurückzukopieren. Ok, hat mit XCopy zweieinhalb Stunden gebraucht. So what. Aber das Schliimme ist: Der Versuch, das Verzeichnis danach aus dem Laufwerksordner heraus (also mit klassischen WPS-Mitteln) zu öffnen, endet im Fiasko. Der Verzeichnisbaum geht gerade von Buchstabe A bis D, dann fehlen fast alle, die mit E,F, G anfangen, dann kommt eines mit H, dann ist Schluß. Die Anzeige mittels VIO-Programm (ZTBold/XTree) zeigt dagegen lückenlose Unterverzeichnisse von A wie Abba bis Z wie Zuccero.

Kurioserweise stürzt dabei die Samba-Verbindung nicht ab.

Ich stelle fest: Meine 50.000 MP3-Dateien konnte ich bisher, in der Vor-NAS-Zeit, mit all meinen OS/2-Versionen problemlos verwalten. Rückblickend muß ich aber konstatieren, dass das nur möglich war, weil ich - aus historischen Gründen - insgesamt 8 Partitionen, von C: bis O: betreibe. Und diese 50.000 Dateien auf mehrere dieser Partitionen verteilt habe.

Dass ich diese willkürliche Verteilung nun auch auf meinen Samba-Shares abbilden muß - macht mich nicht gerade froh.

Oder gibt es vielleicht doch noch irgendwo einen "Max-Files-" o.ä. Parameter?

Gruß,
Don Lucio.

Andi B.
Posts: 557
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

DonLucio wrote:
Tue 2. Feb 2021, 22:49
Andi B. wrote:
Tue 2. Feb 2021, 20:24
Oder unfreundlicher formuliert, du hast ev. ein unsauber zusammengeschustertes System.
Ja, ich weiß. Das Vergewaltigungsopfer war selbst schuld. Warum trägt sie auch so einen kurzen Rock.

Nichts für ungut, aber die Schuld immer bei dem "dummen" User zu suchen, das muß ich zurückweisen.
...
Ich suche nicht die Schuld beim Vergewaltigungsopfer, sondern versuche bei der Aufklärung zu helfen. Obwohl ich denke, dass dich niemand gezwungen hat eine bestimme SW zu benutzen, also das ein etwas unpassender Vergleich ist. Aber wenn du nicht mithelfen willst, kann ich auch nichts machen. Entweder hab ich's überlesen, oder du hast immer noch nicht gepostet, welche Version des plugins du verwendest. Der nächste Schritt wäre dann für mich gewesen zu kontrollieren, ob du wirklich aktuelle Versionen der benötigten Libraries installiert hast. Vor allem vor dem Hintergrund wo du ja anscheindend nichts anderes geändert hast, als Samba und NAS zu deiner Arbeitsumgebung hinzuzufügen. Aber möglicherweise ist ja meine Methode der Fehlereingrenzung nicht passend. Und vielleicht macht ja das spekulieren über mögliche Fehler in anderen Programmen oder File Dialogen mehr Spaß. Da halt ich mich aber lieber raus. Den was man hier rauslesen kann, haben die ja bis dato problemlos funktioniert.

User avatar
LotharS
Posts: 744
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

DonLucio wrote:
Tue 2. Feb 2021, 22:49
Ich bin jetzt mit dem alten FOC unterwegs und habe mich mal bemüht, die fragliche Verzeichnisstruktur von Z: auf eine lokale Platte zurückzukopieren. Ok, hat mit XCopy zweieinhalb Stunden gebraucht. So what. Aber das Schliimme ist: Der Versuch, das Verzeichnis danach aus dem Laufwerksordner heraus (also mit klassischen WPS-Mitteln) zu öffnen, endet im Fiasko. Der Verzeichnisbaum geht gerade von Buchstabe A bis D, dann fehlen fast alle, die mit E,F, G anfangen, dann kommt eines mit H, dann ist Schluß. Die Anzeige mittels VIO-Programm (ZTBold/XTree) zeigt dagegen lückenlose Unterverzeichnisse von A wie Abba bis Z wie Zuccero.

Kurioserweise stürzt dabei die Samba-Verbindung nicht ab.
Da wären wir doch ein ganzes Stück weiter:
(1) Die Dateien an sich sind demnach komplett heruntergeladen worden, ok. (Ob dabei irgendwelche EAs beschädigt waren oder nicht, sei erstmal dahingestellt. Für den alten FOC reicht's ja.) Plausibel dass Samba nicht abstürzt, wenn es beim Lesen-nur-lokal nicht benötigt wird.
(2) Das Problem wurde sichtbar erst während der graphischen Darstellung der Dateinamen usw im PM-Fenster: aus Bytes werden Punkte, Striche, Buchstaben, Bildchen usw. gesammelt, sortiert ins PM-Fenster geliefert und gemalt; dabei entstand "Unfug" und Samba-Trennung.
Oder salopp: Der Wurm (oder gar mehrere) mag irgendwo zwischen DOSCALL1.DLL, Samba-DLLs und Grafiktreiber liegen... Hardware was-auch-immer schließe ich hier aus.
Andi B. hat geschrieben: ↑Di 2. Feb 2021, 20:24
Oder unfreundlicher formuliert, du hast ev. ein unsauber zusammengeschustertes System.
Ja, ich weiß. ...
Nichts für ungut, aber die Schuld immer bei dem "dummen" User zu suchen, das muß ich zurückweisen.
Hier im Forum gibt es keine "Dummen User". Obwohl bekanntlich... Computer-Probleme sitzen am weitaus häufigsten zwischen Rückenlehne und Tastatur/Touch-Display. :lol: Und wenn sogar Einstein unsicher war ob das Universum unendlich sei...
Ich versuch's mal weniger umgangssprachlich: "Your system has possibly reached its maintenance entropy". :geek:

Deshalb mein letzter unverbindlicher Vorschlag:
(1) Routine, evtl nach Backup, kann niemals schaden:
(1a) chkdsk ... ausführen von außen(!), dh. aus einer gebooteten Wartungspartition gestartet oder DVD-Boot->Maintenance.
(1b) INIs säubern : checkini, cleanini.
(2) Testweise ein frisches ArcaOS5.0.6 mitsamt ArcaMapper sowie AN-Treiber- und ANPM-Update auf leerer (oder geräumter) Partition *) und Formatierung aufsetzen, nur als Test-Systemlaufwerk gedacht von max. 4GB, Als erstes interessiert bloß Samba-Verbindung und danach Zugriff auf dieses 'Z:' mit Kommandozeile und neuem FOC. Nur falls dies -Überraschung!- klappt, evtl Test mit PMView und Audio&VLC, andernfalls wäre ein Ticket bei AN sicher willkommen.
*) alternativ als kleine virtuelle Maschine auf einer verfügbaren Win-Kiste mit VirtualBox.
Nebenbeit: Auch ich brauchte für ArcaOS wiederholt zwei Anläufe..., dank VBox ging das relativ zügig...

Viel Erfolg!
Ich denke, dass Du mit Deinem ersten klasse NAS-Bericht bei Manchem von uns Riesen-Interesse geweckt hast, und Berichte über dabei aufgetretene Probleme genauso nützlich für alle sind. Danke für Deine ausführlichen Beiträge! :)

Am Rande:
Dass ich diese willkürliche Verteilung nun auch auf meinen Samba-Shares abbilden muß - macht mich nicht gerade froh.
Ich nehme an, Du verteilst auf dem NAS Deine Sammlung nach für Dich geeigneten übersichtlichen Ordnungsprinzipien.
Nur rein technisch sei erwähnt, dass Du sehr wohl ganz flexibel z.B ein Share der Art qnapMusik auf Mount Z:\Musik, qnapVideos auf Z:\Videos, qnapBilder auf Z:\Bilder gleichzeitig mounten kannst, dh. 1 *ndc-Datei mit 3 oder mehr Zeilen laden, anstatt "flach" alles unter 'Z:\'. Beim ersten Einrichten natürlich nacheinander mounten, doch danach das Resultat als 1 ndc-Datei speichern (evtl zusätzlich Autostart). Dargestellt werden die virtuellen Z:\xxx als Vereichnisse unter Z: wie gewohnt. - Hier sammle ich n Shares unterschiedlicher Rechner als Verzeichnisse unter 1 virtuellen 'J:', nach Bedarf auch aus mehreren ndc's im ArcaMapper nachgeladen...

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

Andi B. wrote:
Wed 3. Feb 2021, 09:51
Da halt ich mich aber lieber raus.
Tut mir leid, wenn mein Tonfall etwas entglitten ist. Natürlich ist dein Rat weiterhin willkommen.

Gruß,
Don Lucio.

User avatar
DonLucio
Posts: 594
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Wed 3. Feb 2021, 11:52
Deshalb mein letzter unverbindlicher Vorschlag:
Das wäre schade ... :-)

LotharS wrote: (2) Testweise ein frisches ArcaOS5.0.6 mitsamt ArcaMapper sowie ....
Ok, ich habe noch einen abgelegten PC, darauf werde ich mal total frisch ArcaOS installieren. Mal sehen, wie's da aussieht.

LotharS wrote:Danke für Deine ausführlichen Beiträge!
Dank an dich für deine unermüdliche Geduld, weiter zu diskutieren :-)

Wenn sich der Pulverdampf gelegt hat, werde ich mal einen zusammenfassenden, strukturierten Bericht abgeben. Für mich jedenfalls hat sich mit der Anschaffung dieser (halbwegs professionellen) NAS ein Tor in eine ganz neue Welt eröffnet, mit ganz neuen Möglichkeiten der Datenverwaltung (in Zeiten der Terabytes). Und wie du schon sagtest, das ist vielleicht auch für andere OS/2-User von Interesse.

LotharS wrote:Ich nehme an, Du verteilst auf dem NAS Deine Sammlung nach für Dich geeigneten übersichtlichen Ordnungsprinzipien.
Eben nicht. Die 50.000 mp3-Dateien sind im Dateisystem nur nach Artist und Album untergliedert. Die weitere Unterteilung, z.B. in Stil: Klassik, Pop, Jazz, Blues etc. passiert in einer selbstgestrickten Datenbank-Anwendung (CDMagic, ein Programm, das vor 10 Jahren hier auch schon einige Dutzend Anwender gefunden hatte; was aber in Zeiten von Streaming, Spotify etc. aus der Mode gekommen ist).

In meiner bisherigen, vor-NAS-Welt, waren alle diese MP3-Dateien auf lokalen Fetsplatten gespeichert. Aus historischen Gründen aber auf mehrere Festplatten verteilt. Das CDMagic-Programm ist darauf ausgelegt, einen gesuchten Titel auf einem beliebigen Laufwerk zu finden, solange dort ein Unterverzeichnis x:\CDMagic existiert. Das hat aber im Laufe der Jahre zu einiger Unübersichtlichkeit geführt (z.B. Doubletten), sodass ich froh war, mit der NAS ein Speichersystem zu haben, das es mir erlaubt, sämtliche MP3-Dateien an einem Ort zu speichern, ein Ort, der per Samba einem Laufwerksbuchstaben zugeordnet wird.

Das hat ja zu Beginn auch prima geklappt (tut's ja auch immer noch). Es sind die Anwendungen drumherum, die Probleme machen. Z.B. PMView, denn ausser MP3-Dateien besteht meine Musiksammlung auch aus JPG- und BMP-Dateien, Album-Cover, gescannte Zeitungsartikel (über Konzerte, etc.). Und so fing der ganze Ärger an: Es war PMView, das zuerst dadurch auffiel, dass es beim Suchen nach JPG-Dateien auf dem Z:-Laufwerk abstürzte und die Samba-Verbindung mitriß. Bei dem Versuch, dem vermeintlichen PMView-Fehler auf die Spur zu kommen, habe ich festgestellt, dass auch andere Programme betroffen sind, wobei das gemeinsame Element die Verwendung dieses erweiterten FOC ist.
LotharS wrote:Nur rein technisch sei erwähnt, dass Du sehr wohl ganz flexibel z.B ein Share der Art qnapMusik auf Mount Z:\Musik, qnapVideos auf Z:\Videos, qnapBilder auf Z:\Bilder gleichzeitig mounten kannst, ...
Ja, das geht wohl. Das ähnelt dann meinem bisherigen System, wo die MP3s auf mehreren lokalen Laufwerken verteilt waren. Davon wollte ich eigentlich weg.

Und ich bin immer noch voller Hoffnung, dass die Probleme ausgeräumt werden können, entweder durch die Entdeckung bisher unbekannter Parameter (maxfiles o.ä.) oder eben Warten auf ein neues Samba in ArcaOS 5.1. Obgleich ich ja der Meinung bin, dass nicht Samba, sondern der FOC den Bug enthält.

Notfalls muß ich eben weiterhin auf den schicken neuen FOC verzichten ... Und mit der Verwendung bestimmter, PM-basierter Programme vorsichtig umgehen. ;)

Gruß,
Don Lucio.