USB keyboard: Tester mit keybard mit LEDs gesucht

(DE) Neuigkeiten zu den Themen OS/2, eCS, und dem OS/2-Forum
(EN) News about OS/2, eCS and the OS/2 Forum
erdmann
Posts: 288
Joined: Mon 4. Jan 2016, 14:36

USB keyboard: Tester mit keybard mit LEDs gesucht

Post by erdmann » Sun 16. Oct 2016, 18:11

Hallo,

während ich gerade USBD.SYS upgedated habe um die Fehler in 10.208 zu beheben bin ich über einen Fehler in USBKBD.SYS gestolpert.
Gäbe es jemanden mit einem USB keyboard mit LEDs (für NumLock,ScrollLock,ShiftLock) der den upgedateten USBKBD.SYS testen würde ?
Der ggw. USBKBD.SYS (Version <= 10.208) wird wahrscheinlich die LEDs nicht richtig setzen. Das sollte jetzt behoben sein aber ich brauche da Rückmeldung weil mein USB keyboard keine LEDs hat.

Lars

User avatar
ak120
Posts: 956
Joined: Thu 8. May 2014, 12:50
Location: Demmin

Post by ak120 » Mon 17. Oct 2016, 00:13

Das Zusammenspiel mit einer über USB angeschlossenen Tastatur ist in der Tat sehr merkwürdig. Ich habe mal die Version 10.208 getestet. Normalerweise ist eine PS/2-Tastatur angeschlossen, welche wie erwartet funktioniert.
Schließt man nun eine USB-Tastatur (mit LED) an, wird diese auch erkannt. Die Funktion der Feststelltasten für Rollen und Ziffernblock inklusive der Signalisierung per LED ist ebenfalls gegeben. Allerdings erleuchtet bei Betätigung der Umschaltsperre (Caps Lock) die LED nicht.
Nun wird es richtig interessant:
Drückt man die entsprechenden Feststelltasten auf der ebenfalls noch angeschlossenen PS/2-Tastatur ändern sich nicht nur die LED-Anzeigen auf dieser, sondern auch auf der USB-Tastatur. Das gleiche funktioniert auch in umgekehrter Richtung. Irgendwann nach einer Kombination von Umschaltvorgängen mit den Feststelltasten ist es dann auch an der USB-Tastatur möglich, daß die CapsLock-LED erleuchtet.
Es kann sein, daß der OS/2-Tastaturtreiber nicht besonders clever ist. Hier nur mit 2 Tastaturen deutscher Belegung erprobt.
Bei Bedarf kann ich noch das Verhalten mit den IBM-Treibern testen.

erdmann
Posts: 288
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Mon 17. Oct 2016, 05:10

Soweit ich das beurteilen kann ist die Kopplung zwischen PS/2 Tastatur und USB Tastatur Absicht und zwar sowohl in Hinsicht auf den Zustand der ScrollLock, NumLock und ShiftLock Tasten als auch der zugehörigen LED Anzeige (logisch daß wenn die Tasten den gleichen Zustand haben sollen die entsprechenden LEDs natürlich auch den gleichen Zustand haben sollen).

Allerdings bin ich überrascht daß das Setzen der LEDs auf der USB Tastatur überhaupt funktioniert. Oder funktioniert das nicht zuverlässig ? Würden sie den neuen USBKBD.SYS testen ? Eine Änderung ist in jedem Fall nötig weil es neben der LED Problematik noch ein weiteres Problem gibt welches ich mit meiner Tastatur (ohne LEDs) beobachten konnte.
Den alten Treiber brauchen sie nicht zu testen, das würde jetzt auch nicht (mehr) helfen.

LutzG
Posts: 87
Joined: Mon 23. Dec 2013, 14:24

Post by LutzG » Tue 18. Oct 2016, 14:14

erdmann wrote:Gäbe es jemanden mit einem USB keyboard mit LEDs (für NumLock,ScrollLock,ShiftLock) der den upgedateten USBKBD.SYS testen würde ?
Lars
Kann ich gern mal machen (Cherry MX-Board 3.0)

Geht wahrscheinlich nur mit USB-Komplettpaket?

Gruß
Lutz
Zuletzt geändert von LutzG am Tue 18. Oct 2016, 14:15, insgesamt 1-mal geändert.

User avatar
ak120
Posts: 956
Joined: Thu 8. May 2014, 12:50
Location: Demmin

Post by ak120 » Tue 18. Oct 2016, 18:33

Wie schon geschrieben, funktioniert die Signalisierung für Rollen und Num absolut zuverlässig, nur für die Umschaltsperre störrisch bis unzuverlässig. Ich habe es zum Vergleich auch an einem Windows- und Mac-System getestet, um einen Wackelkontakt der LED auszuschließen. Ich kann den neuen Treiber gerne testen, kann ihn aber nirgends finden.

LutzG
Posts: 87
Joined: Mon 23. Dec 2013, 14:24

Post by LutzG » Thu 20. Oct 2016, 15:27

erdmann wrote:Gäbe es jemanden mit einem USB keyboard mit LEDs (für NumLock,ScrollLock,ShiftLock) der den upgedateten USBKBD.SYS testen würde ?
Woher bekomme ich den?

Gruß
Lutz

User avatar
hanno
Posts: 97
Joined: Thu 9. Jan 2014, 22:20

Post by hanno » Fri 11. Nov 2016, 13:14

Hallo,

erstmals vielen Dank für die ständige Pflege und Weiterentwicklung der USB-Treiber! :D

Bezüglich LED der Num-Lock-Taste stelle ich (derzeit Version 10.210 installiert) fest, dass die LED ab und zu nicht leuchtet, obwohl Num-Lock "on" ist.
Leider konnte ich noch nicht wirklich feststellen, dass da eine Regelmäßigkeit dahinter wäre. Nach einem Neustart ist es o.k., bei Warmstarts in manchen Situationen aber nicht - fragt sich nur wann ...
Was ich aber nicht wirklich verstehe ist, dass ich die Tastatur am PS/2-Port angeschlossen habe (es ist zwar eine USB-Tastatur, Fujitsu Siemens KBPC PX D) und trotzdem: vor der Inst. der neuen USB-Treiber habe ich ein solches Verhalten nie bemerkt.

Schöne Grüße
Hanno
Zuletzt geändert von hanno am Fri 11. Nov 2016, 13:25, insgesamt 1-mal geändert.