pmMail SSL Verschlüsselung einrichten?

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
Martin Vieregg
Beiträge: 210
Registriert: Di 19. Aug 2014, 09:30

pmMail SSL Verschlüsselung einrichten?

Beitrag von Martin Vieregg » Do 14. Feb 2019, 15:17

Ich benutze pmMail 3.11 (ich weiß es gibt auch schon neuere Versionen, die sind aber deutlich langsamer). Mein E-Mail Provider schreibt mir, dass er bis Ende des Monats nur noch SSL-verschlüsselte E-Mails zuläßt. Wie stelle ich das in pmMail ein?

Unter "New features and enhancements" in der Doku wird etwas dazu aufgeführt:

Secure Transfer
The Secure Transfer feature, which uses Stunnel (http://stunnel.mirt.net/), adds the option to communicate with mail servers that offer encrypted transfers based on the Secure Socket Layer (SSL) protocols.

Ich weiß aber trotzdem nicht, wie ich das aktiviere. Der Provider hat mir URLs geschickt, die ich für SSL in meinem Mailprogramm eingeben muss.

Benutzeravatar
Frank Wochatz
Beiträge: 956
Registriert: So 22. Dez 2013, 22:04
Wohnort: Berlin

Beitrag von Frank Wochatz » Do 14. Feb 2019, 17:27


erdmann
Beiträge: 265
Registriert: Mo 4. Jan 2016, 14:36

Beitrag von erdmann » Do 14. Feb 2019, 18:06

Frank Wochatz hat geschrieben:
Do 14. Feb 2019, 17:27
[Tutorial] PMMail mit SSL-Verschlüsselung


HTH
Frank
Nach allem was ich so gelesen habe würde ich folgendes versuchen:

Code: Alles auswählen

socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
client = yes
output = stunnel.log
verify = 0
debug  = 7

[popMeinEmailProvider]
accept = localhost:110
connect = popServerMeinesEmailProviders:995
delay = yes
protocol = pop3

[smtpMeinEmailProvider]
accept = localhost:25
connect = smtpServerMeinesEmailProviders:587
delay = yes
protocol = smtp
Eventuell muss es auch sein:

Code: Alles auswählen

[smtpMeinEmailProvider]
accept = localhost:25
connect = smtpServerMeinesEmailProviders:465
delay = yes
protocol = smtp
Was jetzt passieren sollte ist folgendes: das "alte" Emailprogramm versucht unverschlüsselt per POP3 Emails zu empfangen: es connected sich via port 110 mit stunnel. stunnel connected sich via port 995 mit deinem Emailprovider. Wenn das alles klappt sendet dein Emailprovider die Daten an stunnel welche sie entschlüsselt und dann zu deinem Emailprogramm weiter überträgt.

Das gleiche sinngemäß für die Senderichtung (smtp). Für secure SMTP sind zwei Ports gängig (587 oder 465). Da musst du ausprobieren welcher von deinem Emailprovider unterstützt wird (es sei denn er hat dir dies bereits mitgeteilt).
Zuletzt geändert von erdmann am Do 14. Feb 2019, 18:06, insgesamt 1-mal geändert.

ehemaliger
Beiträge: 70
Registriert: Mi 22. Nov 2017, 23:46

Beitrag von ehemaliger » So 17. Feb 2019, 20:54

erdmann hat geschrieben:
Do 14. Feb 2019, 18:06
Für secure SMTP sind zwei Ports gängig (587 oder 465). Da musst du ausprobieren welcher von deinem Emailprovider unterstützt wird...
SMTP via SSL verwendet 465. Der Port 587 wird üblicherweise in Zusammenhang mit STARTTLS benutzt (1). In diesem Fall baut der Client zunächst eine ungesicherte Verbindung auf und schaltet erst nach entsprechender Featureabfrage in den gesicherten Modus. Ob das mit diesem Tunnelkonstrukt funktioniert, kann ich nicht sagen. Eigentlich ist ein Mailprogramm, das SSL/TLS nicht beherrscht, ein absolutes Unding! Ich habe früher auch PMMail benutzt und fand das Programm gut. Aber selbst als OS/2 noch mein Hauptsystem war, wurde es irgendwann unakzeptabel, weil es viele (HTML-) Nachrichten nicht korrekt anzeigen konnte. Ich bin damals auf Thunderbird umgestiegen, was den Charme hatte, sich auf den verschiedensten von mir genutzten Betriebssystemen einigermaßen gleich zu verhalten.

(1) Streng genommen kommt 587 immer dann zum Einsatz, wenn eine SMTP-Authentifizierung erforderlich ist. Und zwar unabhängig davon, ob mit oder ohne Verschlüsselung. Auf dem früher für SMTP verwendeten Port 25 (ohne Authentifizierung) akzeptieren die Server zwecks Spamvermeidung in der Regel nur noch Mails an Nutzer innerhalb der Domain, für die dieser Server zuständig ist bzw. an diesem Server namentlich bekannte Nutzer.
Zuletzt geändert von ehemaliger am So 17. Feb 2019, 20:56, insgesamt 1-mal geändert.

eCSBenutzer
Beiträge: 231
Registriert: Fr 10. Jan 2014, 07:24
Wohnort: 641m ü. NN

Beitrag von eCSBenutzer » Mo 18. Feb 2019, 07:33

ehemaliger hat geschrieben:
So 17. Feb 2019, 20:54
... Eigentlich ist ein Mailprogramm, das SSL/TLS nicht beherrscht, ein absolutes Unding! ....
Ich gebe Dir recht. Aber: PMMail ist m.W. das einzige Mailprogramm, was schon auf dem betreffenden Mailserver unerwünschte Sachen (SPAM) löschen kann.
Deshalb sortiere ich mit PMMail die Nachrichten auf dem Server ( und speichere diese als "Backup") und lade diese dann mit TB runter. Ist zwar ein grösserer Aufwand aber hat sich bewährt.

Hier meine Einstellungen für Web.de GMX und T-Online:

Code: Alles auswählen

cert = stunnel.pem
socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
client = yes
debug = 7
verify = 0
output = E:/Internet/Stunnel/stunnel.log 


[t-online_pop3s]
accept = localhost:995
connect = securepop.t-online.de:995
delay = yes
;# protocol = pop3

[t-online_smtps]
accept = localhost:465
connect = securesmtp.t-online.de:465
delay = yes
;# protocol = smtp 

[pop3s]
accept = localhost:996
connect = pop.gmx.net:995
delay = yes
;# protocol = pop3

[smtps]
accept = localhost:466
connect = mail.gmx.net:465
delay = yes
;# protocol = smtp

[pop1und1]
accept = localhost:997
connect = pop3.web.de:995
delay = yes
;# protocol = pop3 

[smtp1und1]
accept = localhost:467
connect = smtp.web.de:465
delay = yes
;# protocol = smtp

Andi B.
Beiträge: 437
Registriert: Di 24. Dez 2013, 16:40

Beitrag von Andi B. » Mo 18. Feb 2019, 10:02

Ich gebe Dir recht. Aber: PMMail ist m.W. das einzige Mailprogramm, was schon auf dem betreffenden Mailserver unerwünschte Sachen (SPAM) löschen kann.
Wie das? Läuft auf dem Server ein PMMail? Oder meinst du das "Nur Kopfzeilen runterladen" Feature von z.B. Seamonkey?

Benutzeravatar
Frank Wochatz
Beiträge: 956
Registriert: So 22. Dez 2013, 22:04
Wohnort: Berlin

Beitrag von Frank Wochatz » Mo 18. Feb 2019, 11:20

Du hast schon recht, Ehemaliger. Das Programm ist eigentlich hoffnungslos veraltet. Aber damit kennen wir uns ja aus. ;) Mit stunnel kann man zumindest SSL nachrüsten. Ich benutze PMMail aus Gewohnheit und wg. der Filterfunktionen zum Sortieren der Mails, zum Glück bekomme ich kaum HTML Mails.

Martin Vieregg
Beiträge: 210
Registriert: Di 19. Aug 2014, 09:30

Beitrag von Martin Vieregg » Mi 27. Feb 2019, 23:39

Danke für die Beschreibungen. Ich denke das meiste habe ich schon hinbekommen, aber es läuft noch nicht. Ich habe die stunnel.conf editiert, sie sieht aktuell so aus (für Strato):

Code: Alles auswählen

socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
;client = yes
output = H:\software\pmmail3\bin\stunnel\stunnel.log
verify = 0
debug = 7

[popstrato]
accept = localhost:995
connect = pop3.strato.de:110
delay = yes
cert = H:\software\pmmail3\bin\stunnel\stunnel.pem

[smtpstrato]
accept = localhost:465
connect = smtp.strato.de:25
delay = yes
cert = H:\software\pmmail3\bin\stunnel\stunnel.pem
Ich musste "client = yes" auskommentieren und pem-Zertifikatsdateien angeben. Ich habe die verwendet, die im pmMail enthalten war. (Soll ich die ändern?)

Es kommen jetzt keine Fehlermeldungen mehr, aber pmMail bleibt bei "Connecting to server" stehen. STunnel gibt keine Fehlermeldungen aus.

Code: Alles auswählen

[H:\software\pmmail3\bin\stunnel]H:\software\util\stunnel452\bin\stunnel stunnel
.conf
2019.02.27 23:25:53 LOG7[270:1]: Clients allowed=1000
2019.02.27 23:25:53 LOG5[270:1]: stunnel 4.52 on i386-pc-os2-emx built by Steven
 H. Levine on Feb 28 2012
2019.02.27 23:25:53 LOG5[270:1]: Compiled/running with OpenSSL 1.0.0f 4 Jan 2012

2019.02.27 23:25:53 LOG5[270:1]: Threading:PTHREAD SSL:ENGINE Auth:none Sockets: SELECT,IPv4
2019.02.27 23:25:53 LOG5[270:1]: Reading configuration from file stunnel.conf
2019.02.27 23:25:53 LOG7[270:1]: Compression not enabled
2019.02.27 23:25:53 LOG7[270:1]: PRNG seeded successfully
2019.02.27 23:25:53 LOG6[270:1]: Initializing SSL context for service popstrato
2019.02.27 23:25:53 LOG7[270:1]: Certificate: H:\software\pmmail3\bin\stunnel\stunnel.pem
2019.02.27 23:25:53 LOG7[270:1]: Certificate loaded
2019.02.27 23:25:53 LOG7[270:1]: Key file: H:\software\pmmail3\bin\stunnel\stunnel.pem
2019.02.27 23:25:53 LOG7[270:1]: Private key loaded
2019.02.27 23:25:53 LOG7[270:1]: Using DH parameters from H:\software\pmmail3\bin\stunnel\stunnel.pem
2019.02.27 23:25:53 LOG7[270:1]: DH initialized with 512-bit key
2019.02.27 23:25:53 LOG7[270:1]: ECDH initialized with curve prime256v1
2019.02.27 23:25:53 LOG7[270:1]: SSL options set: 0x00000004
2019.02.27 23:25:53 LOG6[270:1]: SSL context initialized
2019.02.27 23:25:53 LOG6[270:1]: Initializing SSL context for service smtpstrato

2019.02.27 23:25:53 LOG7[270:1]: Certificate: H:\software\pmmail3\bin\stunnel\stunnel.pem
2019.02.27 23:25:53 LOG7[270:1]: Certificate loaded
2019.02.27 23:25:53 LOG7[270:1]: Key file: H:\software\pmmail3\bin\stunnel\stunnel.pem
2019.02.27 23:25:53 LOG7[270:1]: Private key loaded
2019.02.27 23:25:53 LOG7[270:1]: Using DH parameters from H:\software\pmmail3\bin\stunnel\stunnel.pem
2019.02.27 23:25:53 LOG7[270:1]: DH initialized with 512-bit key
2019.02.27 23:25:53 LOG7[270:1]: ECDH initialized with curve prime256v1
2019.02.27 23:25:53 LOG7[270:1]: SSL options set: 0x00000004
2019.02.27 23:25:53 LOG6[270:1]: SSL context initialized
2019.02.27 23:25:53 LOG5[270:1]: Configuration successful
2019.02.27 23:25:53 LOG7[270:1]: Service popstrato bound FD=8 to 127.0.0.1:995
2019.02.27 23:25:53 LOG7[270:1]: Service smtpstrato bound FD=9 to 127.0.0.1:465
2019.02.27 23:25:58 LOG7[270:1]: Service popstrato accepted FD=11 from 127.0.0.1:52447
2019.02.27 23:25:58 LOG7[270:2]: Service popstrato started
2019.02.27 23:25:58 LOG5[270:2]: Service popstrato accepted connection from 127.0.0.1:52447
Der pmmail Error.log gibt nach gewisser Zeit aus:

Mi, 27 Feb 2019 23.28.01 ==> Error: Connection timed out


Was ich nicht so richtig verstehe:

(1) Was soll ich eigentlich auf der Seite pmMail Settings - Secure Transfer eintragen? Wenn ich das STunnel Programm extern starte, muss ich überhaupt etwas eintragen, außer "enable Tunnel" ? Kann ich es überhaupt über pmMail starten und wenn ja, wie gebe ich dann den Dateinamen der stunnel.conf Datei an?

(2) Gehe ich recht in der Annahme, dass man im Einstellungen-Buch nur noch "localhost" angibt und die eigentlichen Adressen jetzt in der stunnel.conf Datei stehen?

(3) Ich benutze die etwas ältere pmMail 3.11 und stunnel 4.52. Warum kann ich die neueren Versionen (5.41) nicht herunterladen? Auf Paul Smedleys stunnel Seite kann man die Zip-Dateien nicht auspacken, die scheinen beschädigt zu sein.

Ich würde mich sehr über weiterer Tipps freuen, an was es liegen könnte, dass es noch nicht richtig läuft.

Benutzeravatar
Frank Wochatz
Beiträge: 956
Registriert: So 22. Dez 2013, 22:04
Wohnort: Berlin

Beitrag von Frank Wochatz » Do 28. Feb 2019, 14:11

Ich benutze erfolgreich stunnel 4.52 mit PMMail 2.20 mit 1und1.


Bei sind keine Zertifikate angegeben, aber noch die Protokolle:

Code: Alles auswählen

socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
client = yes
output = stunnel.log
verify = 0
debug  = 0

[smtp1und1]
  accept  = localhost:465
  connect = smtp.1und1.de:25
  delay   = yes
  protocol = smtp

[pop1und1]
  accept  = localhost:995
  connect = pop.1und1.de:110
  delay   = yes
  protocol = pop3
Wenn du stunnel extern startest, musst du wahrscheinlich in PMMail 3.x garnichts einrichten und auch stunnel nicht auf "enable" setzen (womöglich wird stunnel dann nochmal gestartet - nur eine Vermutung, ich benutze halt die alte PMMail Version), nur die Server entsprechend auf Localhost mit dem richtigen Port einstellen. Authenticate steht bei mir auf "passwords". Warum du bei dir client = yes auskommentieren mußt, verstehe ich nicht.

Da du nun schon PMMail 3.x hast kannst du natürlich auch stunnel aus PMMail automatisch aufrufen. Dann halt nicht extern aufrufen.
Zuletzt geändert von Frank Wochatz am Do 28. Feb 2019, 14:12, insgesamt 1-mal geändert.

Benutzeravatar
LotharS
Beiträge: 549
Registriert: So 29. Dez 2013, 20:07
Wohnort: Düsseldorf

Beitrag von LotharS » Do 28. Feb 2019, 14:52

Versuchs mal mit folgenden zusätzlichen Zeilen "oben":

Code: Alles auswählen

sslVersion = all
options = NO_SSLv2

Ohne ging t-online nicht mehr.
Hier sind "client = yes" gesetzt, "protocol = ..." auskommentiert, "debug = 7" mal für alle Fälle.

Die Einträge bie "accept = ..." müssen mit den "server"-Einstellungen in den Account settings übereinstimmen.
Die Einträge bei "connect = ..." sind vom Provider vorgegeben und finden sich auch in den "Secure Transfer"-Channel-Settings.
Sieht dann hier insgesamt so aus:

Code: Alles auswählen

socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
client = yes
output = e:/APPS/PMMAIL/BIN/stunnel.log
verify = 0
debug  = 7

sslVersion = all
options = NO_SSLv2

[t-online_pop3s]
  accept  = localhost:995
  connect = securepop.t-online.de:995
  delay   = yes
;#  protocol = pop3

[t-online_smtps]
  accept  = localhost:465
  connect = securesmtp.t-online.de:465
  delay   = yes
;#  protocol = smtp
Eine Verrücktheit kann bei neueren Telekom-Routern vorkommen: Manchmal muss man erst den SMTP-Server des Providers darin als "vertrauenswürdig" eintragen. Was auch immer die sich dabei gedacht hatten oder auch nicht.

Martin Vieregg
Beiträge: 210
Registriert: Di 19. Aug 2014, 09:30

Beitrag von Martin Vieregg » Do 28. Feb 2019, 15:44

Ich habe die Vorschläge umgesetzt, es geht leider immer noch nicht. Ich werde mal bei Strato fragen, ob es eine fertige stunnel.conf Datei gibt.

Was ich noch gar nicht verstehe, was ich bei der Einstellungen-Seite Secure Transfer in pmmail eintragen soll. Momentan mache ich dort jetzt gar nichts, sondern mache es extern. Zwei Dinge verstehe ich nicht:

- Wo trage ich den Dateienamen der stunnel.conf Datei ein?
- Was sind Channel Definitions? Brauche ich die? Wenn ja, was muss ich da eintragen?

Benutzeravatar
LotharS
Beiträge: 549
Registriert: So 29. Dez 2013, 20:07
Wohnort: Düsseldorf

Beitrag von LotharS » Fr 1. Mär 2019, 11:32

Martin Vieregg hat geschrieben:
Do 28. Feb 2019, 15:44
Ich werde mal bei Strato fragen, ob es eine fertige stunnel.conf Datei gibt.
Vielleicht geht's schneller, mal auf deren Webseite nach den nötigen Einstellungen unter den Stichworten 'Mail' und 'SSL' zu forschen. Die Namen dieser Server und Port-Nrn gehören dann in die "connect = ..." -Einträge in stunnel.conf. Probier da mal die Ports 995 bzw. 465 od. 587.
- Wo trage ich den Dateienamen der stunnel.conf Datei ein?
- Was sind Channel Definitions? Brauche ich die? Wenn ja, was muss ich da eintragen?
- Sämtliche stunnel.*-Dateien befinden sich hier einfach unter ...\pmmail\bin und werden von dort verwendet. Zwar habe ich daneben ein Unterverzeichnis "stunnel", aber darin sind nur die nach dem Download zunächst ausgepackten Dateien.
- Die "Channel Definitions" beinhalten genau den unteren Teil der stunnel.conf.

Im übrigen lohnt es sich, in die Logs zu schauen (stunnel.log und ....\accounts\logfile.log), wobei "accounts" das selbst wählbare Arbeitsverzeichnis ist (dürfte z.B. auch unter %HOME% liegen). Liefert selten direkt eine Problemlösung, zeigt aber wo's "aus dem Gleis gesprungen" ist.

Martin Vieregg
Beiträge: 210
Registriert: Di 19. Aug 2014, 09:30

Beitrag von Martin Vieregg » Fr 1. Mär 2019, 16:42

Danke Lothar. Ich kann jetzt zumindest einen Teilerfolg vermelden.

Ich habe folgendes geändert:
- stunnel.conf in den pmmail3\bin Pfad verschoben
- die alte stunnel.exe 4.26, die bei pmMail 3.11 enthalten war, durch die Version 4.52 ersetzt.
- stunnel über die Seite "Security transfer" direkt in pmMail eingebunden.

Jetzt kann ich immerhin empfangen, Senden geht noch nicht.
Korrektur: Es ist genau umgekehrt. Ich kann Senden, aber nicht empfangen, entschuldigung.

Die technischen Angaben mit Zahlen und Adressen wurden mir von Strato zugesandt, 995 und 465 stimmt.

Der pmMail Error log gibt aus: Error: Connection reset by peer

pmmail editiert jetzt die stunnel.conf Datei von selbst, er hat auch Zeilen gelöscht. Jetzt steht darin:

Code: Alles auswählen

socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
client = yes
output = H:/SOFTWARE/PMMAIL3/BIN/stunnel.log
verify = 0
debug  = 7

[popstrato]
  accept  = localhost:995
  connect = pop3.strato.de:110
  delay   = yes
;#  protocol = xxxx

[smtpstrato]
  accept  = localhost:465
  connect = smtp.strato.de:25
  delay   = yes
  protocol = smtp
Man sieht jetzt, dass auf der pmMail Secure Transfer Einstellungen Seite die "Channel Definitions" Inhalte der stunnel.conf darstellen. Was mich stutzig macht, ist dass ich, wenn ich "modify" drücke und mir die Werte einer der zwei Zeilen popstrato und smtpstrato anzeigen lasse, bei popstrato beim Drücken auf OK die Fehlermeldung kommt: Missing Information - All entry fields are required, obwohl der Haken "Channel encryption is optional" nicht gesetzt ist. Kann es sein, dass ich für das Empfangen tatsächlich ein CA file benötige? Wenn ja, was ist das und wie mache ich das?
Zuletzt geändert von Martin Vieregg am Fr 1. Mär 2019, 17:53, insgesamt 1-mal geändert.

Benutzeravatar
Frank Wochatz
Beiträge: 956
Registriert: So 22. Dez 2013, 22:04
Wohnort: Berlin

Beitrag von Frank Wochatz » Fr 1. Mär 2019, 16:50

Martin Vieregg hat geschrieben:
Fr 1. Mär 2019, 16:42
Kann es sein, dass ich für das Empfangen tatsächlich ein CA file benötige? Wenn ja, was ist das und wie mache ich das?

Du hast doch weiter oben geschreiben, dass du jetzt bereits empfangen kannst, und nur Senden nicht geht. Da würde ich die Pop-Einstellungen doch mal so lassen wie sie jetzt sind.

Bei Senden über SMTP könnte es an der Art der Authentifizierung liegen. Die muss wahrscheinlich angeschaltet und die enstprechenden Daten müssen hinterlegt sein (User ID und Passwort). Und SMTP muss natürlich zum Senden ausgewählt sein,

PS: Manchmal muss auch "Send after fetch" aktiviert werden.
Zuletzt geändert von Frank Wochatz am Fr 1. Mär 2019, 16:52, insgesamt 2-mal geändert.

Martin Vieregg
Beiträge: 210
Registriert: Di 19. Aug 2014, 09:30

Beitrag von Martin Vieregg » Fr 1. Mär 2019, 17:52

Oops, nein es ist umgekehrt. Ich kann Senden, aber nicht empfangen. Auf der Seite "Receive" habe ich einen Haken bei POP3, dann als POP server "localhost" und "995" eingetragen, dann folgt User ID und Passwort. Dann ein Radiobutton bei "Plain text" und als einzigen weiteren Haken auf der Seite ein "Validate RFC822 Internet message format".

Benutzeravatar
Frank Wochatz
Beiträge: 956
Registriert: So 22. Dez 2013, 22:04
Wohnort: Berlin

Beitrag von Frank Wochatz » Fr 1. Mär 2019, 18:23

Bei PMMail 3.x kann ich leider nicht weiter helfen. bei der alten Version konnte man noch den Authentifizierungstyp einstellen, und der muss natürlich der Serverseite entsprechen. Hier "Passwords" statt RPA oder APOP. Ich weiss allerdings auch nicht was Strato da macht.

Ansonsten sieht es so aus, dass man die volle Flexibilität der Stunnel-Config hat, wenn man es extern startet. die Config wird als Parameter übergeben. Dann kannst du da alles reinschreiben, und PMMail ändert dann auch nichts.

Ist leider 'ne anstrengende Bastelei....

aschn
Beiträge: 805
Registriert: Mi 25. Dez 2013, 22:47

Beitrag von aschn » Fr 1. Mär 2019, 18:45

Ist die Serveradresse für Strato vielleicht nicht richtig?
Andreas Schnellbacher

ehemaliger
Beiträge: 70
Registriert: Mi 22. Nov 2017, 23:46

Beitrag von ehemaliger » Fr 1. Mär 2019, 19:42

Martin Vieregg hat geschrieben:
Fr 1. Mär 2019, 16:42
Die technischen Angaben mit Zahlen und Adressen wurden mir von Strato zugesandt, 995 und 465 stimmt.
Und warum steht dann in Deiner Konfiguration bei "connect = " etwas anderes ???

aschn
Beiträge: 805
Registriert: Mi 25. Dez 2013, 22:47

Beitrag von aschn » Fr 1. Mär 2019, 19:49

Na, das Ratespiel war ja einfach. Das gilt für beide "connect"-Zeilen.
Andreas Schnellbacher

Benutzeravatar
LotharS
Beiträge: 549
Registriert: So 29. Dez 2013, 20:07
Wohnort: Düsseldorf

Beitrag von LotharS » Fr 1. Mär 2019, 20:49

Martin Vieregg hat geschrieben:
Fr 1. Mär 2019, 16:42

pmmail editiert jetzt die stunnel.conf Datei von selbst, er hat auch Zeilen gelöscht. Jetzt steht darin:
...
connect = pop3.strato.de:110
delay = yes
;# protocol = xxxx
...
connect = smtp.strato.de:25
delay = yes
protocol = smtp
...
"von selbst"? Vermutlich eher doch nach Ändern im Settings-Notizbuch :)

Deine Port-Nrn bei connect (Server Port) sind nicht SSL-konform; mindestens da gehören die von Strato genannten 995 bzw. 465 hin.
Die Port-Nrn am accept-Ende (dh. localhost) dürfen ebenfalls 995 bzw. 465 lauten und müssen mit denen bei Receive bzw. Send in den Account settings übereinstimmen. Sie dürfen auch anders lauten, z.B. 110/25 für ein weiteres Konto mit dann passenden Channel Definitions, solange es für den localhost keine Kollisionen mit anderweitig belegten Ports gibt.

Die Zeilen protocol = ... sind hier dann jeweils auskommentiert, müssen bei SSL glaub'ich auch.

Der Trick mit den zusätzlichen Zeilen

Code: Alles auswählen

sslVersion = all
options = NO_SSLv2

war seinerzeit nötig zumindest bei t-online (evtl. auch anderen Providern); diese müssen vermutlich immer wieder händisch in den oberen Teil der stunnel.conf eingefügt werden. Den Tipp hatte ich irgendwo bei den Linuxern ausgegraben und voilà.

Trotz SSL ist in den Account Settings bei "Send" der Haken bei "Allow non secure" zu setzen. Das Einloggen geschieht üblich im Klartext, die Nachrichten selber dann aber verschlüsselt versandt.

Mag sein, dass nach Änderung der Konfiguration PMMail neu gestartet werden sollte/muss (kostet ja nix ;) ).

Bleibt noch der weiter oben erwähnte Hinweis, dass bei manchen (z.B. neueren Telekom-) Routern obendrein der smtp-Server extra als "vertrauenswürdig" eingetragen werden muss; dieser Quatsch ist mir bei Bekannten schon wiederholt entgegengelaufen.

Martin Vieregg
Beiträge: 210
Registriert: Di 19. Aug 2014, 09:30

Beitrag von Martin Vieregg » Fr 1. Mär 2019, 22:11

Danke für Eure Hinweise. Jetzt läuft alles. Die 110 bei POP3 sind nicht mehr relevant, doch bei SMTP ist 25 weiterhin erforderlich.

Jetzt nochmal alles zum Festhalten als würdiges Thread-Ende:

Hier also die Schritt-für-Schritt-Anleitung, wie man Strato Mail mit PMMail 3.11 richtig einrichtet:

(1) STUNNEL 4.52 von Netlabs herunterladen, EXE-Datei nach \PMMAIL3\BIN als STUNNEL452.EXE spielen

(2) Textdatei STUNNEL.CONF im selben Verzeichnis anlegen:

Code: Alles auswählen

socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
client = yes
output = stunnel.log
verify = 0
debug  = 7

[popstrato]
  accept  = localhost:995
  connect = pop3.strato.de:995
  delay   = yes
;#  protocol = xxxx

[smtpstrato]
  accept  = localhost:465
  connect = smtp.strato.de:25
  delay   = yes
  protocol = smtp

Bei Output= kann man ggfs. noch ein anderes Verzeichnis angeben, andernfalls wird es in das PMMAIL3\BIN Verzeichnis geschrieben.

(3) Unter Account - Settings - Receive
unter POP server "localhost", bei Port "995" eintragen

(4) Unter Account - Settings - Send
unter SMTP server "localhost" und bei Port "465" eintragen,
Haken muss bei "Server requires authentication" gesetzt sein, bei "Allow non-secure" muss der Haken nicht gesetzt sein.

(5) Unter PMMail - Settings - Secure Transfer Einen Haken bei "Enable Tunnel" setzen und bei "Path to executable" den Dateinamen des Executables anpassen (stunnel452.exe)

Das war's.
Zuletzt geändert von Martin Vieregg am Fr 1. Mär 2019, 23:47, insgesamt 1-mal geändert.

Benutzeravatar
LotharS
Beiträge: 549
Registriert: So 29. Dez 2013, 20:07
Wohnort: Düsseldorf

Beitrag von LotharS » Sa 2. Mär 2019, 09:37

Martin Vieregg hat geschrieben:
Fr 1. Mär 2019, 22:11
[smtpstrato]
accept = localhost:465
connect = smtp.strato.de:25
delay = yes
protocol = smtp

Das war's.
Na prima, wenn Strato zufällig nicht-SSL-verschlüsselte Mails dennoch akzeptiert. Ich wäre aber lieber deren Vorgaben gefolgt. Also connect = smtp.strato.de:465, und protocol dann auskommentieren. accept kannste so lassen, wenn es mit den "Send"-Settings zum Account übereinstimmt.

Alles weitere in vorangehenden Posts. Fehlermeldungen in den Logs sind oft "international", notfalls läst sich danach googeln und wird irgendwo passend - auch evtl. bei Linuxern - fündig.

ehemaliger
Beiträge: 70
Registriert: Mi 22. Nov 2017, 23:46

Beitrag von ehemaliger » Sa 2. Mär 2019, 10:43

Ich kann hier @LotharS nur zustimmen! Die gewählte Einstellung wird Probleme bereiten. Früher oder später...

Benutzeravatar
Frank Wochatz
Beiträge: 956
Registriert: So 22. Dez 2013, 22:04
Wohnort: Berlin

Beitrag von Frank Wochatz » Sa 2. Mär 2019, 11:54

Bei mir funktioniert das mit 1und1 im Prinzip genauso wie bei Martin.

Zwar empfiehlt 1und1 zB. für SLL und Pop den Port 995, allerdings unterstützt der Server auch den Port 110 TLS/STARTTLS. Bei SMTP ist der Alternativport für TLS/STARTTLS 25. Könnte bei Strato ähnlich sein.
Zuletzt geändert von Frank Wochatz am Sa 2. Mär 2019, 11:55, insgesamt 1-mal geändert.

Martin Vieregg
Beiträge: 210
Registriert: Di 19. Aug 2014, 09:30

Beitrag von Martin Vieregg » Sa 2. Mär 2019, 13:04

OK. Accept 465 geht, wenn man protokol auskommentiert. Hier nochmals die korrigierte Gesamtlösung, wie man Strato Mail mit PMMail 3.11 richtig einrichtet:

(1) STUNNEL 4.52 von Netlabs herunterladen, EXE-Datei nach \PMMAIL3\BIN als STUNNEL452.EXE spielen

(2) Textdatei STUNNEL.CONF im selben Verzeichnis anlegen:

Code: Alles auswählen

socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0
client = yes
output = stunnel.log
verify = 0
debug  = 7

[popstrato]
  accept  = localhost:995
  connect = pop3.strato.de:995
  delay   = yes

[smtpstrato]
  accept  = localhost:465
  connect = smtp.strato.de:465
  delay   = yes

Bei Output= kann man ggfs. noch ein anderes Verzeichnis angeben, andernfalls wird es in das PMMAIL3\BIN Verzeichnis geschrieben.

(3) Unter Account - Settings - Receive
unter POP server "localhost", bei Port "995" eintragen

(4) Unter Account - Settings - Send
unter SMTP server "localhost" und bei Port "465" eintragen,
Haken muss bei "Server requires authentication" gesetzt sein, bei "Allow non-secure" muss der Haken nicht gesetzt sein.

(5) Unter PMMail - Settings - Secure Transfer Einen Haken bei "Enable Tunnel" setzen und bei "Path to executable" den Dateinamen des Executables anpassen (stunnel452.exe)