GELÖST! - Hoppla unter ArcaOS - Fehlermeldung? Hilfe erbeten!!

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
User avatar
Sigurd
Posts: 808
Joined: Mon 23. Dec 2013, 08:35

GELÖST! - Hoppla unter ArcaOS - Fehlermeldung? Hilfe erbeten!!

Post by Sigurd »

Ja, wie das so ist. Ich nutze ja eigentlich bisher die eigene aufgemotzte OS/2 Version, aber für meine Warpstock Präsentation will ich natürlich ArcaOS 5.0.6 verwenden. Alles klappt eigentlich reibungslos, aber als ich jetzt Hoppla von Lutz Wagner entpackt habe und hoppla.exe starten will, kommt folgende Fehlermeldung:

Line 25 of Init in Hoppla.VRM:
+++ Call RxExtra 'LOAD';
*** Error 43 Routine not found
Line 45 of Main in Hoppla.VRM:
+++ Call Init;

Was mache ich falsch bzw. was fehlt? Für eine kurzfristige Hilfe wäre ich Dir sehr dankbar, da ich da noch einiges abfilmen muss, für Samstag.
Ich habe Lutz auch über seine Homepage angeschrieben, aber da die Zeit etwas drängt, wollte ich auch hier nachfragen, evtl. ist es nur ein "einfacher"
Fehler?

vrobj.dll habe ich schon in OS2/DLL des Bootlaufwerks kopiert.

Oder muss unter ArcaOS Vrexx installiert werden?

Vielen Dank schon einmal für Eure Mühe!
Last edited by Sigurd on Wed 4. Nov 2020, 16:23, edited 1 time in total.
OS/2 versus Hardware - Maximum Warp!

aschn
Posts: 1057
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Dir fehlt wahrscheinlich die RXEXTRAS.DLL. Martin hat das ZIP-Paket rxxg1.zip hier bereitgestellt. Früher war das Paket unter rexxtra erhältlich und es war Shareware.

Ich sehe gerade auf eCSoft/2: Das gibt's auch als RPM- oder ZIP-Paket auf netlabs.org.

Code: Select all

yum install rxextras
Last edited by aschn on Wed 4. Nov 2020, 00:18, edited 2 times in total.
Andreas Schnellbacher

User avatar
Sigurd
Posts: 808
Joined: Mon 23. Dec 2013, 08:35

Post by Sigurd »

Guten Morgen Andreas,

vielen Dank, aber das war es wohl nicht, jedenfalls nicht vollständig.

Ich erhalte nun diese Fehlermeldung

Line 26 of Init in Hoppla.VRM:
+++ Call PYRxInit;
*** Error 43 Routine not found
Line 45 of Main in Hoppla.VRM:
+++ Call Init;


Also nun Line 26 statt 25. Ich habe dann auch noch VisproRexx Gold installiert, das ändert aber auch nichts.

Gibt es da noch Ideen?

Vielen herzlichen Dank schon einmal!!
OS/2 versus Hardware - Maximum Warp!

User avatar
Sigurd
Posts: 808
Joined: Mon 23. Dec 2013, 08:35

Post by Sigurd »

Noch ein paar Zusatzinfos:

- auf dem Yoga habe ich "mein" OS/2 auf C: installiert
- ArcaOS ist auf D: installiert
- Hoppla habe ich jeweils auf jeder Partition
- von "Meinen OS/2" von C: aus lässt sich sowohl das Hoppla von C: als auch das von D: starten
- von ArcaOS aus von D: aus lässt sich weder das Hoppla von C: noch das von D: aus starten
-> deshalb habe ich das Problem auf ArcaOS eingegrenzt
-> ansonsten bliebe ja nur, das es evtl. mit dem Laufwerksbuchstaben zusammenhängt? Verlangt Hoppla C:?
-> PMDLL auf Hoppla.exe zeigt bei beiden (nach der Installation von Visprorexx auch auf D:) denselben "erfolgreichen" Baum an

-> ob jemand mal Hoppla testen kann, auf verschiedenen Laufwerken? Da es keine config.sys Änderungen etc. braucht, wäre es relativ gefahrlos möglich.


Wichtig: leider kann ich hier im Forum weder Mails schreiben noch empfangen, da mein Postfach mit 50 voll ist und das Löschen alter Nachrichten (hatte ich schon einmal, hatte Andreas dankenswerterweise schnelle Abhilfe geschaffen) wieder nicht geht.


Vielen Dank nochmals, habe ja leider nicht mehr viel Zeit bis Samstag und wollte halt alles unter ArcaOS zeigen.
Last edited by Sigurd on Wed 4. Nov 2020, 13:00, edited 1 time in total.
OS/2 versus Hardware - Maximum Warp!

Andi B.
Posts: 535
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

Hab hier die gleiche Fehlermeldung sowohl auf T:\ als auch auf C:\.

Du braucht wohl auch noch die pyrxutil.dll z.B. von hier -
http://ru2.halfos.ru/software/projects/pyrxutil/

Oder von deiner anderen Partition. Irgendwo muss die bei dir liegen und der Libpath von ArcaOS zeigt aber nicht dort hin.
Last edited by Andi B. on Wed 4. Nov 2020, 16:01, edited 2 times in total.

User avatar
Sigurd
Posts: 808
Joined: Mon 23. Dec 2013, 08:35

Post by Sigurd »

Andi B. wrote:
Wed 4. Nov 2020, 15:48
Hab hier die gleiche Fehlermeldung sowohl auf T:\ als auch auf C:\.

Du braucht wohl auch noch die pyrxutil.dll z.B. von hier -
http://ru2.halfos.ru/software/projects/pyrxutil/

Oder von deiner anderen Partition. Irgendwo muss die bei dir liegen und der Libpath von ArcaOS zeigt aber nicht dort hin.
Super Andreas, vielen Dank! Problem gelöst, läuft!!
OS/2 versus Hardware - Maximum Warp!