Secure Transfer Optionen in PMMAIL 3.x

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
GAKA
Posts: 32
Joined: Tue 3. Jun 2014, 15:58

Secure Transfer Optionen in PMMAIL 3.x

Post by GAKA » Mon 18. Aug 2014, 15:50

In dem Bereich "Global Settings" gibt es eine Lasche "Secure Transfer".

In dieser Lasche kann man zwei Optionen in einer Box markieren:

1. Enable Secure Proxy

2. Start Proxy hidden from Window List

Welche Option soll man wählen, wenn man nicht weitere Aktionen
vornehmen will, d.h. ich möchte das einmal hier auswählen, so dass
stunnel immer beim Aufruf von PMMAIL mit aktiviet wird?

User avatar
LotharS
Posts: 689
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Mon 18. Aug 2014, 16:47

aktuell habe ich zwar noch die ältere V.3.11. Aber es sollte eigentlich alles in der Hilfe zu PMMail erklärt sein.
Wahrscheinlich bedeutet (1) das gleiche wie zuvor "Enable stunnel", dh. PMMail startet dann stunnel gleich mit; natürlich nur mit zuvor korrekt definierten Einstellungen (hier gibt's ein langes Tutorial dazu...).
Und (2) ist offenbar optional und soll den im Hintergrund aufpassenden stunnel vor der "Fensterliste" verstecken.
Einfach mal ausprobieren... (1) oder (2) oder (1)+(2) :)

GAKA
Posts: 32
Joined: Tue 3. Jun 2014, 15:58

Post by GAKA » Tue 19. Aug 2014, 12:59

Ich bin mir immer nicht sicher trotz der guten Anleitung
hier im Forum, ob man bei PMMAIL 3.x noch zu stunnel
ein Unterverzeicnis mit etc für die Datei stunnel.conf anlegen
muss. Ich bin bei gmx.angemeldet, und jeder Provider ver-
langt ja fast eine andere Zugangskonfiguration.

In PMMAIL 2.x hatte ich folgende stunnel.conf Datei:

; Sample stunnel configuration file by Michal Trojnara 2002-2006
; Some options used here may not be adequate for your particular configuration

; Certificate/key is needed in server mode and optional in client mode
; The default certificate is provided only for testing and should not
; be used in a production environment
;cert = stunnel.pem
;key = stunnel.pem

; Some performance tunings
socket = l:TCP_NODELAY=0
socket = r:TCP_NODELAY=0

; Workaround for Eudora bug
;options = DONT_INSERT_EMPTY_FRAGMENTS

; Authentication stuff
verify = 0
; Don't forget to c_rehash CApath
;CApath = certs
; It's often easier to use CAfile
;CAfile = certs.pem
; Don't forget to c_rehash CRLpath
;CRLpath = crls
; Alternatively you can use CRLfile
;CRLfile = crls.pem

; Some debugging stuff useful for troubleshooting
debug = 7
output =C:\stunnel\stunnel.log

; Use it for client mode
client = yes
verify = 0

; Service-level configuration

[pop3s]
accept = localhost:110
connect = pop.gmx.net:995
delay = yes


;[imaps]
;accept = 993
;connect = 143

[ssmtp]
accept = localhost:25
connect = mail.gmx.net:465
delay = yes


;[https]
;accept = 443
;connect = 80
;TIMEOUTclose = 0

; vim:ft=dosini

Was ist deine Erfahrung mit deiner Konfiguration?

User avatar
LotharS
Posts: 689
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Tue 19. Aug 2014, 16:14

In PMMail 3.1x ist stunnel mitgeliefert. Es sucht seine Dateien voreingestellt im /bin-Unterverzeichnis (oder sonst im ggfs. eingegebenen Pfad zur exe), einschließlich der Konfigurationsdatei. Letztere entsteht durch Befüllen des "Secure Transfer" Tab und 'OK'. Alternativ kannst Du ja auch Dein separates stunnel verwenden. Einfach ausprobieren (vielleicht zuvor das alte irgendwie sichern...).
Deine Konfiguration scheint mir auf den ersten Blick ok, kann aber zu gmx nicht mitreden.

User avatar
Frank Wochatz
Posts: 974
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz » Tue 19. Aug 2014, 19:04

Wenn die Config mit PMMail 2.x ging, dann sollte sie auch mit PMMail 3.x funktionieren (egal ob Du stunnel aus PMmail startest oder einzeln, das ist nämlich am Ende genau das gleiche).

GAKA
Posts: 32
Joined: Tue 3. Jun 2014, 15:58

Post by GAKA » Wed 20. Aug 2014, 16:01

Ich möchte stunnel in PMMAIL 3.14 implizit starten und
muss deshalb unter GlobalSettings -> Secure Transfer
die folgenden Parameter unter Channel Definitions einsetzen:,
wobei jeweils für die Option "pop3" und "smtp" die Wahl ist:

1. Channel name
2. Server name
3. Server port
4. Local port
5. CA file

Weil jeweils die Parameter für püp3 und smtp zu setzen sind,
gehe ich davon aus, dass das die Einträge sind, die sonst
in der Datei stunnenl.config zu setzen sind (Ist das richtig?):

Bei "Cahnnel name" kann man einen beliebigen Namen oder
ganze positive Zhal für jeweils einen Provider angeben?

Bei "server name" ist dann der Name von gmx jeweils einzutragen.
Bei "Server port" und Local port" bin ich mir nicht sicher. Wo trägt
man das "localhost" ein?

Die Option "CA file" bezeichnet wohl eine bestimmte Verschlüsselung,
die man dann angeben müßte. Das ist aber bei mir nicht der Fall.
Auch die Option der Verschlüsselung wählt man ja in der Box nicht
an, weil ja eine Verschlüsselung erfolgen soll. Deshalb ist mir diese Option
auf der Seite nicht schlüssig.

Für Hinweise wäre ich dankbar. Leder hat ja Lothar hier im Forum nur das
Ergebnis der Einträge im Fenster der Seite gezeigt.

User avatar
Frank Wochatz
Posts: 974
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz » Wed 20. Aug 2014, 16:31

Mach es Dir doch einfach: schließe PMMail und beende ggf. laufende Stunnel Sessions, öffne mit einem Editor die stunnel.config, die im PMMail Verzeichnis (bzw. \PMMail\BIN\stunnel o.ä., suchen!) liegt, lösche den Inhalt, und füge den Inhalt Deiner alten stunnel.config (die Du mit PMMail 2.1 benutzt hast) dort ein. Dann aktivierst Du in PMMail einfach noch den automatischen Start von stunnel. Oder kopier die alte stunnel.config drüber. Voila.

Btw, jetzt haben wir den nächsten Thread zum gleichen Thema...

User avatar
ARoederer
Posts: 353
Joined: Fri 27. Dec 2013, 17:25
Location: Hamburg / Germany

Post by ARoederer » Thu 21. Aug 2014, 11:28

Moin
Frank Wochatz » Mi 20. Aug 2014, 16:31 wrote:... jetzt haben wir den nächsten Thread zum gleichen Thema...
Deswegen zusammengefügt.

Andreas

GAKA
Posts: 32
Joined: Tue 3. Jun 2014, 15:58

Post by GAKA » Thu 21. Aug 2014, 14:12

Vielen Dank nochmals für die Hinweise.

Selbst wenn man alles so ausführt, wie oben
beschrieben, kann man immer noch von GMX
die Nachricht erhalten beim "Holen" (Receive)
von e-Mails, dass man die SSL-Verschlüsselung
nicht gewählt hat. Selbst dann, wenn stunnel
läuft und die stunnel.conf korrekt definiert
wurde (was durch die Einträge in Channel
definitions bewirkt wurde, die damit eine
stunnel.conf generieren).

Ursache: ich hatte übersehen, dass in "Receive"
die Option "Use secure channel" angekreutz werden
muss.