Problem mit SD-Karte 8GB

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
Rolf Stephan
Posts: 66
Joined: Fri 3. Jan 2014, 21:16

Re: Problem mit SD-Karte 8GB

Post by Rolf Stephan » Mon 15. Sep 2014, 21:53

Vielen Dank, Frank.

Ich werde morgen (16.9.) die Post abschicken.

Rolf Stephan

volkerd
Posts: 24
Joined: Thu 17. Jul 2014, 20:39

Post by volkerd » Wed 24. Sep 2014, 09:29

Ist das Problem mittlerweile eigentlich gelöst?

Wie dem auch sei, es könnte auch einfach daran liegen, dass unter dem verwendeten eCS kein FAT32.IFS installiert ist oder der Treiber beim Booten nicht startet weil er keine FAT32 Laufwerke findet.

Und, ob der Kartenleser prinzipiell geht kann man normalerweise an den technischen Daten ablesen:
SD: bis 2 GByte
SDHC: 4 - 32 GByte
SDXC: über 32 GByte

Volker

User avatar
Frank Wochatz
Posts: 974
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz » Wed 24. Sep 2014, 12:06

Ich habe die SD inzwischen erfolgreich unter eCS zum Laufen bekommen, und an Rolf zurückgesendet.

Das Problem ist nicht das Dateisystem.

Die SD war nicht wie ein Plattenlaufwerk partitioniert, sondern wurde als (Super?-) Floppy unter eCS erkannt, allerdings kann man nicht darauf zugreifen. Und mit LVM ein Volume hinzufügen geht auch nicht. Das Problem ist, das ein so angemeldetes Gerät unter eCS oder OS2 nicht richtig mit LVM bearbeitet werden kann. FixMBR geht nicht, Partition Löschen geht auch nicht, und neu Formatieren sowieso nicht. D.h. es geht nur mit Linux (komplett plattmachen, unter eCS partitionieren, unter Linux dann wieder formatieren), oder sicherlich mit DFSEE (mit DFSEE ist ein Endanwender aber überfordert).

Es wäre wirklich wünschenswert, wenn solche Sticks oder SDs unter OS2 so funktionieren würden, wie unter allen anderen Systemen. Sonst ist da schlichtweg kein Datenaustausch mit fremden Sticks/SDs möglich. Ich schätze das Problem ist LVM, das Sch***ding hat uns damals eben ein ganzen Stück von Standards weggerückt und inkompatibel gemacht. Weil wir ja unbedingt Diskspawning brauchen ^^. Aber was solls, Schnee von gestern, es ist wie es ist. Hoffen wir mal, das man irgendann auch auf diese Super-Floppies normal zugreifen kann.

Ich hoffe auch, das Rolfs SD jetzt mit Partition und FAT32 auch in seiner Kamera funktioniert, sonst war die Aktion umsonst.

Andi B.
Posts: 510
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. » Wed 24. Sep 2014, 13:07

Code: Select all

FixMBR geht nicht
Hieß das nicht lvm /newmbr?
Partition Löschen geht auch nicht, und neu Formatieren sowieso nicht.
Einerseits schlecht, andererseits das Verhalten anderer OS welche Dinge einfach löschen nur weil sie sie nicht kennen, wäre noch schlechter.
Es wäre wirklich wünschenswert, wenn solche Sticks oder SDs unter OS2 so funktionieren würden, wie unter allen anderen Systemen. Sonst ist da schlichtweg kein Datenaustausch...
Volle Zustimmung.
Ich schätze das Problem ist LVM, das Sch***ding hat uns damals eben ein ganzen Stück von Standards weggerückt und inkompatibel gemacht. Weil wir ja unbedingt Diskspawning brauchen ^^.
Nein, ziemlich sicher kein LVM Problem. Sondern der uralten IBM Floppy Behandlung. Und Partition spanning brauche ich auch nicht. Das Fehlen der freien Zuordnung der Laufwerksbuchstaben wäre aber katastrophal. Ein Horror wenn man sich noch immer mit den Laufwerksbuchstaben die das Bios vergibt rumschlagen müsste. Da wäre ich dann auch schon weg von OS/2.

User avatar
Frank Wochatz
Posts: 974
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz » Wed 24. Sep 2014, 13:16

Hieß das nicht lvm /newmbr?
Von der Kommandozeile - ja. Habe ich auch probiert, funktioniert nicht. Im LVM Menü heisst es imo FixMBR, müsste auf meiner englischen eCS nachschauen, sitze gerade an einer deutschen, kann auch sein dass ich mich bei der Bezeichnung irre.... Aber wie auch immer es heisst, es ging nicht.