Thunderbird mit Gedächtnisschwund

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
ajunra
Posts: 370
Joined: Mon 23. Dec 2013, 06:40
Location: Insel Rügen

Thunderbird mit Gedächtnisschwund

Post by ajunra » Mon 19. Jan 2015, 21:17

Hallo ihr,
Ich habe gerade das Problem, daß mein Thunderbird 10.0.x plötzlich nur noch mit jungfräulich mit englischer Oberfläche und ohne Konteneinstellung startet. Gekommen ist das, weil mein Schleppi (IBM T43 2669-CTO) mit APM nicht so klar kommt wie er sollte. Wenn er wegen Strommangel im Akku in den Schlafmodus geht, kann ich ihn durchaus wieder daraus erwecken, ich kann auch noch einiges dann damit machen, jedoch hat er dann scheinbar Probleme damit auf die Platte zu schreiben. Zumindest schmiert er scheinbar beim ersten Schreibzugriff ab (friert komplett ein: Strg+Alt+Entf hilft nicht mehr). Genau das ist jetzt bei geöffneten Thunderbird und Firefox passiert. Während mir diesmal der Feuervogel heil geblieben ist (der verlor schon einmal seine Eindeutschung), ist jetzt der Donnervogel ohne Erinnerung.

Wie kann ich den Zustand des Thunderbird (Version 10 läuft wegen dem letzten passenden Enigmail für eCS) wieder verbessern, ihm also seine Erinnerung wiedergeben? Natürlich sind die Mails am wichtigsten, allerdings wäre mir eine elegante Methode um auch alles andere (Plug-Ins wie Enigmail etc. sowie Konteneinstellungen) wieder zu bekommen lieber.

Übrigens: Hier läuft wirklich APM da ja überall geschrieben wird daß ACPI auf einem IBM T4x nicht besser liefe und nur noch mehr Probleme mache...
Ich benötige diese Funktion eigentlich auch nicht. Es wäre natürlich schön, wenn man einfach den Deckel zuklappen könnte und später einfach nach dem Aufklappen weitermachen kann - notwendig ist das aber nicht unbedingt. Wenn man diese Schlafmodus-Macke kennt, kommt man wirklich selten in diese Situation. Hier hatte ich das (abgesehen von zwei provozierten Vorfällen) in den vergangenen 1,5 Jahren erst zwei mal.
Schöne Grüße von Deutschlands größter Insel
ajunra

Michaelhz
Posts: 23
Joined: Mon 6. Jan 2014, 16:09

Post by Michaelhz » Tue 20. Jan 2015, 06:43

Hallo,

versuche mal "thunderbird -profilemanager" aufzurufen. Dann kannst du ein neues Profil anlegen, der profilemanager schlägt dir einen Verzeichnisnamen vor. Diesen korrigierst du auf den Pfad, in dem sich deine alten profildaten befinden. Danach sollte mit diesem User thunderbird wieder in der alten Konfiguration starten.

Das Profilverzeichnis würde ich vorher sichern, den überflüssigen Profileeintrag im profilemanager nach erfolgter Konfiguration löschen.
Michael

User avatar
ehtron
Posts: 116
Joined: Mon 23. Dec 2013, 10:11

Post by ehtron » Tue 20. Jan 2015, 11:40

Hi :)

ich würde erst mal schauen ob du im tb profil eine heile
prefs.js
hast. ggf liegt dort auch eine kopie.
ansonsten mal deiene backups durchsehen, ob du dort noch eine findest.

ajunra
Posts: 370
Joined: Mon 23. Dec 2013, 06:40
Location: Insel Rügen

Post by ajunra » Fri 23. Jan 2015, 03:40

Danke für die Antworten,
leider halfen sie beide nicht weiter. Tb startet auch nach dem Umbenennen des Verzeichnisses im Profilmanager ohne Erinnerung. Es half auch keine Neuinstallaion.
Die prefs.js - hmm, wie erkenne ich ob sie Fehlerhaft ist? Ich kann mir sie im Editor ansehen, aber ich habe keinen Schimmer was wie drin stehen soll und was nicht. Eine Kopie habe ich leider nicht. Ein weiteres 'Problem': Ich kann - auch bei der neuen Installation - kein deutsches Sprachpaket aktivieren. Es ist installiert - man kann es unter Add-ons:Languages sehen, jedoch aktiviert ist es nicht...
Wie kann ich das aktivieren?
Welche Dateien muss ich nach dem neu-Anlegen eines Profiles mit den zugehörigen email-Konten rüberkopieren? Oder gibt es noch eine Möglichkeit?
Schöne Grüße von Deutschlands größter Insel
ajunra

User avatar
MikeK
Posts: 270
Joined: Mon 23. Dec 2013, 13:51
Location: Potsdam

Post by MikeK » Fri 23. Jan 2015, 07:37

Hatte diesen Verlust aller Einstellungen auch schon mal. Habe mir danach angewöhnt eine Kopie eines funktionierenden Profiles für einfaches Wiederherstellen zu erstellen.

Zum Auswählen der deutschen Sprache benutze ich immer das Add-On "Quick Locale Switcher" sowhl für den FF als auch für den TB. Aktuell in der Version 1.7.8.5 in meinem Donnervogel (v.24.8.1) installert. Natürlich muss vorher das passende Sprachpaket installiert worden sein.

Hoffe das hilft weiter.
Mike

User avatar
Frank Wochatz
Posts: 977
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz » Fri 23. Jan 2015, 08:05

Das klingt wirklich seltsam. Du hast genug Platz auf der Platte, und da ist auch nichts wichtiges auf Read Only gesetzt (passiert zB. wenn man Dateien von einer CD kopiert)? Überprüfe auch mal, ob Du irgendwelche Sachen aus den Mozilla Apps doppelt drauf hast, und ob Du etwas dafür in der config.sys gesetzt hast und die Pfade stimmen, und säubere mal Dein System von temporären Dateien.

Dein Rechner läuft ansonsten stabil?

User avatar
wilfried
Posts: 657
Joined: Mon 23. Dec 2013, 18:26
Location: Barsinghausen

Post by wilfried » Fri 23. Jan 2015, 09:56

ajunra » Fr 23. Jan 2015, 03:40 wrote: Eine Kopie habe ich leider nicht.
Arne Du bist reif für ein Sicherungskonzept! ;-)
Mir ist das auch schon passiert. Ich halte meine Daten schon seit längerem unter X:\home\default von der Software (Thunderbird und Firefox) getrennt. Das bietet die Möglichkeit "mal eben" eine neue Version dieser Programme einzusetzen oder auch auf einen älteren Stand zurückzugehen.
Durch regelmäßige Syncläufe mit einem Backup-System oder einer Sicherungsplatte kannst Du Dich zumindest gegen Totalverluste schützen.
Als Werkzeug hat man inzwischen die Auswahl zwischen verschiedenen Tools (Synkron, Easysync, ...). Ich erledige das allerdings mit einem Eigenbau-Werkzeug (Dirsync). Das gab es im Commtalk-Download-Bereich. Stelle ich gern wieder zur Verfügung, ist aber kein "Eye-Candy" und kann mit den modernen Tools nicht mehr mithalten.
Egal was Du nimmst, Hauptsache Du kannst in Zukunft mit einer Sicherung hantieren um zu klären was kaputtgegangen ist und ob reparieren möglich oder ein Fall-Back erforderlich ist.

Andi B.
Posts: 515
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. » Fri 23. Jan 2015, 12:11

Bei einem WinXP Rechner hatte meine Schwester immer wieder mal das Problem (alle paar Wochen/Monate), dass die prefs.js von Seamonkey nicht zurückgeschrieben und somit zerschossen wird. Nachdem ich mehrfach diese vom Backup wiederherstellen musste, habe ich sie jetzt auf read-only gesetzt. Seitdem ist Ruhe. NUR - diverse Einstellungen wie automatisches Update suchen aber auch Einstellungen von E-mail Konten werden dann nicht mehr gespeichert. Man muss also immer daran denken, dass man wenn man was ändert in den Einstellungen, read-only kurzzeitig wieder deaktiviert.

Mit eCS hatte ich sowas zwar auch schon, aber vielleicht 1x alle paar Jahre. Und da hab ich ohnehin tägliches Backup der geänderten Dateien, ist also leicht zu reparieren.

ajunra
Posts: 370
Joined: Mon 23. Dec 2013, 06:40
Location: Insel Rügen

Post by ajunra » Tue 10. Feb 2015, 18:07

Erstmal Danke für eure Hilfe!
So erstmal zu euren Beiträgen: MikeK hat mir den richtigen Tip gegeben: mit dem QuickLocaleSwitcher habe ich den (neu installierten) Donnervogel endlich wieder in Deutsch. Wieso das nicht wie vorher ohne Hilfsmittel klappte, weiß ich nicht. Damit wäre ich bei Frank. Ich habe wirklich nichts auf 'nur lesen' gesetzt und auch genug Platz (zZ. 13GB Profil/260MB Anwendung) auf der Platte. Das dürfte reichen. Wie gesagt, vor dem Crash funktionierte alles und was neues hatte ich in letzter Zeit nicht installiert. Die Ursache ist wirklich seltsam.
Wilfried hat vollkommen recht: Ich bin reif für ein Sicherungskonzept! Danke für Dein Angebot für das Eigenbau-Werkzeug, aber ich tendiere zu eBackUp von Hanno Sedlmeyr - schon alleine wegen der Datenkompression. Synkron habe ich hier schon installiert und über Jahre im Einsatz gehabt. Allerdings nur für den Geschäftlichen Einsatz. Dafür funktioniert es Prima, nur die fehlende Kompression der doppelt gesicherten (Rückfall~)Dateien und die massive Verlangsamung bei wachsender Datenbank (kann man mit manuellem Packen /manuellen löschen umgehen) sind störende Faktoren. Gut, aber eben nicht Perfekt.
Andis Variante werde ich wohl gleich Umsetzen, wenn ich auch das letzte Mail-Konto wieder eingerichtet habe. Das dürfte das geringste Problem sein...

Danke nochmal für eure Tips!
Nun zu meinem letzten Problem: Wie bekomme ich meine alten Daten in die neue Installation? Da half mir ixquick! Damit fand ich nämlich das hier:
https://www.thunderbird-mail.de/wiki/Na ... ird-Profil
genau genommen der kurze Abschnitt: 'Nachrichten (E-Mails) importieren'. Die ImportExportTools konnte der Donnervogel leider nicht selbst finden, aber Verweis auf die Seite des Autors ( https://nic-nac-project.org/~kaosmos/mboximport-en.html ) half weiter. Das übliche: Download und dann aus Datei installieren. Dann, nach Neustart, neuen Ordner Anlegen und mit Rechtsklick '...Mbox-Datei importieren' anwählen und dann die Ordner importieren - einfach den Anweisungen folgen bzw. die Abfragen abnicken bzw. ablehnen (Wer brauchzt schon unbedingt seinen >Junk<-Ordner;-))
Damit hoffe ich auch anderen geholfen haben
Schöne Grüße von Deutschlands größter Insel
ajunra