Lesen von FAT32-formatiertem USB-Stick

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
ThomasFrey
Posts: 126
Joined: Fri 2. Apr 2021, 17:29

Post by ThomasFrey »

erdmann wrote:
Thu 30. Jun 2022, 21:07
Der USBMSD.ADD von AN funktioniert nicht gescheit mit USB Floppy Drives, mein USBMSD.ADD schon (ich habe genau diese Probleme behoben. Und natürlich noch einige andere Probleme und Performance-Probleme).
Also bei mir hat der USBMSD.ADD von AN immer anstandslos funktioniert. Nach einem Diskettenwechsel muss ich zwar das LW ausziehen und wieder einstecken. Aber dazu habe ich ein USB-Hub mit einzelnen Schaltern. Unter eCS hatte ich mit Deinen Treibern immer einen IRQ-Konflikt mit dem UNIAUD-Treiber und er wurde nicht geladen. Dann ging der Startsound der WPS in den Loop.

Werde mal "pröbeln" und hier Bescheid geben.

erdmann
Posts: 498
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann »

ThomasFrey wrote:
Thu 30. Jun 2022, 23:22
erdmann wrote:
Thu 30. Jun 2022, 21:07
Der USBMSD.ADD von AN funktioniert nicht gescheit mit USB Floppy Drives, mein USBMSD.ADD schon (ich habe genau diese Probleme behoben. Und natürlich noch einige andere Probleme und Performance-Probleme).
Also bei mir hat der USBMSD.ADD von AN immer anstandslos funktioniert. Nach einem Diskettenwechsel muss ich zwar das LW ausziehen und wieder einstecken. Aber dazu habe ich ein USB-Hub mit einzelnen Schaltern. Unter eCS hatte ich mit Deinen Treibern immer einen IRQ-Konflikt mit dem UNIAUD-Treiber und er wurde nicht geladen. Dann ging der Startsound der WPS in den Loop.

Werde mal "pröbeln" und hier Bescheid geben.
Der IRQ Konflikt kann nur von den HC Treibern stammen (USByHCD.SYS) weil das die einzigen sind, die HW programmieren. Da könnte man eventuell was machen. Meine HC Treiber erwarten, dass sie wg. PCI einen "shared Interrupt" nutzen können. Vielleicht geht das nicht auf allen Systemen und eventuell ist ein "exclusive interrupt" vonnöten. Da könnte ich vielleicht an den HC Treibern was ändern.

Und genau das Problem mit "Laufwerk ausziehen und wiedereinstecken nach Diskettenwechsel" etc. habe ich in USBMSD.ADD behoben. Da kannst du das USB Floppy Laufwerk mit oder ohne Diskette schon zum Startup verbunden haben und nachträglich eine Diskette einlegen und auch Disketten wechseln und mein USBMSD.ADD erkennt das in jedem Fall richtig und fordert wenn nötig das Einlesen der neuen Diskette an (ohne dass du das Laufwerk aus- und wieder einstecken musst). Der ggw. USBMSD.ADD von AN kriegt das nicht richtig auf die Reihe. Aber damit kannst du ja so scheint es gut leben.

Du könntest spasseshalber mal den AN Stack nehmen und nur den USBMSD.ADD durch meinen ersetzen und schauen ob das geht. Ich bezweifle das aber.
Auf der anderen Seite ist der AN USB Stack in der Lage, die USB AudioTreiber (USBAUDIO.SYS, USBAUD2.SYS) aus meinem Stack zu unterstützen, und die sind ebenfalls noch "all 16-bit". Also muss es ja noch eine "Backdoor" geben.

ThomasFrey
Posts: 126
Joined: Fri 2. Apr 2021, 17:29

Post by ThomasFrey »

erdmann wrote:
Fri 1. Jul 2022, 10:45
Du könntest spasseshalber mal den AN Stack nehmen und nur den USBMSD.ADD durch meinen ersetzen und schauen ob das geht. Ich bezweifle das aber.
Ja, hat nicht funktioniert. Und dann habe ich weiter gepröbelt und mir das ganze System zerschossen, weil Tastatur und Maus nicht mehr reagierten. :cry: Musste das ganze OS neu aufsetzen!

erdmann
Posts: 498
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann »

ThomasFrey wrote:
Fri 1. Jul 2022, 16:15
erdmann wrote:
Fri 1. Jul 2022, 10:45
Du könntest spasseshalber mal den AN Stack nehmen und nur den USBMSD.ADD durch meinen ersetzen und schauen ob das geht. Ich bezweifle das aber.
Ja, hat nicht funktioniert. Und dann habe ich weiter gepröbelt und mir das ganze System zerschossen, weil Tastatur und Maus nicht mehr reagierten. :cry: Musste das ganze OS neu aufsetzen!
Wieso musstest du das ganze OS neu aufsetzen ? Warum hast du nicht einfach vom Installationsmedium gebootet und alle USB Treiber wieder durch die von AN ersetzt ?

ThomasFrey
Posts: 126
Joined: Fri 2. Apr 2021, 17:29

Post by ThomasFrey »

erdmann wrote:
Fri 1. Jul 2022, 16:50
Wieso musstest du das ganze OS neu aufsetzen ? Warum hast du nicht einfach vom Installationsmedium gebootet und alle USB Treiber wieder durch die von AN ersetzt ?
Das war echt blöd. Die Install-DVD hat immer mit einem komischen SYS-Error abgebrochen, auch die eCS-Install-CD. Ich konnte nirgends eine Maintenance-Routine aufrufen, auch nicht mit Alt-F1. Vom Win habe ich eine Acronis-Boot-CD. Mit der habe ich alles gelöscht und den MBR neu geschrieben. Dann endlich konnte ich AOS installieren. Unterdessen habe ich festgestellt, dass ich USB-Tastatur und Maus direkt einstecken muss, über den Hub mit Schalter reagieren sie nicht mehr nach einem Kalt-Boot. Irgendwas war da faul, hoffentlich hält jetzt die Installation. Zwischendurch hatte ich wieder den gleichen Error/Trap, vielleicht lag es an der HW.

aschn
Posts: 1332
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Eigentlich gibt es ja dafür Image- oder z.B. ZIP-Sicherungen. Wenn das System allerdings noch nicht konfiguriert ist, dann ist eine Neuinstallation auch nicht viel langsamer.

Gerade wenn man Tastatur und Maus an USB hat und an den USB-Treibern größere Änderungen vornimmt, dann bietet sich das an.
ThomasFrey wrote:
Fri 1. Jul 2022, 23:39
Vom Win habe ich eine Acronis-Boot-CD. Mit der habe ich alles gelöscht und den MBR neu geschrieben. Dann endlich konnte ich AOS installieren.
Für solche Basteleien, Sicherungen usw. gibt es DFsee. Das ist OS/2-kompatibel, wenn man's zulässt.
ThomasFrey wrote:
Fri 1. Jul 2022, 23:39
Unterdessen habe ich festgestellt, dass ich USB-Tastatur und Maus direkt einstecken muss, über den Hub mit Schalter reagieren sie nicht mehr nach einem Kalt-Boot. Irgendwas war da faul, hoffentlich hält jetzt die Installation. Zwischendurch hatte ich wieder den gleichen Error/Trap, vielleicht lag es an der HW.
So ein Mist. Die USB-Treiber in der ArcaOS-5.07-ISO-Datei sind schon wieder etwas veraltet. Es gibt inzwischen die Version 12.12.

Um Hardware-Probleme festzustellen, ist es hilfreich ein Vergleichssystem zu haben. Sonst hilft nur häufige Sicherung und Testen/Üben des Wiederherstellens. Wenn ein Treiber bestimmte Hardware nicht unterstützt, dann muss sie nicht gleich defekt sein. Manchmal hilft ein Fehlerbericht an AN, aber andere unterstützte Hardware führt schneller zum Ziel.
Andreas Schnellbacher