Lucide und PDF

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
rbm
Posts: 23
Joined: Thu 2. Jan 2014, 16:45

Lucide und PDF

Post by rbm » Thu 28. Jun 2018, 14:01

Bisher lese und drucke ich auf meinem Warp4.5.2-PC PDF-Dateien mit dem Paar GSView4.9/Ghostscript9.04.
Jetzt wollte ich mal Lucide ausprobieren.
Auf dem Warp-PC ist laut Lucide-Readme alles erforderliche in @unixroot installiert.
Lucide habe ich aus einem ZIP-Paket entpackt.
Lucide läßt sich mit einem Doppelklick starten.
Als Plugins werden nur djvu und gbm angezeigt.

Was fehlt mir noch, um auch PDF-Dateien öffnen zu können?
Gibt es ein PDF-Plugin, wo finde ich es?

User avatar
Rolf
Posts: 48
Joined: Wed 15. Jan 2014, 21:58
Location: Rapperswil / Jona (Switzerland)

Post by Rolf » Thu 28. Jun 2018, 14:16

Die aktuellste Version 1.4.0 vom 20.04.2017 findest Du unter:
ftp://ftp.netlabs.org/pub/lucide/lucide_de.wpi

einfach runterladen und installieren

weitere Infos findest Du auch zB unter:
http://trac.netlabs.org/lucide/

Gruss Rolf

rbm
Posts: 23
Joined: Thu 2. Jan 2014, 16:45

Post by rbm » Thu 28. Jun 2018, 19:29

Jetzt geht es!

Lösung:
Eine Arca5.0.2-Installation gestartet, Lucide installiert.
Dann aus dem Lucide-Verzeichnis die lupplr.dll auf USB-Stick kopiert.
Dann wieder Warp4.5.2 gestartet, die im Lucide-Verzeichnis vorhandene lupplr.dll
gegen die vom USB-Stick ausgewechselt.

Jetzt wird in Lucide das PDF-Plugin angezeigt mit "based on poppler library 0.20.3".
PDF geht jetzt.

Die Original-DLL ist vom 20.4.2017, Version V1.40, Größe 871.229 Byte.
Die kopierte Dll ist vom 9.7.2017 und 1.612.471 Byte groß.

Die gegenseitigen Versionsabhängigkeiten werden offenbar immer größer.

Gerhard
Posts: 71
Joined: Sun 20. Jul 2014, 00:04
Location: Wuppertal

Post by Gerhard » Thu 1. Nov 2018, 16:01

Darf ich mich mal hier reinhängen:

Nach dem Lucide 1.4.0 welches mit ArcaOS 5.0.2 installiert wurde, einwandfrei lief... musst das update auf 1.4.1 her. Mit dem Ergebnis, dass jetzt die pdf-Dateien nicht mehr angezeigt werden - das plug-in für pdf scheint zu fehlen; es wird jedenfalls in der plug-in Liste in Lucide nicht mehr angezeigt.

Also deinstalliert und mal das alte 1.3.5 installiert - dieses läuft dann einwandfrei. Dann wieder deinstalliert und nochmals 1.4.1 installiert - leider klappt es mit den pdf wieder nicht.

Aber woran liegt es und wie behebe ich dieses Problem? Nach der Anleitung von Lucide habe ich per yum nochmals die benötigten Dateien installiert bzw. diese waren bereits alle installiert.
Vorhanden sind im Verzeichnis Lucide auch:
ludjvu.dll
lugbm.dll
lujpeg.dll
lupplr.dll mit size= 252.882
auch vorhanden:
popple63.dll
LngDummy.txt

Darf ich um Hilfe bitten?

Danke,
Gerhard

Edit: Es ist identisch auf dem PC und auf meinem ThinkPad...
Last edited by Gerhard on Thu 1. Nov 2018, 16:03, edited 1 time in total.

Andi B.
Posts: 418
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. » Thu 1. Nov 2018, 17:31

Vielleicht brauchst du neuere Versionen deiner dlls?

Ich hab hier z.B.

Code: Select all

15.12.14  20.56       1.381.927    154   ___A_  popple48.dll
11.08.15  18.53       1.324.616     34   ___A_  popple54.dll
 4.04.16  14.18       1.366.667    154   ___A_  popple59.dll
22.08.16  15.20       1.368.462    154   ___A_  popple63.dll
 1.12.16  16.20       1.376.127    154   ___A_  popple65.dll
17.02.17  14.01       1.378.016    154   ___A_  popple66.dll
20.08.18  18.20       1.400.553    154   ___A_  popple70.dll
Keine Ahnung ob die schon im release sind oder vom exp.

Soweit ich mitbekommen habe, ist Lucide 1.4.1 aber noch beta. Auch wenn's schon die beta 14 ist, leicht möglich, dass dir ANPM noch keine neueren Versionen anzeigt solange du nicht auch das exp Repository aktivierst. Da du ja ArcaOS installiert hast, würde ich ANPM yum vorziehen.
Last edited by Andi B. on Thu 1. Nov 2018, 17:35, edited 1 time in total.

Gerhard
Posts: 71
Joined: Sun 20. Jul 2014, 00:04
Location: Wuppertal

Post by Gerhard » Thu 1. Nov 2018, 21:28

Vielen Dank,

aber wie und wo bekomme ich denn die neuren dll s her?
mit demYUM-Installationsbefehl sind die Dateien als neueste Versionen bezeichnet worden und beim ANPM sind die Rechner offenbar auch aktuell ? - Das programm führe ich regelmäßig aus.

Wo kommt den jetzt die popple70.dll her? :o

Herzlichen Dank,
Gerhard

User avatar
ak120
Posts: 900
Joined: Thu 8. May 2014, 12:50
Location: Demmin

Post by ak120 » Fri 2. Nov 2018, 11:21

Gerhard wrote:
Thu 1. Nov 2018, 21:28
aber wie und wo bekomme ich denn die neuren dll s her?
http://rpm.netlabs.org/experimental/00/ ... 1_oc00.zip
http://rpm.netlabs.org/experimental/00/ ... 1_oc00.zip (wird man dann wohl auch brauchen)
mit demYUM-Installationsbefehl sind die Dateien als neueste Versionen bezeichnet worden und beim ANPM sind die Rechner offenbar auch aktuell ? -
Die aktuellste Version von Poppler ist 0.71 vom 31. Oktober. Den Ausgaben und Meldungen der genannten Programme sollte man nicht blind vertrauen.
Wo kommt den jetzt die popple70.dll her? :o
Eventuell auch unter Hinzufügung des experimentellen Bereitstellungsortes.

Gerhard
Posts: 71
Joined: Sun 20. Jul 2014, 00:04
Location: Wuppertal

Post by Gerhard » Fri 2. Nov 2018, 16:24

Danke nochmals...

soo - witzigerweise gab es heute eine neue Version von poppler-data durch ANPM. Aber das Plug-in für pdf wird trotzdem nicht angezeigt in Lucide 1.4.1.

Dann habe ich Lucide 1.4.1 deinstalliert und die 1.4.0 wieder installiert. Diese Version funktioniert wieder einwandfrei - die Plug-ins sind vorhanden und arbeiten.

Vielleicht sollte ich als Laie doch nicht zu voreilig die Beta-Versionen installieren;-)

Herzlichen Dank und viele Grüße,
Gerhard
Last edited by Gerhard on Fri 2. Nov 2018, 16:25, edited 1 time in total.

User avatar
Sepp Mayr
Posts: 131
Joined: Mon 13. Jan 2014, 11:28
Location: Bayern, oda wos hobt ihr dachd?

Post by Sepp Mayr » Fri 2. Nov 2018, 16:42

Gerhard wrote:
Fri 2. Nov 2018, 16:24
Dann habe ich Lucide 1.4.1 deinstalliert und die 1.4.0 wieder installiert. Diese Version funktioniert wieder einwandfrei - die Plug-ins sind vorhanden und arbeiten.
Ich gestehe so oft nicht mehr mit OS/2 /AOS zu arbeiten aber da fällt mir eben auf dass es bei mir das gleiche Verhalten gab.
Mia san mia

User avatar
hanno
Posts: 91
Joined: Thu 9. Jan 2014, 22:20

Post by hanno » Wed 21. Nov 2018, 08:32

Hallo,

Lucide-1-4-1-beta10.wpi funktioniert jetzt bei mir, da eine neue poppler-version 0.59.0 (+ abhängige Packages; über ANPM installiert) zur Verfügung steht. Ausdrucken geht bei mir auch problemlos, sogar "Duplex" :D.
(Die neueste libcx-Version habe ich mit ANPM auch installiert.)

Schöne Grüße
Hanno

ACHTUNG: Öffnen eines PDFs ist mit der neuen Version (teilweise?) sehr langsam.
Last edited by hanno on Thu 22. Nov 2018, 11:19, edited 1 time in total.

User avatar
Rolf
Posts: 48
Joined: Wed 15. Jan 2014, 21:58
Location: Rapperswil / Jona (Switzerland)

Post by Rolf » Wed 21. Nov 2018, 09:40

Bei mir läuft auch Lucide v1.4.1_beta_10.0 mit poppler v0.59

Ich konnt bei mir aber bisher keinen Unterschied zu v1.4.0 feststellen.

...stimmt: Nachwievor wird nur doppelseitig ausgedruckt (PS Drucker-Treiber 30.822) und ich muss jede Seite einzeln in Auftrag geben, ausser ich nehm meinen sw-Laser, der nur einseitig beherrscht. :lol:

Auch der Ausdruck via PCL6-Treiber (als Bild) funktioniert nicht. Da kommt eh gar nichts.

Gruss Rolf