USB Vers.236

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

USB Vers.236

Post by os2guenni » Thu 7. Jan 2021, 13:30

Hallo zusammen,
habe noch ein kleines Problem mit meinen USB SSD Laufwerken in der virt.Box. ich kann kein SSD Laufwerk einbinden, Sticks ja.
Wenn ich das SSD Laufwerk einbinden will, bekomme ich eine MSG " das usb-Gerät xxxxxx konnte nicht an die virt. Maschine Warp4.52 gebunden werden. Als Fehlercode: failed to create a proxy device for the USB Device (Error:VERR_PDM_NO_USB_Ports)
Wo klemmt es noch?

Gruß
Günter

os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni » Thu 7. Jan 2021, 15:03

Sorry, es geht wohl nur mit USB 3.0

erdmann
Posts: 385
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Thu 7. Jan 2021, 22:11

Das hängt maßgeblich davon ab, in welchen USB Port das device eingesteckt wird. Wenn es ein "USB 3 only" port ist, wird es in der Tat nicht gehen. Ich habe z.B. ein Laptop mit Virtualbox und "USB 3 only" ports links und "USB Mixed" ports rechts. Ich kann deshalb nur die rechten Ports (in Virtualbox) nutzen.
Die devices selbst sind abwärtskompatibel, ein USB 3 device funktioniert auch an einem USB 2 Port (natürlich mit reduzierter Geschwindigkeit).
Mit den AN Treibern sollte es natürlich mit allen Ports gehen, weil da ja ein USB 3 Treiber dabei ist.
Zuletzt geändert von erdmann am Thu 7. Jan 2021, 22:15, insgesamt 2-mal geändert.

os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni » Fri 8. Jan 2021, 00:29

das kann natürlich sein - aber wo bekomme ich die AN Treiber?

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Fri 8. Jan 2021, 01:06

os2guenni wrote:
Fri 8. Jan 2021, 00:29
wo bekomme ich die AN Treiber?
Bei Arca Noae oder Bitwise Works. Meine Empfehlung: gleich ArcaOS 5.0 personal edition nehmen, auch wenn Support und Maintenance erstmal günstiger aussieht.
Andreas Schnellbacher

os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni » Fri 8. Jan 2021, 10:59

Hallo Andreas,
ich habe AN 5.04 in einer virt. Box installiert incl. USB Driver Ver. 12.03, aber einen USB-Stick 3.0 kann er trotzdem nicht lesen. Im Dezember habe ich AN 5.06 runter geladen nur noch nicht installiert. USB-SSD Laufwerke können zur Zeit noch nicht angesprochen werden,oder?
Gibt es für die AN Vers. 5.06 andere USB Driver, oder auch nur die 12.03?

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Fri 8. Jan 2021, 11:24

Ja, USB 12.07 ist aktuell. Deine ArcaOS-Subscription ist dann bestimmt auch abgelaufen.
Andreas Schnellbacher

os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni » Fri 8. Jan 2021, 18:38

Also, zig Versuche!! Habe in der virt. Box Arca 5.04, mit dem USB-Driver 12.07 befruchtet. Ergebnis: USB 3.0 Sticks werden nicht aktiviert, der Controller ist USB 2.0 (OHCI+EHCI). Wenn ich den Controller 3.0 angebe (xHCI), passiert auch nichts.
Auf die virt. OS/2 Box habe ich dann auch den USB Driver 12.07 installiert, hat mir zwar gesagt, dass die vorhandenen Driver neuer sind, aber was soll's.
Aber auch hier, die 3.0 Sticks bekomme ich nicht aktiviert, ist egal welchen Controller ich vorgebe.

erdmann
Posts: 385
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Fri 8. Jan 2021, 20:34

Hast du auch die config.sys entsprechend upgedated? Das macht die Installation nämlich nicht. Musst also USBXHCD.SYS manuell hinzufügen. Da Virtualbox dem guest einen USB 3.0 HC vorgaukelt (wenn USB 3 HC in der Virtualbox Config aktiviert wird) musst du also USBXHCD.SYS einmal hinzufügen.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Fri 8. Jan 2021, 20:38

Langsam hat das nichts mehr mit dem Titelthema zu tun. Ein neuer Thread wäre längst angebracht, z.B. "USB-3-Treiber in VirtualBox-Gastsystem installieren".

Überprüf mal, ob der USBXHCD.SYS in die CONFIG.SYS eingetragen wird. Bei den ersten Versionen, vielleicht jetzt auch noch, hatte das nur bei einer Neuinstallation funktioniert. Bei einem bereits installierten System wurden mit dem aktuellen System nur die vorhandenen Treiber aktualisiert, mit Absicht. Steht mit Sicherheit in einer Readme oder auf der Webseite.

Gefunden:

Code: Select all

This release is intended to update an existing installation only.
Except for xHCI, the installer will not check for which host
controllers you have in your system and it will not change the host
controller drivers in your config.sys. If you are running ArcaOS,
the installer will check for xHCI controllers and will modify your
config.sys accordingly. The installer cannot install the xHCI driver
on non-ArcaOS systems so you will not see the xHCI driver in the
package list on those systems.
Dann wäre ich mir auch nicht so sicher, ob VirtualBox überhaupt USB-3-Geräte an OS/2 durchreicht, weil Warp 4.52 nur USB 2 unterstützt hat.

Zum Installieren von USBXHCD.SYS:

Code: Select all

/****************************************************************************
* Unpack .wpi file
* 
* Syntax: unwpi <wpifile>
****************************************************************************/

'@ECHO OFF'

/* Some OS/2 Error codes */
ERROR.NO_ERROR           =   0
ERROR.INVALID_FUNCTION   =   1
ERROR.FILE_NOT_FOUND     =   2
ERROR.PATH_NOT_FOUND     =   3
ERROR.ACCESS_DENIED      =   5
ERROR.NOT_ENOUGH_MEMORY  =   8
ERROR.INVALID_FORMAT     =  11
ERROR.INVALID_DATA       =  13
ERROR.NO_MORE_FILES      =  18
ERROR.WRITE_FAULT        =  29
ERROR.READ_FAULT         =  30
ERROR.SHARING_VIOLATION  =  32
ERROR.GEN_FAILURE        =  31
ERROR.INVALID_PARAMETER  =  87
ERROR.ENVVAR_NOT_FOUND   = 204

rc = ERROR.NO_ERROR

CALL RxFuncAdd 'SysLoadFuncs', 'RexxUtil', 'SysLoadFuncs'
CALL SysLoadFuncs

DO once = 1 TO 1
   CALL SETLOCAL
   CurDir = DIRECTORY()
   
   /* Parse args */
   PARSE ARG Args
   Args = STRIP( Args)
   
   /* Strip surrounding double quotes */
   IF LEFT( Args, 1) = '"' & RIGHT( Args, 1) = '"' THEN
      Args = SUBSTR( Args, 2, LENGTH( Args) - 2)
      
   /* Check args */
   IF Args = '' THEN
      LEAVE
      
   ArchiveFile = Args
      
   /* Get full pathname */
   next = STREAM( ArchiveFile, 'c', 'query exists')
   IF next <> '' THEN
      ArchiveFile = next
   SAY 'ArchiveFile = 'ArchiveFile
   
   /* Get output dir */
   ArchiveFileName = FILESPEC( 'n', ArchiveFile)
   p1 = LASTPOS( '.', ArchiveFileName )
   IF p1 > 1 THEN
      DestDirName = SUBSTR( ArchiveFileName, 1, p1 - 1)
   ELSE
      DestDirName = '_'ArchiveFileName
   CurDirBsl = STRIP( CurDir, 't', '\' )'\'
   DestDir = CurDirBsl''DestDirName

   /* Create output dir */
   CALL SysMkDir DestDir

   /* Change drive and directory */
   CALL ChangeDriveDir DestDir

   /* Find runwic.cmd */
   WarpInPath = ''
   Wic = 'wic.exe'  /* fallback value */
   next = SysIni( 'USER', 'WarpIN', 'Path')
   next = STRIP( next, 'T', '00'x)
   
   IF next <> '' & next <> 'ERROR:' THEN
   DO
      WarpInPath = next
      Wic = WarpInPath'\runwic.cmd'
   END
   ELSE
   DO
      rc = ERROR.FILE_NOT_FOUND
      SAY 'Error: WarpIN path not found in OS2.INI. Install WarpIN.'
      LEAVE once
   END

   /* Unpack */
   'CALL 'Wic ArchiveFile' -x'
   
   CALL ChangeDriveDir CurDir
   call ENDLOCAL
END

EXIT( rc)

/* ----------------------------------------------------------------------- */
/* Change drive and dir */
ChangeDriveDir: PROCEDURE EXPOSE (GlobalVars)
   rc = ERROR.NO_ERROR
   NewDir = ''
   PARSE ARG ChgDir

   DO 1
      OldDir = DIRECTORY()

      IF ChgDir = '' THEN
      DO
         rc = ERROR.INVALID_PARAMETER
         LEAVE
      END

      OldDrive = LEFT( OldDir, 2)
      IF POS( ':\', ChgDir) = 2 THEN
         ChgDrive = LEFT( ChgDir, 2)
      ELSE
         ChgDrive = OldDrive

      IF TRANSLATE( ChgDrive) <> TRANSLATE( OldDrive) THEN
         CALL DIRECTORY ChgDrive
      NewDir = DIRECTORY( ChgDir)
   END

   RETURN( NewDir)
Als unwpi.cmd sichern. Am besten ein Programmobjekt davon erzeugen und "Close window on exit" und "Start minimized" deaktivieren. Dann siehst Du auch, was ausgegeben wird. Dann die WarpIN-Archivdatei (WPI oder EXE) auf das Objekt ziehen.

Nach dem Auspacken den Treiber USBXHCD.SYS nach \OS2\BOOT kopieren. Dann die Zeile DEVICE=USBXHCD.SYS zur CONFIG.SYS hinzufügen. Mit PCI.EXE vorher die Anzahl der USB-3-Ports abfragen.
Zuletzt geändert von aschn am Fri 8. Jan 2021, 20:48, insgesamt 1-mal geändert.
Andreas Schnellbacher

erdmann
Posts: 385
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Fri 8. Jan 2021, 21:11

Natürlich reicht VirtualBox USB 3.0 HCs durch (wenn man das in der Virtualbox Host Config angibt).
Und wenn man alle nötigen USB Treiber installiert hat (also USBD.SYS, USBXHCD.SYS und die diversen Class Treiber: USBMSD.ADD etc.) dann funktioniert das Ganze völlig problemlos auch unter Warp 4.52 (soweit der Kernel neu genug ist und KEE implementiert). Der kernel weiss nichts von USB. Die Host Controller Treiber wissen es.

erdmann
Posts: 385
Joined: Mon 4. Jan 2016, 14:36

Post by erdmann » Fri 8. Jan 2021, 21:20

aschn wrote:
Fri 8. Jan 2021, 20:38
Langsam hat das nichts mehr mit dem Titelthema zu tun. Ein neuer Thread wäre längst angebracht, z.B. "USB-3-Treiber in VirtualBox-Gastsystem installieren".

Überprüf mal, ob der USBXHCD.SYS in die CONFIG.SYS eingetragen wird. Bei den ersten Versionen, vielleicht jetzt auch noch, hatte das nur bei einer Neuinstallation funktioniert. Bei einem bereits installierten System wurden mit dem aktuellen System nur die vorhandenen Treiber aktualisiert, mit Absicht. Steht mit Sicherheit in einer Readme oder auf der Webseite.

Gefunden:

Code: Select all

This release is intended to update an existing installation only.
Except for xHCI, the installer will not check for which host
controllers you have in your system and it will not change the host
controller drivers in your config.sys. If you are running ArcaOS,
the installer will check for xHCI controllers and will modify your
config.sys accordingly. The installer cannot install the xHCI driver
on non-ArcaOS systems so you will not see the xHCI driver in the
package list on those systems.
Großartig, bedeutet also, wenn ich mir die Treiberupdates kaufe, kann ich XHCI nicht auf eCS installieren, OBWOHL ich dafür bezahlt habe.
Genau das hab ich früher oder später von dieser Firma erwartet.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Fri 8. Jan 2021, 21:40

Ja, das wird dasselbe Paket sein, das man mit der Subscription für Warp 4.x und eCS kaufen kann. Was da genau bei David vorgeht, das weiß ich nicht, sicher hat Lewis dazu aber längst eine eigene Meinung. Es gibt auch andere, die dieses Verhalten nicht verstehen.
Andreas Schnellbacher

os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni » Fri 8. Jan 2021, 23:42

Hallo, danke erstmal für die Infos. Werde morgen noch einmal in Ruhe die Ratschläge durchgehen.

os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni » Sat 9. Jan 2021, 17:59

Es sieht jetzt so aus:
AN 5.04 in der virt.Box 6.1 mit USB Driver 12.07 - Controller in der virt.Box auf 3.0 eingestellt, es kommen keine Fehlermeldungen wenn ich einen USB Stick 3.0 einstecke, zeigt mir aber nicht den Inhalt an. USB Sticks 2.0 werden aber auch nicht angezeigt.
OS/2 4.52 in der virt.Box 6.1 ebenfalls mit Driver 12.07 verhält sich ebenso.
Mich würde interessieren bei wem die USB 3.0 Unterstützung läuft.

Gruß
Günter

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Sun 10. Jan 2021, 15:23

Vorhin mal auf die Schnelle geprüft: USB3.0-Stick läuft hier auch nicht (ArcaOS5.06 mit USB12.07 in VBox6.14 auf Win10-Host), wohl abr USB2. Es scheint alles korrekt installiert zu sein.

Ist mir aber auch egal, denn USB-Stick-Support in der VM stört mich praktisch eher: Denn es "zieht" gerade der Stick, dessen "Rechner" gerade obenauf ist. Ist also zufällig die ArcaOS-VM oben, kann ich nicht zugleich von meinem Host auf einen Stick zugreifen, außer ich fahre die VM erst runter und hinterher wieder rauf...-> keine Lust....
Ergo bleibt hier zur VM der USB-Support ganz abgestellt, und wenn ich mal trotzdem etwas vom Stick in der VM brauche (oder umgekehrt), geht das über den Host und Samba (bzw. Shared Folder). Für meine Belange fahre ich gut damit.

os2guenni
Posts: 228
Joined: Tue 8. Apr 2014, 10:22
Location: Fürstenberg/Weser

Post by os2guenni » Sun 10. Jan 2021, 16:05

Hallo Lothar,
da hast Du natürlich recht - es ärgert mich halt, da bezahlt man für die Lizenz, aber es läuft halt nicht richtig rund.
Ich würde ja einen neuen Eintrag aufmachen - verspreche mir aber auch nicht soviel davon. Vielleicht gibt es nicht so viele User die in der virt. Box mit
USB 3.0 werkeln.
Gruß
Günter

Andi B.
Posts: 528
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. » Sun 10. Jan 2021, 18:59

...es ärgert mich halt, da bezahlt man für die Lizenz, aber es läuft halt nicht richtig rund.
Du hast für VBOX eine Lizenz bezahlt?

Oder hat ArcaNoae mittlerweile Installationen innerhalb von VBOX (welche Version und welcher Host?) als supported angegeben?
Vielleicht gibt es nicht so viele User die in der virt. Box mit USB 3.0 werkeln.
Das ist sehr wahrscheinlich der Fall. USB geht ja generell unter OS/2 und auch ArcaOS nicht gerade perfekt. Und USB3.0 ist ja mit ArcaOS gerade erst mal so halbwegs ans Laufen gekommen. Bei weitem nicht so gut wie es andere OSes unterstützen. Warum man in einer virtuellen Maschine USB braucht wenn der Host USB ja ohnehin viel besser unterstützt, ist mir eh schleierhaft. Aber in deinem Fall ist ja, soweit ich das sehe, noch nicht mal geklärt, ob es ein VBOX oder ArcaOS Problem ist.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Sun 10. Jan 2021, 21:08

VirtualBox unterstützt offiziell nur OS/2 Warp 4.x. Deshalb meine Warnung.
Andi B. wrote:
Sun 10. Jan 2021, 18:59
Warum man in einer virtuellen Maschine USB braucht wenn der Host USB ja ohnehin viel besser unterstützt, ist mir eh schleierhaft.
Das war auch mein erster Gedanke. Bei USB-Sticks, die man auf verschiedenen OS/2-Systemen einsetzt, finde ich das aber praktisch. Sonst geht natürlich jeder Datenträger mit einem fast beliebigen anderen Dateisystem über Netzwerk (oder teilweise auch über Shared Folders) viel besser.
Andreas Schnellbacher

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Mon 11. Jan 2021, 11:59

aschn wrote:
Sun 10. Jan 2021, 21:08
VirtualBox unterstützt offiziell nur OS/2 Warp 4.x.
Nur ganz am Rande: Ganz so arg ist es nicht. Im VBoxManager lassen sich offiziell OS2 1.x über Warp3, 4, 4.5, eComstation bis 'Other OS/2' auswählen, soll sich wohl auf die Schieberegler auswirken. Die gelieferte virtuelle Hardware ist je nach Wahl bestimmt überall von der gleichen Sorte, dann auch für ArcaOS bereit. Ob und wie die dann akzeptiert wird, hängt üblich von der Software im Gast ab. - In meiner Linux-VM ist ein USB3.0-Stick jedenfalls ansprechbar, hilft uns aber jetzt nicht....
Zum (abgedrifteten) Thema "USB-Stick in VBox" sind wir ja einig.
Zuletzt geändert von LotharS am Mon 11. Jan 2021, 12:30, insgesamt 1-mal geändert.