Update für USB zu LAN Adapter möglich?

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
Andi B.
Posts: 515
Joined: Tue 24. Dec 2013, 16:40

Re: Update für USB zu LAN Adapter möglich?

Post by Andi B. » Fri 12. Feb 2016, 12:16

Einzig eine Besonderheit habe ich nun noch: ich kann immer erst eine Internetverbindung (nach einem Systemstart erstmalig) nutzen, wenn ich die IP Adresse manuell mal mit dem Programm TCPIP Konfiguration geändert habe.
Dann könnte es leicht sein, dass ein einfacher "ifconfig lan0..." Befehl auch ausreichen würde. Eventuell wird deine \mptn\bin\setup.cmd zu früh ausgeführt. Also schon bevor der USB Adapter erkannt wird.

Einfacher Test, nach dem booten mal \mptn\bin\setup.cmd händisch starten. Das TCP/IP Konfigurationsprogramm erstellt/editiert die setup.cmd und startet diese ziemlich sicher beim beenden um die Änderungen zu übernehmen.

User avatar
Sigurd
Posts: 790
Joined: Mon 23. Dec 2013, 08:35

Post by Sigurd » Fri 12. Feb 2016, 14:38

Andi B. » Fr 12. Feb 2016, 12:16 wrote: Dann könnte es leicht sein, dass ein einfacher "ifconfig lan0..." Befehl auch ausreichen würde. Eventuell wird deine \mptn\bin\setup.cmd zu früh ausgeführt. Also schon bevor der USB Adapter erkannt wird.

Einfacher Test, nach dem booten mal \mptn\bin\setup.cmd händisch starten. Das TCP/IP Konfigurationsprogramm erstellt/editiert die setup.cmd und startet diese ziemlich sicher beim beenden um die Änderungen zu übernehmen.
Hallo Andi,

vielen Dank, genau so ist es! Ich werde das mal in die startup.cmd einbauen, mal sehen ob das dann reicht.
EDIT: war wieder Unsinn was ich machen wollte, ist ja noch zu früh in der startup.cmd 8-)
Ich habe mir einfach ein Programmobjekt auf der Arbeitsoberfläche abgelegt, bevor ich ins Internet möchte, löse ich das eben aus :)

Damit kann mein Klon nun auch von jedem PC, der noch USB 2.0 Hardware hat, ins Internet :)

Zu meinem "Glück" auf dem Sony Vaio Pro 13 fehlt mir eigentlich nur noch Sound.....
Moschip11.png
Danke.

Sigurd
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
OS/2 versus Hardware - Maximum Warp!

User avatar
ehtron
Posts: 116
Joined: Mon 23. Dec 2013, 10:11

Post by ehtron » Fri 12. Feb 2016, 15:46

Hi :)
du kannst den ip start aus der config.sys nehmen
und die startup.cmd in den autostart setzen :)

aschn
Posts: 999
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Fri 12. Feb 2016, 16:15

Sigurd » Do 11. Feb 2016, 20:59 wrote: ich kann immer erst eine Internetverbindung (nach einem Systemstart erstmalig) nutzen, wenn ich die IP Adresse manuell mal mit dem Programm TCPIP Konfiguration geändert habe.
Das macht doch auch nichts anderes, als die ?:\mptn\bin\setup.cmd zu editieren und dann auszuführen. Das kannst Du auch jederzeit von Hand machen.

Wahrscheinlich geht es Dir aber darum, dass Du sie überhaupt ändern musst. Die setup.cmd wird mit Sicherheit zu früh ausgeführt, nämlich bevor der Netzwerkknoten überhaupt erkannt wurde. Da würd ich dann zur Verzögerung etwas über den XWP Startup Folder machen oder ein Skript schreiben.

Ich glaub nicht, dass Du XWLAN dahin umgebogen bekommst, dass es erkennt wann der Adapter zur Verfügung steht und damit automatisch ein setup.cmd-ähnliches Skript ausführt.
Andreas Schnellbacher

User avatar
thorolf
Posts: 435
Joined: Wed 25. Dec 2013, 16:14
Location: Rhein-Main

Post by thorolf » Fri 12. Feb 2016, 18:31

aschn » Fr 12. Feb 2016, 16:15 wrote: Da würd ich dann zur Verzögerung etwas über den XWP Startup Folder machen oder ein Skript schreiben.
hab ich in der Vergangenheit auch so gemacht, zur Not kann man eine Schleife einbauen in der man den Status des Adapters abfragt und im Anschluss daran die setup.cmd aufrufen.
Ich glaub nicht, dass Du XWLAN dahin umgebogen bekommst, dass es erkennt wann der Adapter zur Verfügung steht und damit automatisch ein setup.cmd-ähnliches Skript ausführt.
Erkennt XWLAN Netzwerk-Adapter am USB?
Grüße,

Thorolf