Apache OpenOffice 4.1.1 Installation schlägt fehl

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
User avatar
Thomas Müller
Posts: 237
Joined: Tue 24. Dec 2013, 13:14
Location: Bremen

Apache OpenOffice 4.1.1 Installation schlägt fehl

Post by Thomas Müller » Fri 9. Jan 2015, 18:09

Hallo zusammen.

Ich habe hier auf meinem X41 Tablet eine Installation von eCS 2.1 und ein Warp 4.52 (Kernel 14.104a). Auf beiden Systemen habe ich Apache OpenOffice 4.1.1 installiert. Auf eCS lief die Installation erfolgreich durch und die Anwendung läuft.
Auf Warp 4.52 gibt es folgende Fehlermeldungen:
PMGRAB00.jpg
PMGRAB01.jpg
PMGRAB02.jpg
Kann mir jemand aufgrund dieser Fehlermeldungen sagen in welcher Richtung ich nach der Ursache suchen kann?
Vielen Dank im Voraus.

Thomas
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

User avatar
Sigurd
Posts: 786
Joined: Mon 23. Dec 2013, 08:35

Post by Sigurd » Sat 10. Jan 2015, 00:26

Hallo Thomas,

hast Du alle Dateien bzw. Voraussetzungen wie in der readme1st.txt unter Warp 4 nachinstalliert, seit ecs 2.0 sind diese dort schon dabei:

(zum Beispiel UniClip usw.)

Hier die Ausschnitte aus der Readme:


** Installation **

Double click on the base WPI file (AOO-xxx-GA-base-en-US.wpi), it will automatically
find the binaries and NLS WPI files.

Please note that WarpIn 1.0.19 or higher is required for installation.
You can download the latest WarpIn package from http://warpin.netlabs.org

Besides this, also the UniClip and the kLIBC 0.6.5. packages are required to
be installed prior to installing Apache OpenOffice 3.4.

WarpIn version 1.0.19, UniClip 0.3 and kLIBC 0.6.5 can also be downloaded
from the AOO download directory.

** Installation notes **

- UniClip is required to complete installation. (Available by default in
eComStation 2.0)

- LibC 0.6.5 is required to complete installation.

- Innotek Font Engine is required to run Apache OpenOffice for
eComStation and OS/2. (Available by default in eComStation)
You can download it from the following location:
http://download.innotek.de/ft2lib/InnoT ... lease1.exe

- this installation can be used alongside Apache OpenOffice 1.1.5 and
OpenOffice.org 2.x releases.

- installation should preferably be done on a JFS volume, as it may
run slow otherwise. The installation target volume must support long
filenames.

- installation takes around 400 MB of drivespace.

- during installation a template folder is created which holds a large number
of templates which can be used as a base for Apache OpenOffice documents.

- for better rendering of the GUI font, it is suggested to install Workplace
Sans TrueType font. This will also visualize the numbering for the vertical
ruler, since the default font, WarpSans, cannot be rotated. It is advised to
install this font prior to installing Apache OpenOffice.
This font is available by default in eComStation 2.0.

You can download the Workplace Sans font from the following website:
http://www.altsan.org/creative/fonts/

- Internet Application Integration (optional)

This tool is installed and configured by default in eComStation 2.0.
You can download it from the authors webpage if needed:
http://7cities.net/~mckinnis/os2/index.html

When configured properly, it is possible to use Thunderbird for sending
your documents. To enable this feature, the Internet Application
Integration tool must be installed and configured for your email client.
In AOO options, Internet settings, set email program field to 'thunderbird'.
The full path for executable and directories will be taken from your INI
files (IAI settings).

The default OS/2 browser will be used for opening web pages. To enable
this feature, the Internet Application Integration tool must be installed
and configured for your browser.

- Quickstart: To enable quickstart, you can place a shadow of the quickstart
WPS icon object in the startup folder.


Hoffe es hilft.
OS/2 versus Hardware - Maximum Warp!

User avatar
Thomas Müller
Posts: 237
Joined: Tue 24. Dec 2013, 13:14
Location: Bremen

Post by Thomas Müller » Sat 10. Jan 2015, 10:31

Vielen Dank Sigurd,

ich denke ich habe alles berücksichtigt.
Ich werde mal weiter forschen und mich hören lassen.

Thomas

User avatar
Frank Wochatz
Posts: 977
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz » Sat 10. Jan 2015, 11:16

Sigurd » Sa 10. Jan 2015, 00:26 wrote: - Internet Application Integration (optional)

This tool is installed and configured by default in eComStation 2.0.
You can download it from the authors webpage if needed:
http://7cities.net/~mckinnis/os2/index.html
Dieser Link ist übrigens mausetot. Der hier funktioniert:

https://sites.google.com/site/chuckmckinnis/os-2

Michaelhz
Posts: 23
Joined: Mon 6. Jan 2014, 16:09

Post by Michaelhz » Sat 10. Jan 2015, 13:58

Hm.. in downloadbereich der dropbox gibt es noch ein readme_aoo.txt. Hast Du entweder

AOO-4110-GA-rpm.wpi
oder
yum install libc gcc-4.4.4 gcc-4.7.3 openssl curl libjpeg libxslt libicu zlib libxml2 mmap pthread urpo libstdc++6

durchgeführt?.
System requirements:
--------------------
- eComStation 1.x,2.x
- OS/2 Warp
- 32bit tcpip stack
- the following packages must be installed (dll only)
libc 0.6.5
gcc 4.7.3
gcc 4.4.4
ssl
curl
jpeg
xslt
libicu
z
xml2
stdcpp6
mmap
pthread
urpo

These files can be installed with the following command:

yum install libc gcc-4.4.4 gcc-4.7.3 openssl curl libjpeg libxslt libicu zlib libxml2 mmap pthread urpo libstdc++6

if you have a valid rpm/yum installation.

Otherwise you need to grab the AOO-4110-GA-rpm.wpi before you start the installation.

User avatar
Thomas Müller
Posts: 237
Joined: Tue 24. Dec 2013, 13:14
Location: Bremen

Post by Thomas Müller » Sat 10. Jan 2015, 19:10

So, nun klappt es auch hier.
Nach einer erneut durchgeführten Installation blieb noch eine Fehlermeldung mit Bezug auf eine stdcpp.dll. Diese wurde aus einem für mich nicht nachvollziehbarem Grund nach C:\os2\dll kopiert. Nachdem ich das nachgeholt klappt alles. Wunderbar. Ganz herzlichen Dank an Bitwise!
Jetzt warte ich noch auf eine neue Firefox-Version und dann wird wieder kräftig "gesponsert".
Beste Grüße von

Thomas

User avatar
Thomas Müller
Posts: 237
Joined: Tue 24. Dec 2013, 13:14
Location: Bremen

Post by Thomas Müller » Sun 11. Jan 2015, 18:22

Nach einem Tag "Spielerei" mit der neuen Version möchte ich auf diesem Wege einmal meinen ganz herzlichen Dank an die Macher zum Ausruck bringen. Ohne ein Office dieser Art wäre ich wahrscheinlich früher oder später auf ein anderes Betriebssystem angewiesen, da ich eine Office-Anwendung mit breiter Nutzung in meiner täglichen Nutzung dringend benötige.
Von daher kann ich gar nicht sagen wie froh ich bin, dass bitwise (Silvan Scherrer u.a.?) dieses Produkt für uns verfügbar gemacht hat.
Ganz herzlichen Dank also von mir!

Thomas

aschn
Posts: 996
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Sun 11. Jan 2015, 18:24

In dem Fall geht der Dank an Yuri Dario, der schon die älteren Versionen portiert hat.
Andreas Schnellbacher

User avatar
Thomas Müller
Posts: 237
Joined: Tue 24. Dec 2013, 13:14
Location: Bremen

Post by Thomas Müller » Sun 11. Jan 2015, 19:38

Danke Andreas.
Dann also herzlichen Dank an Yuri Dario!

Thomas

User avatar
herby
Posts: 95
Joined: Tue 24. Dec 2013, 12:45
Location: 35104 Lichtenfels

Post by herby » Sun 11. Jan 2015, 21:26

Hallo,
wenn ich den Downloadlink anklicke, verlangt Dropbox ein Kennwort.
Wo ist der Hinweis darauf oder wie lautet das Kennwort.

mfg
Herbert Grebe
Wo kämen wir denn hin, wenn alle sagten "Wo kämen wir denn hin" und niemand ginge um zu sehen, wohin wir kämen, wenn wir gingen!?!

aschn
Posts: 996
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Sun 11. Jan 2015, 21:42

Andreas Schnellbacher

User avatar
herby
Posts: 95
Joined: Tue 24. Dec 2013, 12:45
Location: 35104 Lichtenfels

Post by herby » Sun 11. Jan 2015, 21:59

Danke

Herbert Grebe
Wo kämen wir denn hin, wenn alle sagten "Wo kämen wir denn hin" und niemand ginge um zu sehen, wohin wir kämen, wenn wir gingen!?!

ajunra
Posts: 370
Joined: Mon 23. Dec 2013, 06:40
Location: Insel Rügen

Post by ajunra » Sun 11. Jan 2015, 22:16

Ein kleines Problem:
ich habe auf meinem einzigen mit dem Internet verbundenen Rechner rpm/yum installiert. Wenn ich nun die Zeile 'yum install libc gcc-4.4.4 gcc-4.7.3 openssl curl libjpeg libxslt libicu zlib libxml2 mmap pthread urpo libstdc++6' aus der readme_aoo.txt in ein Befehlszeilenfenster kopiere und ausführe, zeigt es mir auch ein 'libc devel 0.6.5-20.oc00' als 'Installiert für Abhängigkeiten' an. Weiterhin sagt yum mir, daß es diese Pakete trotzdem installieren will.

Nun habe ich sorge, daß mir genau dieses Paket meine libc066.dll-dll ad absurdum führt. Gehe ich recht in der Annahme daß das eine libc065.dll - Installation ist, oder bin ich mal wieder komplett auf dem Holzweg?

Irgendwie verwirrt mich dieses rpm/yum-Geraffel mehr als daß es hilft. Es ist selbstverständlich schön wenn man mit 'yum update' einfach Dateien aktualisieren kann (muss man die eigentlich spezifizieren oder reicht 'yum update' für alle installierten?), jedoch habe ich ehrlich gesagt dadurch total den Überblick verloren. Ich komme mir vor als säße ich vor Windows: Ich habe keine Ahnung mehr was das System da anstellt. Dazu dann noch diese Doppelinstallationen: mal wird etwas in (per klassischem *.wpi zb.) nach \ecs\dll abgelegt, mal in irgendein \usr\... Aktualisiert man dann das eine, ist das andere möglicherweise das was benutzt wird. Durch diesen extra linux-Verzeichnisbaum habe ich echt den überblick verloren und verbrachte schon so manche Zeit mit Aufräumen (z.B. bei der libc). Manchmal bekommt man eine aktuelle Version nur per *.wpi; meistens per *.zip und manchmal nur per rpm/yum. Machmal gleichzeitig, manchmal (z.B. libc066) aber nur auf die eine ODER andere Art. Irgendwie verwirrend und mittlerweile frustrierend.
Trotz meiner Frustrierten Zeilen: Welche wäre die sicherste (auch für bestehende Programme) Variante AoO zu installieren?
Schöne Grüße von Deutschlands größter Insel
ajunra

aschn
Posts: 996
Joined: Wed 25. Dec 2013, 22:47

Post by aschn » Sun 11. Jan 2015, 23:07

ajunra » So 11. Jan 2015, 22:16 wrote: Nun habe ich sorge, daß mir genau dieses Paket meine libc066.dll-dll ad absurdum führt. Gehe ich recht in der Annahme daß das eine libc065.dll - Installation ist, oder bin ich mal wieder komplett auf dem Holzweg?
Es ist mit der von den Entwicklern gewählten Namensgebung kein Problem mehrere Versionen nebeneinander zu haben. Die achten genau darauf, dass die Versionsnummer im DLL-Namen enthalten ist. Dann gibt's keine Probleme. Der Name kann nicht einfach durch Umbenennen geändert werden, sondern mit einem Entwicklerwerkzeug müssten auch die Referenzen angepasst werden.

Mach Dir einfach keine Gedanken, welche RPM-Pakete installiert sind. Yum verwaltet das schon - demnächst auch mit GUI-Unterstützung. Führ einfach nur den in der Readme-Datei genannten Yum-Befehl aus und gut ist.
ajunra » So 11. Jan 2015, 22:16 wrote: jedoch habe ich ehrlich gesagt dadurch total den Überblick verloren
Bei der Menge an Dateien, die diese Riesenpakete mitbringen und als Voraussetzung erfordern, ist das doch völlig normal. Überlassen wir einfach den Entwicklern den Durchblick dabei. Die haben ihn schon eher, auch wenn diese Riesenpakete jeden überfordern.

Nicht nur Java bringt heute ein komplettes OS mit, sondern auch Mozilla und OpenOffice sind schon ähnlich komplex. Eine Alternative gibt es nicht. Wir können eher froh sein, dass es bei Linux auch üblich ist DLLs systemweit zu nutzen. (Ja, bei Linux gibt's inzwischen auch schon DLLs ;-) .)
ajunra » So 11. Jan 2015, 22:16 wrote: Manchmal bekommt man eine aktuelle Version nur per *.wpi; meistens per *.zip und manchmal nur per rpm/yum. Machmal gleichzeitig, manchmal (z.B. libc066) aber nur auf die eine ODER andere Art. Irgendwie verwirrend und mittlerweile frustrierend.
Wichtig ist, dass Du Dich für eine Art entscheidest. Bei libc ist das z.B. ganz einfach, weil libc eine der wichtigsten DLLs für das portierte Zeugs ist. "yum update" sorgt dafür, dass Du immer die neueste und auch ältere Versionen bereit hast. Die von den Entwicklern am besten unterstütze Art ist RPM. Seit einiger Zeit benutze ich nur noch RPM (natürlich von Yum aus), wenn mehrere Paketarten angeboten werden. Ich bin verwundert, dass OpenOffice nur als WPI existiert, obwohl Yuri selbst RPM portiert hat und auch ständig neue Pakete erstellt. Die installierten WarpIN-Pakete sind bei mir inzwischen auch so zahlreich, dass ich auch da den Überblick verloren hab.

Also: Das WPI-Paket mit den DLLs sollte man nicht (könnte man aber) installieren, wenn man sowieso Yum installiert hat. Es installiert sich in das program-Verzeichnis von OpenOffice. Ich denke, das ist eher für Bastler geeignet, die unbedingt ohne Yum und \usr-Baum auskommen wollen und statt dessen lieber gleichnamige DLLs mehrfach in verschiedenen Verzeichnissen auf der Platte haben wollen.
Andreas Schnellbacher

ajunra
Posts: 370
Joined: Mon 23. Dec 2013, 06:40
Location: Insel Rügen

Post by ajunra » Mon 12. Jan 2015, 17:30

Hallo Andreas,

so unrecht hast Du nicht. Aber wie installiere ich denn die libc066.dll mit yum? Ich glaube gelesen zu haben (und da sind sie wieder - die mangelhaften Englischkenntnisse), daß es die nur per zip und wpi gibt.

Nun, was die sich auf die jeweilige Version beziehende Dateinamen betrifft, hast Du Recht. Aber: ich habe mir das mal erklären lassen (Danke Dir nochmal, Holger). Mit der neuesten Version (hier libc066.dll) werden auch Dummy-Dateien der älteren Versionen mitgeliefert welche anstelle des Codes einen Verweis auf die neueste libc-Version enthalten. Diese enthält dann im Idealfall eben nicht nur Erweiterungen sondern auch Fehlerbereinigungen der 'alten' Funktionen. Wenn ich nun eine ältere Version über eine neuere installiere, mag das im besten Fall keine Auswirkungen haben: die neue Version bleibt bestehen so daß Programme die explizit diese benötigen darauf zugreifen können. Die ältereren Versionen werden dann aber wieder auf den Stand der neu installierten -aber eben älteren- Version zurückgesetzt. Die Fehlerbereinigungen gehen damit verloren.

Na ja, ich werde dann wohl erstmal mit yum weitermachen.
Ach so, es reicht also ein 'yum update' um alle installierten Pakete zu aktualisieren. Ich befürchtete schon jedes Paket einzeln benennen zu müssen, also 'yum update libc' o.ä. Woher sollte ich denn bloß die ganzen Namen kennen... ;-)
Schöne Grüße von Deutschlands größter Insel
ajunra

_diver
Posts: 204
Joined: Fri 27. Jun 2014, 10:57

Post by _diver » Mon 12. Jan 2015, 18:43

Dazu wurde ja genau http://trac.netlabs.org/rpm/wiki/RpmHowToEndUsers erstellt.
Klar das ganze ist in englisch, aber wer Google kennt, weiss wie man sich sowas übersetzen lassen kann :)

Wir sind uns bewusst, dass auch yum/rpm noch fehler hat. Aber seit doch einige Leute das nutzen, ist unser Supportaufwand sehr gesunken. Und es ist auch einfacher zu schreiben was zu installieren ist.

Dass es noch kein libc 066 rpm gibt, ist schnell erklärt. Ich musste entscheiden was mehr Priorität hat. ApacheOpenOffice, Firefox (sprich die ganzen eben erst veröffentlicheten) Applikationen, oder libc und andere rpm updates. Meinermeinung nach sind die Applikationen wichtiger. Libc rpm ist zur Zeit im Teststadium und wird sehr bald, sprich bestimmt diesen Monat, in's normale Repository verschoben.

Gruss
Silvan

ajunra
Posts: 370
Joined: Mon 23. Dec 2013, 06:40
Location: Insel Rügen

Post by ajunra » Tue 13. Jan 2015, 01:53

Auf jeden Fall muss ich ein ganz großes DANKE an Dich bzw. an euch schicken, _diver!

Bitte werte meine Meinung bezüglich rpm/yum nicht als Gemecker. Es ist einfach so, daß ich mir mit der englischen Sprache tierisch einen abbreche, und das von Dir genannte Google macht so manchen Text eher schwerer denn leichter verständlich (wende das mal auf os2world.com-Forenbeiträge an ;-)). Und ausserdem bin ich ein klassischer 'Mausschubser'. Das rpm/yum sich noch in Entwicklung befindet, ist mir durchaus bewusst. Daß es demnächst (endlich!) eine Grafische Oberfläche dafür geben soll, vernahm ich bereits und kann es kaum Erwarten.
Nee, mittlerweile lehne ich rpm/yum nicht mehr grundsätzlich ab, für mich ist es aber in der momentanen Form -bitte nicht falsch verstehen- eine kaputte Krücke. Sie hilft auf der einen Seite und macht es doch auf der anderen wieder schlimmer. Wie andi es schrieb: wenn man es als einziges Installationswerkzeug anwenden (kann), funktioniert es sicherlich recht gut. Wenn ihr als Entwickler damit auch noch Arbeit spart, um so besser! Aber genug zu rpm/yum. Der Wurm liegt wohl eher in der Uneinigkeit der Ablageplätze (und der damit verbundenen Mehrfachablage) für dlls.

Also empfehlt ihr für die optimale Installation von AOO die Nutzung von rpm mit anschließendem Neustart und folgender WPI-Installation. Ist das korrekt? Sollte man vorher eines der oOo 3.2 - WPI-Pakete (evtl. Associations oder Shared files) deinstallieren?
Schöne Grüße von Deutschlands größter Insel
ajunra

_diver
Posts: 204
Joined: Fri 27. Jun 2014, 10:57

Post by _diver » Tue 13. Jan 2015, 09:56

ajunra » Di 13. Jan 2015, 01:53 wrote:Auf jeden Fall muss ich ein ganz großes DANKE an Dich bzw. an euch schicken, _diver!
Bitte gern geschehen.
Also empfehlt ihr für die optimale Installation von AOO die Nutzung von rpm mit anschließendem Neustart und folgender WPI-Installation. Ist das korrekt? Sollte man vorher eines der oOo 3.2 - WPI-Pakete (evtl. Associations oder Shared files) deinstallieren?
Ja wir empfehlen wann immer möglich mittels rpm/yum zu installieren.

AOO funktioniert gut mit der alten OOO 3.2 zusammen. Also muss man nichts deinstallieren.
Wir sind gerade am überlegen, ob wir auch die WPS extension an AOO anpassen sollen. Lasst euch überaschen.

Gruss
Silvan

Andi B.
Posts: 515
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. » Tue 13. Jan 2015, 13:47

...ob wir auch die WPS extension an AOO anpassen sollen...
Finde ich wichtig.

Auch der Parallelbetrieb einer 3er Version und der 4er. Wie bekannt sein dürfte, ist ja ab v4 die Unterstützung verschiedener alter Dateiformate (StarOffice .sdc, .sdw, ....) rausgefallen. Wer also noch eine alte Datei öffnen will, ist auf eine 3er Version oder dem uralten StarOffice5.1a angewiesen.

Holger_27
Posts: 17
Joined: Thu 15. Jan 2015, 15:46

Post by Holger_27 » Mon 19. Jan 2015, 13:05

Hallo OS/2 Fans
Ich habe versucht die Datei AOO-4110-GA-rpm.wpi zu installieren indem ich das wpi Symbol anklicke, bekomme aber eine Fehlermeldiung das die Datei nicht vollständig ist. Ich habe dann die Datei AOO-4110-GA-rpm.wpi per Kommandozeile entpackt mit wic AOO-4110-GA-rpm.wpi -x. Einige DLL´s wurden entpackt. Diese habe ich in mein OS/2 DLL Verzeichnis kopiert. Open Office meldet aber einen Fehler das die Datei libc0684.dll fehlt. Wo bekomme ich diese dll her ? Vielleicht hat jemand auch eine AOO-4110-GA-rpm.wpi Datei die man problemlos entpacken kann ?

Vielen Dank im voraus
Holger

_diver
Posts: 204
Joined: Fri 27. Jun 2014, 10:57

Post by _diver » Mon 19. Jan 2015, 18:47

Holger_27 » Mo 19. Jan 2015, 13:05 wrote:Hallo OS/2 Fans
Ich habe versucht die Datei AOO-4110-GA-rpm.wpi zu installieren indem ich das wpi Symbol anklicke, bekomme aber eine Fehlermeldiung das die Datei nicht vollständig ist. Ich habe dann die Datei AOO-4110-GA-rpm.wpi per Kommandozeile entpackt mit wic AOO-4110-GA-rpm.wpi -x. Einige DLL´s wurden entpackt. Diese habe ich in mein OS/2 DLL Verzeichnis kopiert. Open Office meldet aber einen Fehler das die Datei libc0684.dll fehlt. Wo bekomme ich diese dll her ? Vielleicht hat jemand auch eine AOO-4110-GA-rpm.wpi Datei die man problemlos entpacken kann ?

Vielen Dank im voraus
Holger
Holger,

den Hinweis hast gelesen oder? Otherwise you need to grab the AOO-4110-GA-rpm.wpi before you start the installation.
Das ist aus der Readme, welche im Downloadverzeichniss ist.
Das GA-rpm.wpi ist kein eigenständiges wpi, es ist ein helper wpi. Das heisst die AOO Installation entpackt das wpi, falls notwendig.

Und du bist sicher AOO meldet, dass libc0684.dll fehlt? Nicht nur libc064.dll.
Wie alt ist deine installation, dass du noch kein libc064 oder neuer drauf hast?
Ich empfehle dir das ganze entweder via rpm/yum zu installieren, oder das libc ftp://ftp.netlabs.org/pub/gcc/libc-0_6_6-csd6.wpi zu installieren.

Gruss
Silvan

Holger_27
Posts: 17
Joined: Thu 15. Jan 2015, 15:46

Post by Holger_27 » Tue 20. Jan 2015, 12:50

Hallo Silvan
Ich habe zuerst nur Open Office installiert und wollte dann das paket AOO-4110-GA-rpm.wpi nachinstallieren, bekam dann die Fehlermeldung das die Datei libc0684.dll fehlt. Darauf hin habe ich mir die readme Datei nochmals durchgelesen und gelesen das die Open Office Installations wpi Datei die AOO-4110-GA-rpm.wpi automatisch findet und mit installiert. Daraufhin habe ich Open Office komplett gelöscht und die OpenOffice wpi mit der AOO-4110-GA-rpm.wpi in ein Unterverzeichnis kopiert und neu installiert. Die Datei AOO-4110-GA-rpm.wpi wurde mit installiert. Leider war das Ergebnis das selbe, ich bekam wieder die Fehlermeldung das die Datei libc0684.dll fehlt. Die libc06...dll sind alle im OS2\DLL verzeichnis vorhanden.

Hat jemand noch eine Idee wo das Problem liegen könnte ?

Viele Grüße
Holger

_diver
Posts: 204
Joined: Fri 27. Jun 2014, 10:57

Post by _diver » Tue 20. Jan 2015, 15:48

Holger_27 » Di 20. Jan 2015, 12:50 wrote:Hallo Silvan
Ich habe zuerst nur Open Office installiert und wollte dann das paket AOO-4110-GA-rpm.wpi nachinstallieren, bekam dann die Fehlermeldung das die Datei libc0684.dll fehlt. Darauf hin habe ich mir die readme Datei nochmals durchgelesen und gelesen das die Open Office Installations wpi Datei die AOO-4110-GA-rpm.wpi automatisch findet und mit installiert. Daraufhin habe ich Open Office komplett gelöscht und die OpenOffice wpi mit der AOO-4110-GA-rpm.wpi in ein Unterverzeichnis kopiert und neu installiert. Die Datei AOO-4110-GA-rpm.wpi wurde mit installiert. Leider war das Ergebnis das selbe, ich bekam wieder die Fehlermeldung das die Datei libc0684.dll fehlt. Die libc06...dll sind alle im OS2\DLL verzeichnis vorhanden.

Hat jemand noch eine Idee wo das Problem liegen könnte ?

Viele Grüße
Holger
Bitte poste die genaue Fehlermeldung, weil eine libc0684.dll gibt es nicht.
Bitte auch mal den Inhalt der libc* in os2\dll posten und schauen dass keine doppleten libc*.dll vorhanden sind.
Gruss
Silvan

User avatar
LotharS
Posts: 695
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS » Tue 20. Jan 2015, 17:19

Holger_27 » Di 20. Jan 2015, 12:50 wrote: ich bekam wieder die Fehlermeldung das die Datei libc0684.dll fehlt. Die libc06...dll sind alle im OS2\DLL verzeichnis vorhanden.
Manchmal hilft PMDLL, den Verursacher einzukreisen. Eventuell liegt es an irgendeiner dritten aufrufenden DLL, diese aber Namensduplikat zu einer aus AOO und nur zufällig weiter vorne im LIBPATH?

Holger_27
Posts: 17
Joined: Thu 15. Jan 2015, 15:46

Post by Holger_27 » Wed 21. Jan 2015, 12:50

Hallo
Ich habe gestern das DLL Paket libc-0_6_6-csd6.wpi installiert, hatte eine etwas ältere Version installiert. Ich hatte das DLL Paket AOO-4110-GA-rpm.wpi per kommandozeile entpackt und dann ins DLL Verzeichnis kopiert. Gestern ist mir aufgefallen das diese DLL´s von Open Office nicht ins DLL Verzeichnis kopiert werden sondern ins Open Office Verzeichnis unter dem Verzeichnis Program. Habe daraufhin die DLL´s im OS2 \DLL Verzeichnis entfernt und auch Open Office deinstalliert. Danach habe ich Open Office neu installiert. Beim aufrufen eines Programteils bekomme ich wieder die Fehlermeldung das die libc0684.dll fehlt. Hat vielleicht jemand ncoh einen Lösungsansatz ?

Vielen Dank
Holger