Samba scheint etwas verwirrend....

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Samba scheint etwas verwirrend....

Post by DonLucio »

Aus Anlass meines neuen QNAP-NAS habe ich mich jetzt mal mit Samba befassen müssen. Ich schrieb hier an anderer Stelle im Forum, dass die Verbindung zum NAS mittels Samba funktioniert.

Inzwischen muß ich da einige Einschränkungen machen.

Angefangen habe ich in der Weise, dass ich die NAS auf mein lokales Laufwerk/Verzeichnis "Z:\Qnap" gemappt habe. Das funktionierte. Ich konnte mit versch. Filebrowsern das Laufwerk Z: öffnen und fand dann sämtliche Verzeichnisse, die ich im NAS angelagt hatte, dort unter "Qnap" wieder.

Das Mappen auf ein künstliches Verzeichnis "Qnap" erweist sich aber (für mich) als unzweckmäßig. Also habe ich versucht, einfach nur auf Laufwerk Z:\ zu mappen. Das verweigert der Arca-Mapper aber: "Invalid parameter".

Zufällig finde ich aber in den Tiefen meiner OS/2-Archive noch eine alte Version von Samba, repräsentiert durch das Programm evfsgui.exe, Dateigröße 718.600 Bytes, Timestamp: 13-08-13 16:23:28. Vermutlich noch aus eCS-Zeiten.

Mit dieser alten Samba-Version ist es aber möglich, die NAS ohne weitere Zwischen-Verzeichnisse direkt auf ein Laufwerk zu mappen und ich sehe auch keine anderen Funktions-Beschränkungen. Ich könnte also das allgemeine Unbehagen über die Verwendung einer veralteten Programmversion ignorieren und gut ist.

Leider hat das alte Samba (evfsgui) ein anderes Problem: Die zugehörige NLS-Datei ist futsch. Beim Starten kriege ich mehrfach die Meldung "could not find a valid language file", zum Schluß auch noch "could not find net.exe". All das beeinträchtigt aber nicht die Funktionalität (wozu ist net.exe gut?).

Störend ist das mehrfache Hochpoppen der Fehlermeldungen allerdings schon, zumal da sich mein Samba im Startup-Folder befindet und dadurch den morgendlichen (bzw. mehrfachen) Boot-Vorgang stolpern läßt.

Frage also: Wo kriege ich die fehlenden Dateien her? (Das Samba auf Hobbes ist aus dem Jahre 2000 ...)

Danke,
Don Lucio.

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

Vorab: Danke für Deinen ausführlichen Bericht!
DonLucio wrote:
Fri 8. Jan 2021, 19:40
Das Mappen auf ein künstliches Verzeichnis "Qnap" erweist sich aber (für mich) als unzweckmäßig. Also habe ich versucht, einfach nur auf Laufwerk Z:\ zu mappen. Das verweigert der Arca-Mapper aber: "Invalid parameter".
Wenn es nur mit Mountpoint Z:\Qnap statt Z:\ gehen sollte, dann könnte das ein Bug sein?; aus der Hilfe:
"If the selected virtual drive does not exist already, it will be attached (created, added) automatically. The same is true for the mountpoint. By default, the root of the virtual drive is used as the mountpoint. "
Oder was anderes, dann hilft vielleicht ein Log (auf höchster Stufe) und Inspektion der ndc-Datei weiter?
Oder dies: https://www.arcanoae.com/wiki/arcamapper/.
Ich selbst verwende nicht das Rootverzeichnis, sondern jeweils ein "echtes" Verzeichnis je Share. Und (noch..?) kein NAS.
zum Schluß auch noch "could not find net.exe".
Da hab ich sogar dreie von: :ugeek:

Code: Select all

[C:\]dir /s net.exe
The volume label in drive C is ARCAOS.
The Volume Serial Number is A666:85BE.
Directory of C:\Programs\NDFS
 3.11.16 11.53         43.791      0 a---  net.exe
        1 file(s)      43.791 bytes used
Directory of C:\Programs\Samba
16.02.17 11.34      6.929.008      0 a---  net.exe
        1 file(s)   6.929.008 bytes used
Directory of C:\usr\libexec\samba
26.01.20  0.46      4.618.107    124 a---  net.exe
        1 file(s)   4.618.107 bytes used
Laut %PATH% könnte grundsätzlich ersteres genommen werden, aber wer weiß...
wozu ist net.exe gut?
Eigentlich: damit es funktioniert... :roll: Tippe mal "net | more" (ohne Gänseklein) in die Kommandozeile, je Fundstelle...
Viel Erfolg!
Last edited by LotharS on Sat 9. Jan 2021, 10:18, edited 1 time in total.

User avatar
Pepe
Posts: 13
Joined: Wed 15. Jan 2014, 14:21

Post by Pepe »

Hallo Lutz !

Versuche es einmal mit diesem Link.

ftp://ftp.netlabs.org/pub/samba/client/ ... 130813.zip

Zumindestens sind dort im Verzeichnis "lang" die unterschiedlichen *.msg - Dateien.

Die "net.exe" findet das Programm im installierten SAMBA-Verzeichnis (Samba Server Version 3.6.25) , wenn vorhanden.

Bei mir ist das jedenfalls so.

Ich hoffe, das hilft Dir weiter.

Gruß Pepe

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

Hallo LotharS,
hallo Pepe,

vielen Dank, das hat mich einen Schritt weiter gebracht. Die *.msg-Dateien sind jetzt da (aus dem netlabs-Archiv), die Fehlermeldungen sind weg.

Weiterhin unklar ist die Fehlermeldung "could not find net.exe".
Unklar aus zwei Gründen:
(1) Genau wie LotharS geschrieben hat, befinden sich tatsächlich drei Versionen von net.exe in drei versch. Verzeichnissen. Eines davon (C:\programs\ndfs) ist auch im PATH drin. Wieso findet evfsgui das dann nicht??
(2) Eigentlich funktioniert alles (soweit ich es sehen kann). Ich kann mounten mit Mountpoint oder auch ohne (also nur Z:\). Was stört, ist lediglich die aufpoppende Fehlermeldung beim Booten.

Verwirrend ist auch, dass das neuere Samba, unter dem Namen Arca-Mapper zwar keine Fehlermeldungen beim Start generiert, dafür aber den (offensichtlich) Bug enthält, kein Mounten nur aufs Laufwerk zuzulassen.

Andererseits muß ich zugestehen, dass meine Methode, ohne Mountpoint zu connecten, ziemlich ungewöhnlich ist: knapp 4 Terabyte Daten auf ein einziges Laufwerk zuzuordnen - das werde ich wohl noch mal überdenken müssen.

Alles in Allem: Samba funzt jetzt und ich kann das Thema damit schließen. Nochmals vielen Dank für eure Hilfe.

Gruß,
Don Lucio.

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

DonLucio wrote:
Sat 9. Jan 2021, 13:55
Alles in Allem: Samba funzt jetzt und ich kann das Thema damit schließen.
Das schrieb ich gestern. Heute schon muß ich das leider revidieren ...

Soll ich einen neuen Thread aufmachen? Ich denke, ich bleibe mal hier.

Problem ist:
Über die SAMBA-GUI kriege ich alles hin, was ich machen will: Verbindung mit der Qnap-NAS herstellen, dortige Verzeichnisse auf ein lokales ("virtuelles") Laufwerk mappen. Soweit so gut.

Was aber überhaupt nicht funzt, ist die Steuerung per Kommandozeile. Das fängt schon mit der Einbindung in den Startup-Folder an. Die Profil-Datei (.ndc), die ich zuvor im Dialog erstellt und gesavet habe, läßt sich im Kommandozeilenmodus nicht laden ("invalid parameter"). Weder beim Booten aus dem Startup-Folder noch später, direkt in einer Kommandozeilen-Session eingegeben. Ein Problem, dass aber nur der (neuere) Arca-Mapper hat, nicht das alte EVFSGUI. Der hat aber andere Probleme (wie hier in meinen vorigen Posts schon geschildert), deswegen will ich beim Arcamap bleiben.

Aber es gibt noch ein zweites Problem:
Es fehlt ein Batch-Parameter für "Detach all". Anders formuliert:
Wenn ich das Arcamap-Programm zweimal hintereinander aufrufe, jeweils mit einer anderen ndc-Parameterdatei, dann wird der zweite Mount *zusätzlich* zu dem ersten angelegt. Und das stört.

Beispiel zur Erläuterung:
Auf der NAS habe ich (u.a.) drei Ordner-Strukturen:
- Musik
- Photos
- Videos
jeweils mit vielen Unterordnern. Weil das insgesamt zigtausende Dateien sind, will ich nicht alles auf ein Laufwerk zuordnen, sondern je nach Bedarf: Vormittags will ich Musik hören, nachmittags Photos und 10 Minuten später Videos. Ich habe aber nur ein virt. Laufwerk frei, und zwar Z:
Ich habe also mal Z:\Musik, mal Z:\Photos, mal Z:\Videos.

Was ich *nicht* möchte, ist:

Code: Select all

Z:
   \Musik
   \Photos
   \Videos
Nach gegenwärtigem Stand meiner Kenntnis kann ich das nur erreichen, indem ich jeweils den Arcamapper aufrufe, zuerst auf "Detach" klicke, dann über die Dialogfunktionen meinen jeweilen Share auswähle und zuordne.

Das kann man so machen, ist aber lästig (finde ich). Ich möchte gern stattdessen mit einem Klick auf ein (von mir erzeugtes) WPS-Programmobjekt einfach von einem Share auf den anderen hin- und her-switchen.

Dazu bräuchte es einen Kommandozeilen-Parameter "detach" oder "unmount" oder etwas Äquivalentes.

In der Hilfedatei habe ich dazu nichts gefunden. Nun habe ich die Hoffnung, dass es dennoch solch eine ("geheime") Batch-Funktion gibt.

Weiß jemand mehr?

Danke,
Don Lucio.

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

DonLucio wrote:
Sat 9. Jan 2021, 13:55
Weiterhin unklar ist die Fehlermeldung "could not find net.exe".
Inzwischen nicht mehr. Es hat sich herausgestellt, dass EVFSGUI nicht im PATH nach dieser Datei sucht, sondern er erwartet sie fest verdrahtet in c:\usr\bin.

War letztendlich aus den Debug-Meldungen in der VX-Rexx-Console herauszulesen.

Gruß,
Don Lucio.

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

DonLucio wrote:
Sun 10. Jan 2021, 18:33
Auf der NAS habe ich (u.a.) drei Ordner-Strukturen:
- Musik
- Photos
- Videos
jeweils mit vielen Unterordnern. Weil das insgesamt zigtausende Dateien sind, will ich nicht alles auf ein Laufwerk zuordnen, sondern je nach Bedarf: Vormittags will ich Musik hören, nachmittags Photos und 10 Minuten später Videos. Ich habe aber nur ein virt. Laufwerk frei, und zwar Z:
Ich habe also mal Z:\Musik, mal Z:\Photos, mal Z:\Videos.

Was ich *nicht* möchte, ist:

Code: Select all

Z:
   \Musik
   \Photos
   \Videos
Nach gegenwärtigem Stand meiner Kenntnis kann ich das nur erreichen, indem ich jeweils den Arcamapper aufrufe, zuerst auf "Detach" klicke, dann über die Dialogfunktionen meinen jeweilen Share auswähle und zuordne.

Das kann man so machen, ist aber lästig (finde ich). Ich möchte gern stattdessen mit einem Klick auf ein (von mir erzeugtes) WPS-Programmobjekt einfach von einem Share auf den anderen hin- und her-switchen.

Dazu bräuchte es einen Kommandozeilen-Parameter "detach" oder "unmount" oder etwas Äquivalentes.
Warum mountest Du nicht einfach beim Systemstart das komplette 'Z:\' und belässt es dabei? Sofern NAS bereits "oben", oder sonst ndc explizit laden. Dessen Unterverzeichnisse und Dateien sind auf dem Rechner allesamt virtuell und produzieren höchstens Handles in der OS2SYS.INI nach WPS-Zugriff (gelegetliches cleanini sei sowieso empfohlen). Würde doch Deinen Tagesablauf wesentlich flexibler erlauben :lol:

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Mon 11. Jan 2021, 12:13
Warum mountest Du nicht einfach beim Systemstart das komplette 'Z:\' und belässt es dabei?
Ja, das geht, so habe ich ja angefangen. Aber einen Datenpool von knapp 4 Terabytes (NAS), aufgteilt in dutzende (Unter)Verzeichnisse, auf *ein* Laufwerk zu mappen, erscheint mir wenig zweckmäßig.

Hinzukommt, dass die Ordnerstruktur auf dem NAS nicht dieselbe ist, wie die auf meinem PC. Beispiel: Ein Ordner, der auf dem PC ein Hauptverzeichnis ist (X:\MeineMusik\...) befindet sich auf der NAS in unterer Ebene (z.B. Qnap//PC-Daten/Multimedia/MeineMusik/...). Und dann möchte ich mein virtuelles Laufwerk Z: direkt auf Qnap/MeineMusik mappen. Aber nicht permanent, sondern nur bei Bedarf. Um einen solchen Mount auszuführen, muß zuerst das alte Z: komplett detached (unmounted) werden. Ich begreife nicht, dass es dafür keinen Kommandozeilen-Parameter gibt, so wie -AUTOCLOSE und -NOGUI.

Man kann sagen: Wo ist das Problem, in der GUI kann ich ja bei jedem Umschalten auf eine andere Mount-Struktur händisch den "Detach" (deutsch: "abhängen") anklicken. Ich bin aber ein fauler Mensch. Ich möchte mit buchstäblich nur einem Klick von meiner Musik-Struktur umschalten auf meine Video-Struktur auf meine Arbeits-Struktur .... etc.

Verwirrend kommt hinzu, dass
(1) Es überhaupt nur funktioniert mit dem alten EVFSGUI
(2) sporadisch es vorkommt, dass die alte Z:-Verbindung gelöscht wird und der neue Mount dann tatsächlich (wie von mir gewünscht) nur die neuen Shares kennt.

Aber - der langen Rede kurzer Sinn - es gibt Licht am Ende des Tunnels:
Ich fand im Original-Netdrive-Paket eine Rexx-fähige DLL namens NDCalls sowie die Beschreibung zu ihren Funktionen. Darin enthalten ist alles, was man zum Programmieren eines Samba-Clients braucht, u.a. eine Detach-Funktion.

Selbst ist der Mann :-)

Gruß,
Don Lucio.

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

DonLucio wrote:
Mon 11. Jan 2021, 14:28
Beispiel: Ein Ordner, der auf dem PC ein Hauptverzeichnis ist (X:\MeineMusik\...) befindet sich auf der NAS in unterer Ebene (z.B. Qnap//PC-Daten/Multimedia/MeineMusik/...). Und dann möchte ich mein virtuelles Laufwerk Z: direkt auf Qnap/MeineMusik mappen.
Wie soll das gehen?? Neben der "echten" Musik im lokalen Laufwerk X: hast Du nach dem Mappen per Samba/NDFS eine "virtuelle" Musik: namens-sichtbar unter Laufwerk Z: aber "echt" auf dem NAS. Getrennt Nebeneinander und nicht gequirlt Ineinander sichtbar, so wird's sauber. Es steht Dir dann frei, eine Mucke 'Z:\tralala...' nach X:\tralala... (oder zB. C:\temp) physisch zu kopieren ("downloaden") oder direkt von der NAS-"Audiothek" mitels (nur) Identifikation per Z:\tralala.. zu "streamen". Umgekehrt kopieren/upload aufs NAS sowie rename/move/delete dort.
Aber nicht permanent, sondern nur bei Bedarf.
Dann mache ich bloß das Ordnerfenster Z:\MeineMusik einfach zu bis ich's wieder ansehen möchte oder den Rechner runterfahre... Die nur virtuellen Musiken kosten auf dem lokalen Rechner so gut wie nichts. - Sollte der externe "Server" NAS vorher beendet werden, so lässt sich die passende gespeicherte ndc-Datei ja notfalls neu laden. Dazu würde ich dem NAS aber eine feste IP im Heimnetz gegeben haben.

Nachtrag:
Zufällig finde ich aber in den Tiefen meiner OS/2-Archive noch eine alte Version von Samba, repräsentiert durch das Programm evfsgui.exe, Dateigröße 718.600 Bytes, Timestamp: 13-08-13 16:23:28. Vermutlich noch aus eCS-Zeiten.
Eine weniger alte EVFSGUI befindet sich hier, neben weiteren Hinweisen.
Last edited by LotharS on Mon 11. Jan 2021, 15:23, edited 1 time in total.

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Mon 11. Jan 2021, 15:19
Wie soll das gehen?? Neben der "echten" Musik im lokalen Laufwerk X: hast Du nach dem Mappen per Samba/NDFS eine "virtuelle" Musik: namens-sichtbar unter Laufwerk Z: aber "echt" auf dem NAS.
Nein, da habe ich mich wohl falsch ausgedrückt. Den "Musik"-Ordner gibt es physisch nur auf der NAS, so wie alle anderen in meinen Beispielen auch. Ich glaube, das entspricht dem, was du in deinen nachfolgenden Sätzen empfohlen hast.

Dann mache ich bloß das Ordnerfenster Z:\MeineMusik einfach zu bis ich's wieder ansehen möchte oder den Rechner runterfahre...
Ok, die ganze Sache mit Hilfe von WPS-Ordnern zu organisieren, könnte ein Weg sein. Werde ich mal ausprobieren. Die Frage ist, ob das nicht bei der riesigen Fülle an gemappten NAS-Daten meine WPS (und damit die INI) stark aufblähen würde.

Dazu würde ich dem NAS aber eine feste IP im Heimnetz gegeben haben.
Habe ich. Entgegen der Empfehlung der Qnap ;)

Eine weniger alte EVFSGUI befindet sich hier, neben weiteren Hinweisen.
Oh - ein guter Hinweis! Da findet sich u.a. dieser bemerkenswerte Satz:
"Try to avoid to install both [Netdrive und EVFS], as this will for sure confuse one or the other. If you need other NetDrive plugins, we recommend to deinstall EVFS. "
Und ja, tatsächlich, ich habe beides installiert. :shock:

Werde mal ans Großreinemachen bei mir gehen, möglicherweise sind danach ja ein paar Verwirrungen weniger :D

Danke einstweilen,
Don Lucio.

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

DonLucio wrote:
Mon 11. Jan 2021, 16:09
Ok, die ganze Sache mit Hilfe von WPS-Ordnern zu organisieren, könnte ein Weg sein. Werde ich mal ausprobieren. Die Frage ist, ob das nicht bei der riesigen Fülle an gemappten NAS-Daten meine WPS (und damit die INI) stark aufblähen würde.
Wenn das Mounten ordentlich geklappt hat, so leuchtet das Laufwerk 'Z:' im Ordner 'Laufwerke' von ganz alleine auf und lässt sich durchklicken; dabei erscheint die ferne Verzeichnisstruktur in Ordnerform. Falls nicht, war was faul...
Zum "Streamen" einer Musik oder Videos lässt sich zB. VLC auch mit Datei->Öffnen bedienen, analog zB. PMView (meine Favoriten), statt mit Doppelklick aufs Dateisymbol.
Meine Shares (hier auf dem VBox-Host=Win10) verwalte ich von eCS/ArcaOS aus mit einem antiquierten Dateimanager. Der tut seit Warp3-Jahren was er soll, ohne jedesmal die WPS zu bebildern und zusätzich die OS2SYS.INI zu belasten; sollte evtl auch mit FM/2 oder FileCommander/2 möglich sein(?).

Für den Fall dass Du doch noch wieder auf die wirklich neueren NDFS und ArcaMapper zurück möchstest (würd' ich prinzipiell empfehlen), so findest Du sie auf der ArcaOS-DVD unter \CID\SERVER\ARCAPKG zum Neuinstallieren. Als Workaround könnte der Mountpoint auch 'Z:\Qnap' heißen und bei Bedarf sowas wie 'Z:\WasAnderes' für die Verbindung von/zu einem anderen Rechner per SMB/Samba. Das 'Z' heißt bei mir 'J', weil das 'Z' manchmal gern als RAM-Lw vergeben wird (zB. DFSee).
danach ja ein paar Verwirrungen weniger
Es wäre daher generell auch gut, immer auf einen Blick zu sagen, ob man mit "Samba" den Client oder den Server gemeint hat :)

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Mon 11. Jan 2021, 18:24
Es wäre daher generell auch gut, immer auf einen Blick zu sagen, ob man mit "Samba" den Client oder den Server gemeint hat :)
Einverstanden. Ich dachte aber, ich hätte dem Genüge getan, da es klar sei, dass ich von Client spreche, denn der Sama-Server ist ja unzweifelhaft auf der NAS.

Auf jeden Fall noch mal Danke für den Hinweis auf die netlabs-Seite, da findet sich ne Menge Interessantes.

Gruß,
Don Lucio.

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

Inzwischen habe ich ganz andere Probleme: Ich kriege keinen Mount mehr hin:

"SYS0059: An unexpected network error occurred"

Das Laufwerk Z: wird zwar noch angelegt (attached), aber ein Mount endet mit der o.a. Fehlermeldung. Egal, welches Verzeichnis ich versuche, zu mounten. Und auch egal, ob per EVFSGUI oder ARCAMAP.

Ich erreiche die Qnap-NAS aber weiterhin per Browser, also die Admin-Seite der NAS ist voll funktionsfähig (natürlich auch ping).
Und per Windows (Explorer -> "Netzwerk") klappt es auch weiterhin, die NAS-Ordner zu sehen und zu verwalten.

Das Problem ist aus heiterem Himmel gekommen, nachdem ich seit Tagen schon mit der NAS gearbeitet hatte. An Netzwerk-Einstellungen habe ich nix geändert.

Vielleicht hängt das Problem mit einem anderen Problem zusammen, das ich unmittelbar zuvor hatte:
Beim kopieren von mehreren tausend Dateien vom PC auf die NAS erhielt ich plötzlich die Nachricht "no more space". Ich schaute in der NAS nach und da wurde mir ein Gesamt-Platz des Volumes mit 350 GB angezeigt, davon "free space" mit 288 GB. Also wieso kriege ich auf dem PC eine "no space"-Fehlermeldung? Gibt es irgendwo in den Tiefen der Netdrive/SMB-Konfigurationen einen Wert, der die Größe von virtuellen Laufwerken begrenzt? Oder eine "magische" 64GB-Grenze? In der smb.conf habe ich nichts gefunden. Unnötig zu erwähnen, dass unter Win diese Beschränkung nicht existiert, von dort konnte ich weitere Gigabytes auf die NAS laden.

Habe die NAS schon runter- und wieder raufgefahren - ohne Ergebnis. Ich bin etwas ratlos.

Danke für hilfreiche Ideen,
Don Lucio.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Was sagt denn ein Dateimanager (kann auch PM sein) oder die Befehlszeile dazu?

Eine obere Grenze gab es beim Ressourcen-Browser, war glaub ich bei 64 MB. Bei Netdrive würd mich das wundern, denn das Mappen passiert ohne WPS.
Andreas Schnellbacher

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

aschn wrote:
Wed 13. Jan 2021, 14:42
Was sagt denn ein Dateimanager (kann auch PM sein) oder die Befehlszeile dazu?
Kann ich nicht sagen, komm' ja nicht mehr ran an die NAS (wg. dem beschriebenen "SYS0059 - unexpected network error").

Interessanterweise sehe ich alle im Netz befindlichen Samba-Server (im Einstellungs-Notebook unter "Netzwerkumgebung"), nicht nur meinen QNAP, sondern auch den alten Medion-NAS sowie einen am Router angeschlossenen Win7-PC. Nur das "Verbinden" oder "mounten" endet immer mit diesem Sys0059.

Verdammte Axt, es lief doch alles schon! Bis gestern.

Eine obere Grenze gab es beim Ressourcen-Browser, war glaub ich bei 64 MB.
Hättest du 64 GB gesagt, würde das zu meinem Speicher-Problem passen. Bei etwa dieser Speicherbelegung bekam ich die "no more space"-Meldung (von der Kommandozeile, xcopy).

Gruß,
Don Lucio.

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

Das SYS0059-Problem hat sich jetzt geklärt:
Eine alte Version von NDCALLS.DLL (aus meinem mal vor Jahren gekauften Netdrive.314) ist mir irgendwie in meinen Libpath geraten ... :-(

Schwamm drüber.

Was jetzt noch Probleme bereitet, ist das (anscheinend) 64-GB-Limit des virtuellen Laufwerks:
aschn wrote:Was sagt denn ein Dateimanager (kann auch PM sein) oder die Befehlszeile dazu?
Der sagt jetzt: Free space 67,108,864.
aschn wrote:Eine obere Grenze gab es beim Ressourcen-Browser, war glaub ich bei 64 MB.
Jetzt erst verstehe ich, was du meintest: 64 MB Limit *pro Datei*. Ja, das macht Sinn, denn die Datei, die zu kopieren immer mit "no more space" endet, ist 92 MB groß. Alle Dateien, die kleiner sind als 64 MB, lassen sich kopieren, größere scheitern.

Also die Frage etwas anders gestellt: Wo im Samba ist das Dateigrößen-Limit von 64 MB konfiguriert? Ich weiß nicht, an welcher Stelle ich da suchen soll. Im net.conf habe ich schon geschaut, nix gefunden.

Danke
Don Lucio.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

DonLucio wrote:
Wed 13. Jan 2021, 17:18
aschn wrote:Eine obere Grenze gab es beim Ressourcen-Browser, war glaub ich bei 64 MB.
Jetzt erst verstehe ich, was du meintest: 64 MB Limit *pro Datei*.
Nein, beim Resssourcen-Browser gilt das insgesamt. Aber das hat überhaupt nichts mit Netdrive zu tun.
DonLucio wrote:
Wed 13. Jan 2021, 17:18
Ja, das macht Sinn, denn die Datei, die zu kopieren immer mit "no more space" endet, ist 92 MB groß. Alle Dateien, die kleiner sind als 64 MB, lassen sich kopieren, größere scheitern.
Das ist wohl eine Schwäche der veralteten OS/2-Werkzeuge. Ich würd das mal mit cp.exe, FM/2 oder Larsen Commander versuchen. Keine Ahnung, wie sich FC/2 da verhält.
DonLucio wrote:
Wed 13. Jan 2021, 17:18
Wo im Samba ist das Dateigrößen-Limit von 64 MB konfiguriert?
Nirgendwo. Wenn überhaupt, dann ist das ein Netdrive-Problem, was ich aber nicht glaube, weil das dann schon mal jemand gemeldet hätte.
Last edited by aschn on Wed 13. Jan 2021, 17:38, edited 1 time in total.
Andreas Schnellbacher

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Wenn es nicht an XCOPY liegen sollte (ich hab keine so großen Dateien), dann könntest Du auch mal bei den SaMBa-Tickets nachsehen, ob da was passt. Achte aber auf das Alter.
Andreas Schnellbacher

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

aschn wrote:
Wed 13. Jan 2021, 17:37
Ich würd das mal mit cp.exe, FM/2 oder Larsen Commander versuchen.
Nu' bin ich platt: mit cp.exe geht's.

Und wie sich herausstellt: mit copy oder xcopy auch!

Nur nicht mit meinem altehrwürdigen XTree (xtp.exe aus dem Jahre 2002). Verwirrung pur ...

Habe bisher mit XtreePro noch nie Probleme gehabt. Auch nicht mit Dateien > 2 GB. Jedenfalls nicht mit lokalen (realen) Laufwerken. Dieses Programm ist mein tägliches Werkzeug, es gibt kaum jemals fünf Minuten, in denen ich XTree nicht irgendwie benutze. Es ist unglaublich vielseitig und an die (bisweilen sperrige) Usability habe ich mich perfekt gewöhnt.

XTreePro ist ein VIO-Programm und ich ging immer davon aus, dass seine Datei-Operationen (copy, delete) letztlich technisch auf den gleichnamigen Kommandozeilen-Befehlen basieren, wenn nicht sogar einfach per Shell aufgerufen. Und bei Nicht-remoten Laufwerken gibt's ja auch keine Limitierung. Also, so ganz klar ist mir das alles nicht.

Ich fürchte, du wirst mir wenig Hoffnung machen, dass es zu diesem Problem irgendein Workaround gibt...

Immerhin muß ich jetzt nicht mehr nach irgendwelchen configs suchen :-)

Vielen Dank!
Don Lucio.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

Ich hab da etwas durcheinander bekommen: Es gibt einige Funktionen, die für große Dateien > 2 GB verwendet werden müssen, wie z.B. DosOpenL. DosCopy gehört nicht dazu.
Andreas Schnellbacher

User avatar
LotharS
Posts: 714
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

Zu "max 64MB" meine 2ct:
Habe eben zum Sapß mal eine Datei >300MB mit nur WPS-Copy von meinem Win10-Share nach ArcaOS c:\temp kopiert (hier ArcaMapper/NDFS). Sowie umgekehrt eine Datei > 2GB per WPS-Copy von eCS mit Samba-Server v.1.3.0 Richtung Win10. War alles heil angekommen.
Desgleichen mit meinem antiquierten Dateimanager (der allerdings Längen >2GB nicht immer korrekt _anzeigt_, war vorher schon klar).
Der Wurm scheint mir daher woanders zu stecken ... :)

Übrigens rate ich vor allem zum ArcaMapper statt EVFSGUI, nicht nur weil neuer, sondern es auch aktuellere Einstellungen zum SMB-Protocol gibt. SMB ist nämlich ein moving target, was die "Sicherheit" betrifft (musste daher dank Win10 damals auf eCS zu Netdrive wechseln). Auch ziemlich verwirrend ... ;)

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

aschn wrote:
Wed 13. Jan 2021, 19:39
Ich hab da etwas durcheinander bekommen: Es gibt einige Funktionen, die für große Dateien > 2 GB verwendet werden müssen, wie z.B. DosOpenL. DosCopy gehört nicht dazu.
Mein Problem besteht bei Dateien > 64 MB.

Ausserhalb von Samba kann mein Xtree sehr wohl Dateien > 64 MB, sogar > 2 GB kopieren.

Ich neige deshalb zu LotharS' Vermutung: Da muß noch etwas anderes dahinter stecken.

Aber, wenn's mit dem normalen copy geht, dann kann ich damit leben, notfalls mir mit Rexx einen Workaround basteln.

Gruß,
Don Lucio.
Last edited by DonLucio on Thu 14. Jan 2021, 00:00, edited 1 time in total.

aschn
Posts: 1037
Joined: Wed 25. Dec 2013, 22:47

Post by aschn »

DonLucio wrote:
Thu 14. Jan 2021, 00:00
Ich neige deshalb zu LotharS' Vermutung: Da muß noch etwas anderes dahinter stecken.
Das hat er doch gar nicht geschrieben. Du hast doch auch XTree eindeutig als Verursacher ausgemacht. Schon mal ZTreeBold probiert (Achtung, noch älter)?
Andreas Schnellbacher

Andi B.
Posts: 528
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

Bei alten Netdrive Versionen gab es ein Problem, welches ich beim WebDAV plugin debugged habe. Wenn ein Programm einen Buffer mit 64MB oder größer kopieren wollte, wurde ein Byte verschluckt. Man konnte das Problem beheben indem man ein Kopierprogramm nimmt welches kleinere Buffer übergibt (cmd copy, usw.,), das WebDAV plugin fixed, oder Netdrive fixed. Meine LarsenCommander Version hat damals größere Buffer übergeben, darum ist mir das aufgefallen.

Ich hab daraufhin mein lokales WebDAV gefixed, keine Ahnung ob der Bugtracker Eintrag es auch in die offiziellen sourcen geschafft hat, der Netdrive Entwickler hat in späteren Versionen auch eine Änderung diesbezüglich eingebaut wodurch dieses Problem nicht mehr auftreten sollte, und ich hab auch LarsenCommander wieder auf kleinere Buffer umgestellt.

Warum der lange Text - nun das Gleiche könnte ev. auch beim Samba plugin passieren. Klingt ja sehr ähnlich. Ich denke es sollte reichen, wenn du das aktuellste Netdrive verwendest. Das sollte den Fehler zudecken, wenn es sich um den Gleichen wie von mir geschildert handelt. Man könnte auch das plugin debuggen, oder Xtree anpassen......

Edit - ev. hab ich das MB und KB durcheinander gewürfelt. Genau erinnere ich mich nicht mehr. Aber die Kernaussage bleibt - du solltest nur mit den aktuellsten Versionen von netdrive/ArcaMapper/samba plugin testen.
Last edited by Andi B. on Thu 14. Jan 2021, 13:28, edited 1 time in total.

User avatar
DonLucio
Posts: 519
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

LotharS wrote:
Wed 13. Jan 2021, 19:47
Übrigens rate ich vor allem zum ArcaMapper statt EVFSGUI, nicht nur weil neuer, sondern es auch aktuellere Einstellungen zum SMB-Protocol gibt.
Beide Programme benutzen für die Mount- und Attach-Funktionen dieselbe NDCALLS.DLL, und die ist immerhin von 2017 (jedenfalls bei mir). Somit dürfte das aus 2013 stammende EVFSGUI dennoch die aktuellen Protokoll-Anforderungen erfüllen.

Gegen ArcaMapper spricht leider immr noch, dass das Programm mit einer Fehlermeldung abbricht, wenn man es aus dem Startup-Folder heraus aufruft, also mit einer .ndc-Datei als Parameter: "The parameter is incorrect". Während dieselbe .ndc-Datei beim EVFSGUI keine Probleme bereitet.

Leider hat aber auch das EVFSGUI eine Macke:
Es ist noch in einem Debug-Modus compiliert, mit der an sich nützlichen Folge, dass während des Programmablaufs jede Menge Zustandsmeldungen in der VX-Rexx-Console ausgegeben werden, eben diese Console aber bei Programmende nicht automatisch schließt, sondern mit einem manuellen Click auf das "X" in der Titlebar beendet werden muß.

Es fehlt einfach in der Quit-Section der Befehl: "Call VRRedirectStdIO 'OFF';"

Vielleicht liest ja jemand, der im Besitz des Sourcecodes ist, hier mit und kann das kurz einfügen ... ;)

Nachtrag:
Habe inzwischen einen Workaround gefunden. Mit dem Tool Pgmcntrl von Christian Langanke ist es möglich, die Session automatisch zu closen. Der Aufruf von EVFSGUI erfolgt ja ohnehin von innerhalb eines Rexx-Skripts, da kann man so eine Programmzeile leicht einfügen:

Code: Select all

pgmcntrl /Close "VX-REXX Console for <Name des Rexx-Programmobjekts>"
Damit bin ich am Ziel meiner Wünsche: Kann mit einem einzigen Mausclick beliebige NAS-Shares aktivieren, d.h. auf mein virt. Laufwerk Z: zuordnen, wobei der jeweils vorige Mount entfernt (detached) wird.

Danke an alle hier, die mir dabei geholfen haben :P

Gruß,
Don Lucio
Last edited by DonLucio on Thu 14. Jan 2021, 16:28, edited 1 time in total.