System zerschossen

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
User avatar
Frank Wochatz
Posts: 1067
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

System zerschossen

Post by Frank Wochatz »

Nun habe ich leider ein schwerwiegendes Problem: nach einiger Bastelei startet mein System nicht mehr.

Ich habe testweise mal SNAP installiert. Nachdem das nicht so gut lief, habe ich es mit der Deinstallationsroutine deinstalliert. Danach bootet mein System immer von alleine in einer Endloschleife neu, bevor der Desktop geladen war. OK - ich boote mit ALT F1, und benutze die Option um die Grafik auf Standard VGA zurückzustellen.

Nun startet mein System nicht mehr. Ich bekomme folgende Fehlermeldung:

Internal rev 14.105-SMP
Datei SCREEN01.SYS konnte nicht gefunden werden.

Boote ich von eCS CD 1 zu einer Wartungskonsole, dann kann ich auf mein Laufwerk nicht zugreifen. Ich kann zwar auf C: wechseln, bekomme da aber bei jeder Aktion einen
SYS0318 Message file OS0001.MSG cannot be found for message 0627.

Offenbar ist das Dateisystem zerschossen.

Ein checkdisk brachte keine Abhilfe.

Hat jemand eine Idee? Ich habe dann mal JUNE Demo zum Retten von JFS Datein gestartet, das findet auch viele Dateien, stürzt dann aber einfach irgendwann beim Auflisten ab.

User avatar
Sigurd
Posts: 924
Joined: Mon 23. Dec 2013, 08:35

Post by Sigurd »

Frank Wochatz wrote:Nun habe ich leider ein schwerwiegendes Problem: nach einiger Bastelei startet mein System nicht mehr.

Ich habe testweise mal SNAP installiert. Nachdem das nicht so gut lief, habe ich es mit der Deinstallationsroutine deinstalliert. Danach bootet mein System immer von alleine in einer Endloschleife neu, bevor der Desktop geladen war. OK - ich boote mit ALT F1, und benutze die Option um die Grafik auf Standard VGA zurückzustellen.

Hallo Frank,

ich hoffe das nicht allein meine Grafikkarte an Deiner Misere Schuld ist :shock: !!

Zum deinstallieren von SNAP:

Wenn Du zunächst den Panorama installiert hattest und dann SNAP, um dann auf den Panorama zurück zu kommen reicht es in der config.sys den Eintrag von sddgradd wieder auf panogradd zu ändern (und wieder andersrum, wenn man zurück möchte). Jedenfalls hat das bei mir immer funktioniert. Ich befürchte, dass die Deinstallationsroutine von SNAP nun auch weitere Teile des Grafiksubsystems entfernt hat.

Es ist meist auch besser, wenn man zurücksetzen muss, auf gengradd statt vga zurück zu setzen, gerade bei ACPI Systemen.

Das andauernde Neubooten von eCS - hing das nicht mit dem config.sys Eintrag AUTOFAIL=YES zusammen?

Hast Du keine Möglichkeit mit ALT+F1 eine gesicherte Konfiguration zu laden?

Ich benutze auf dem Bootlaufwerk meistens HPFS, Sjöerd Visser hatte mal in einem Vortrag ausgeführt, dass sich JFS es ab einer bestimmten Partitionsgröße (jenseits 4GB wenn ich mich recht entsinne) richtig lohnt.

Hast Du mal mit DFSEE gebootet und das Laufwerk dort über OPEN PARTITION TO WORK ON angesehen?

Mehr fällt mir jetzt auch nicht ein.
OS/2 versus Hardware - Maximum Warp!

User avatar
Frank Wochatz
Posts: 1067
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz »

Hallo Sigurd,
ich hoffe das nicht allein meine Grafikkarte an Deiner Misere Schuld ist
Nein, keine Sorge. :)
Vielmehr habe ich festgestellt, das meine Onboardgrafik höhere Auflösungen darstellen kann, als Panorama mir anbietet. Daher mal der Versuch mit Snap. Leider unterstützt Snap den Onboard-Chip nicht direkt, sondern auch nur im Vesamodus, und der ist deutlich langsamer als Panorama (Bildschirmaufbau in Zeitlupe...).
Wenn Du zunächst den Panorama installiert hattest und dann SNAP, um dann auf den Panorama zurück zu kommen reicht es in der config.sys den Eintrag von sddgradd wieder auf panogradd zu ändern (und wieder andersrum, wenn man zurück möchte). Jedenfalls hat das bei mir immer funktioniert. Ich befürchte, dass die Deinstallationsroutine von SNAP nun auch weitere Teile des Grafiksubsystems entfernt hat.
Aha, Danke für die Info.
Hast Du keine Möglichkeit mit ALT+F1 eine gesicherte Konfiguration zu laden?

Nein, das ging nicht. Ich konnte nun aber von der Wartungspartition mit "chkdsk /f" wieder Zugriff auf die Daten erlangen. Offenbar war da schon was "ganz vorne" im argen, so dass der Bootvorgang von HD schon garnicht mehr beim chkdsk ankam. Es war gar kein Dateisystemzugriff mehr möglich.

Zum Glück hatte ich noch ein Backup meines Basis-OS, das ich nun einfach über Bootlaufwerk ge-unzipped habe. Zwar nicht auf dem neuesten Stand, aber nur geht das System erstmal wieder (und meine Daten sind alle wieder da).

Was mir jetzt kurioserweise nicht mehr gelingt ist ein Upgrade auf den neuesten Panorama (hatte ich aber vorher zu laufen). Danach bootet das System nicht mehr. Ist aber nicht wichtig, der vorhandene Treiber funktioniert soweit, das laß ich jetzt erstmal so.

Aber wieder mal was dazu gelernt:
- Snap Deinstallationsroutine hinterläßt einen Scherbenhaufen
- Rückstellung auf VGA mit Bootmenü hinterläßt auch einen Scherbenhaufen
- Panorama ist irgendwie auch ein Hack der mal geht und mal nicht
- beide Treiber fummeln an Systemdateien rum, das Originalsetup wird nicht korrekt gesichert und das ganze ist nicht transparent und nur schwer umkehrbar
- Snap-Vesa ist lansgamer als Panorama-Vesa

Andi B.
Posts: 651
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

- Snap Deinstallationsroutine hinterläßt einen Scherbenhaufen
- Rückstellung auf VGA mit Bootmenü hinterläßt auch einen Scherbenhaufen....
Ja kann sein. Darum immer vorher ein z.B. .zip davon. Das ist einfacher als sich die verschiedenen Komponenten des Graphicsubsystems zu verstehen/zu reparieren.

Btw. ein chkdsk /F geht auch von der eCS Boot CD (Managementkonsole). Aber einfacher ist eine zweite Maintenance-Installation. Mit den Bootmanager und den heutigen Festplattengrößen ist das ja kein Problem.