Seltsames USB Problem

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
Markus
Posts: 77
Joined: Mon 23. Dec 2013, 16:32

Seltsames USB Problem

Post by Markus »

Habe mal wieder meine Kamera eingestöpselt und was passiert? Nichts. Seltsam. Wieder gezogen und einen Stick rein - wieder nichts. Kann nicht sein. Also mal versuchsweise bei gestecktem Stick (LED des Sticks leuchtete) im Laufwerke-Ordner auf "Wechsel-Laufwerke-aktualisieren" doppelt geklickt. Und schon war der Stick da. :o Schön. Stick auswerfen, Kamera rein, doppelklick auf aktualisieren, nichts. Na gut es war spät gestern, also heute weiter.

Rechner an Wartungspartition gestartet, Kamera rein, nichts, soweit so gut. Doppelklick auf aktualisieren und schon war die Kamera da. Kamera auswerfen. Reboot, die "normale" Partition gestartet, Kamera rein, aktualisieren, nichts. Kamera raus, Stick rein, aktualisieren, erscheint im Laufwerks-Ordner. Wieder Reboot zur Wartungspartition. Kamera, aktualisieren, da. Kamera raus, Stick rein, aktualisieren, da.
Stick raus - Trap 000e ... :shock:

Zusammengefaßt:
Arbeitspartition lt. eCS USB Configuration Notebook Beta 0.7.5
UHCI 10.183 Lars Erdmann
OHCI 10.183 Lars Erdmann
EHCI 10.183 Lars Erdmann
USBHID 10.162 IBM (Was ist USBHID) :?:

Anscheinend keine Probleme beim Auswerfen, jedoch wird die Kamera nicht erkannt.


Wartungspartition
Keine Updates, Programme o. ä. installiert. USB Treiber sind die originalen von eCS 2.1 D

Kamera alleine geht (mit aktualisieren). Stick alleine geht (mit aktualisieren). Erst Kamera, Auswurf, dann Stick, Auswurf, produziert Trap 000e

Anzumerken bleibt folgendes. Habe bei beiden Partitionen nicht versucht 2 Sticks nacheinander einzustecken und zu entfernen. Der Trapp könnte also auch bei beiden Systemen nur mit Sticks auftreten, eventuell auch nur sporadisch.
Kamera funktionierte einwandfrei auf dem normalen System (Arbeitspartition). Habe sie nur relativ lange nicht mehr eingesteckt. K. A. was ich seither alles upgedatet habe (außer den USB-Treibern).

Wie krieg ich eCS dazu Sticks/Kamera wieder automatisch zu erkennen und einzubinden?
Wie kann ich den Trap verhindern? (Ok könnte mal die neuesten Treiber von Lars probieren, möglicherweise jedoch ein anderes Problem?)

Danke schon mal für Tips,

Markus

User avatar
Frank Wochatz
Posts: 1053
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz »

Ich hatte auch schonmal einen Trap, nachdem ich einen Stick gezogen, und einen anderen eingesteckt habe.... Allerdings mache ich das zu selten, um da eine Gesetzmäßigkeit zu erkennen.
Wie krieg ich eCS dazu Sticks/Kamera wieder automatisch zu erkennen und einzubinden?
Das geht mit dem NeoWPS USB Widget, das aktualisiert die Laufwerke automatisch. Allerdings hatte ich damit Probleme, ich würde davon abraten. Lieber von Hand "Laufwerke aktualisieren", das ist ja kein Aufwand.

Grüße
Frank

User avatar
LotharS
Posts: 836
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

Frank Wochatz wrote: Das geht mit dem NeoWPS USB Widget, das aktualisiert die Laufwerke automatisch. Allerdings hatte ich damit Probleme, ich würde davon abraten. Lieber von Hand "Laufwerke aktualisieren", das ist ja kein Aufwand.
Zum USB Widget liest man von Problemen bis hin zum Abraten, deshalb habe ich es erst gar nicht. :idea:
Hier läuft der USB-Monitor, als Programmobjekt im Systemstart-Ordner: C:\ECS\BOOT\USBMSDD.EXE und als 'Parameter': C:\ecs\boot\usbmsdd.ini. Stick oder Kamera anschließen, erkennt nach kurzem Moment automatisch. Auswerfen tu ich klassich per Kommandozeile mit 'eject <lw:>'.

Hier USB-Basistreiber auch v.10.183, USBMSD.ADD v.10.162.
Der USBHID.SYS ist der 'Human Interface Device Driver', hier v. 10.145 (scheint bis auf die Versionsnr identisch mit v.10.162?). -> Wikipedia :geek:
Edit: Habe vorhin usbhid.sys auf v.10.162 "upgedatet". Läuft. Und 2 Sticks nacheinender oder zugleich tun ebenfalls.
Last edited by LotharS on Fri 7. Mar 2014, 21:23, edited 1 time in total.

Markus
Posts: 77
Joined: Mon 23. Dec 2013, 16:32

Post by Markus »

Frank Wochatz wrote:Ich hatte auch schonmal einen Trap, nachdem ich einen Stick gezogen, und einen anderen eingesteckt habe.... Allerdings mache ich das zu selten, um da eine Gesetzmäßigkeit zu erkennen.
Wie geschrieben, normalerweise stecke ich nur den einen Stick, um mal schnell von einem PC (Win) auf den anderen (eCS) was zu kopieren und vice versa. CD-RW ist da overkill und dauert zu lange. Obwohl, eCS schreibt recht gemächlich auf den USB, hab aber Zeit und ist ein anderes Thema.
Frank Wochatz wrote:
Wie krieg ich eCS dazu Sticks/Kamera wieder automatisch zu erkennen und einzubinden?
Das geht mit dem NeoWPS USB Widget, das aktualisiert die Laufwerke automatisch. Allerdings hatte ich damit Probleme, ich würde davon abraten. Lieber von Hand "Laufwerke aktualisieren", das ist ja kein Aufwand.
Habe das Widget nach diversen Problemen (z. B. PC fuhr runter, schaltete sich aber nicht ab) auch entfernt. Aktualisieren ist kein Aufwand, jedoch, mMn, für eCS etwas, wie soll ich sagen, altbacken?

Habe in der Readme von usbhcd196 folgendes gefunden:
Important note: if you have problems using the USB widget from eCenter/XCenter (part of eWorkplace/XWorkplace):
You can revert back to the original daemon program that handles USB devices attaches/detaches.
This is \ecs\boot\USBMSDD.EXE.
Here is a piece of REXX code to create a program object in the startup folder:

/* REXX script */
if RxFuncAdd('SysLoadFuncs','REXXUTIL','SysLoadFuncs') then do
rc = SysLoadFuncs()
end
bootDrive = SysBootDrive()
class='WPProgram'
title='USB-Monitor V1.2'
location='<WP_START>'
app='EXENAME='bootDrive'\ecs\boot\usbmsdd.exe'
startupdir='STARTUPDIR='bootDrive'\ecs\boot'
parameters='PARAMETERS='bootDrive'\ecs\boot\usbmsdd.ini'
icon='ICONFILE='bootDrive'\os2\boot\usbmon.ico'
iconpos='ICONPOS=0,0'
open='OPEN=RUNNING'
minimized='MINIMIZED=YES'
progtype='PROGTYPE=WINDOWABLEVIO'
autoclose='NOAUTOCLOSE=NO'
objectid='OBJECTID=<USB_MON>'
rc = SysCreateObject(class,title,location,app';'startupdir';'parameters';'icon';'iconpos';'open';'minimized';'progtype';'autoclose';'objectid';','R')
if rc==0 then
ret = 0
else
ret = 1
return ret

Save this to a file with extension .cmd and execute from a commandline. Of course you can modify the title and/or object id to whatever you like.
Das werde ich mal bei Gelegenheit probieren.

Bliebe noch das Problem mit der Kamera. Werde die 196 mal einspielen und schauen was passiert :)
Grüße
Frank
Danke trotzdem für den Tip,
Markus

Markus
Posts: 77
Joined: Mon 23. Dec 2013, 16:32

Post by Markus »

So, habe die 10.196 "eingespielt", das Rexx-Script ausgeführt.

Im Systemstart ist jetzt der USB-Monitor V1.2 (USBMSDD.EXE). USB-Geräte werden automatisch erkannt und eingebunden.
Trap trat zwar wieder auf, hatte aber auch eine Stick-Orgie vollführt. :D

MarcSenn

Post by MarcSenn »

Das Langsame schreiben auf USB geräte ist Normal bei OS/2.

Andi B.
Posts: 632
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

MarcSenn wrote:Das Langsame schreiben auf USB geräte ist Normal bei OS/2.
Wenn man 20MByte/s als langsam bezeichnet, dann ja. Win schafft am gleichen Board ca. 26. Der Unterschied ist also nicht so groß. Nur FAT32 unter eCS ist sehr langsam.

Markus
Posts: 77
Joined: Mon 23. Dec 2013, 16:32

Post by Markus »

Andi B. wrote: Wenn man 20MByte/s als langsam bezeichnet, dann ja. Win schafft am gleichen Board ca. 26. Der Unterschied ist also nicht so groß.
Bei mir benötigt eCS beim Kopieren auf USB-Stick die doppelte Zeit, oder auch mehr, als Windoof. Der Unterschied kann also schon groß sein.
Andi B. wrote:Nur FAT32 unter eCS ist sehr langsam.
Versuch mal folgenden Tip:
... hatte ich auf mehreren Rechner auch. Die kontinuierlichen Übertragungsraten auf USB-Medien mit FAT32 lagen bei um ein MB/Sek. Durch Veränderung der Parameter geht die Geschwindigkeit ganz erheblich hoch. Versuch's mal und berichte!

IFS=E:\ECS\BOOT\FAT32.IFS /CACHE:2048 /H /Q
CALL=E:\ECS\BIN\CACHEF32.EXE /CP:850 /S /F /N


Viele Grüße und ein gute Neues Jahr

Hans v. Mangoldt.
Bisher habe ich es noch nicht geschafft ein FAT32 Medium unter eCS ans Laufen zu kriegen. Kann daher nicht sagen ob das funktioniert.

User avatar
LotharS
Posts: 836
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

Markus wrote: Bisher habe ich es noch nicht geschafft ein FAT32 Medium unter eCS ans Laufen zu kriegen. Kann daher nicht sagen ob das funktioniert.
Es gibt Sticks, die ziehen einfach reichlich Strom. Deshalb hatte ich einen (billigen) einmal wegwerfen müssen, obwohl mein Netzteil eigentlich genügend Power lieferte.
Ich nehme doch an, dass Du Deine USB-Sticks für eCS vorbereitet hast: http://www.ehlertronic.de/ecs-os2/tipps ... b-msd.html ?
Und sollte ich überlesen haben, dass Du auch den USBMSD.ADD tatsächlich eingebunden hast?

Andi B.
Posts: 632
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

So sehen die Einträge in meiner config.sys aus -

Code: Select all

IFS=M:\ECS\BOOT\FAT32.IFS /CACHE:2048 /H /Q /EAS
REM cachef32.exe /S /F It's preferrable to replace "/F" with "/N" instead of remming out the line completly. Otherwise the codepage translation table will not be initialized correctly
CALL=M:\ECS\BIN\CACHEF32.EXE /S /N  
Also cache32 sollte deaktiviert sein und -

Code: Select all

REM 201310xx /REMOVABLES:6 set as higher values (see discussion at comp.os.os2.misc) drastically drops transfere speed
BASEDEV=USBMSD.ADD /REMOVABLES:6 /FLOPPIES:0
Aber die 20MByte bekommt man nur mit externer Festplatte und g'scheitem Dateisystem, also nicht FAT32. Die Sticks sind alle zu langsam, auch die angeblich USB3.0er, und es gibt gravierende Unterschiede zwischen den Sticks.

Markus
Posts: 77
Joined: Mon 23. Dec 2013, 16:32

Post by Markus »

LotharS wrote: Ich nehme doch an, dass Du Deine USB-Sticks für eCS vorbereitet hast
Die Seite kenn ich. Jedoch schrecke ich ein wenig vor DFSee zurück. Die frei verfügbare Version auf Hobbes habe ich nicht probiert, da ich bei DFSee so meine Bedenken habe. Mag ja ein gutes Programm sein, jedoch kenne ich mich mit meinem Glück ;) Falls ich mal wieder einen PC aufsetze, da kann ja nicht viel kaputt gehen, werde ich das vielleicht mal probieren

Habe es mal auf diesem Weg probiert, mit Live-DVD's. Hatte da (mangels meines Wissens über Linux) mit Suse und gentoo kein Glück. Auch der Versuch mit HPUSBDisk und Partition Wizard (beides Win-Progs) war nicht erfolgreich.
Benötige nicht unbedingt einen FAT32 formatierten Stick/Card/..., schön wär's schon. Habe hier nen alten 2GB mit Fat. Sollte der nicht reichen halt der Umweg über DVD-RW.
LotharS wrote: Und sollte ich überlesen haben, dass Du auch den USBMSD.ADD tatsächlich eingebunden hast?
Er ist eingebunden. Removables:8 und Floppies:1. Und noch ein, wenn ich mich recht erinnere, A_Usage:2. Für was auch immer der Parameter sein soll.

Markus
Posts: 77
Joined: Mon 23. Dec 2013, 16:32

Post by Markus »

Andi B. wrote: Also cache32 sollte deaktiviert sein und
Cache32 deaktivieren? Was soll das bringen?
Andi B. wrote: Die Sticks sind alle zu langsam, auch die angeblich USB3.0er, und es gibt gravierende Unterschiede zwischen den Sticks.
Unterschiede zwischen Sticks gibt es bestimmt, jedoch spielt es für eCS keine Rolle ob du einen 2.0 oder 3.0 benutzt. USB 3.0 funktioniert nicht bei eCS. Sollte ein Stick oder HD am 3er Port erkannt werden und nutzbar sein, so wird die Geschwindigkeit die eines 2.0 Ports sein.

User avatar
LotharS
Posts: 836
Joined: Sun 29. Dec 2013, 20:07
Location: Düsseldorf

Post by LotharS »

Markus wrote:Jedoch schrecke ich ein wenig vor DFSee zurück. Die frei verfügbare Version auf Hobbes habe ich nicht probiert, da ich bei DFSee so meine Bedenken habe. Mag ja ein gutes Programm sein, jedoch kenne ich mich mit meinem Glück ;) .
Wenn Du Dich einfach an Ehtrons präzise Anleitung hältst, steht Deinem Glück nichts im Wege .. :-D
Es liegt auch nicht an der Formatierung mit FAT32, das ist schon für eCS voll in Ordnung; die meisten Sticks kommen schon damit daher. Der Knackpunkt aber ist, dass eCS-OS/2 etwas eigenwillig mit Partition Tables ist, deshalb ist der Griff zu DFSee nötig. Lade Dir einfach von hier die Testversion herunter.
Markus wrote:Cache32 deaktivieren?
Mit dem Parameter /N ist nicht etwa das Caching deaktiviert, sondern nur das verzögerte Schreiben daraus ("lazy write"). Bei mir (und wohl den meisten?) funktioniert auch der vorgelieferte Parameter /F. Im Übrigen empfehle ich Dir Andis Einstellungen.

P.S.: Richtig, eCS kann noch immer kein USB 3.0. Aber solange Du keine Daten gigaweise schaufeln möchtest... Und wenn obendrein die nur leicht ältere Ziel-Hardware auch höchstens USB 2.0 besitzt, ist man damit doch bereits recht happy :lol:

Viel Erfolg!

Andi B.
Posts: 632
Joined: Tue 24. Dec 2013, 16:40

Post by Andi B. »

Markus wrote: Cache32 deaktivieren? Was soll das bringen?
Geschwindigkeitszuwachs. Kann man einfach testen indem man während des Schreibens einer großen Datei cache32 per command line Parameter umschaltet (wird wohl das lazy write sein welches bremst wie Lothar schreibt)
Andi B. wrote:Unterschiede zwischen Sticks gibt es bestimmt, jedoch spielt es für eCS keine Rolle ob du einen 2.0 oder 3.0 benutzt.
Ich meine nicht den Unterschied zwischen USB2.0 und 3.0 sondern dass sich manche Sticks mit 7MByte/s schreiben lassen und andere nur mit 2. Auch sog. 3.0 Sticks schaffen meist nicht mal 10MByte/s beim Schreiben und das ist weit unter den ca. 20MB welche eCS mit den derzeitigen Treibern kann. Ein uralter 4GB SanDisk ist noch immer einer meiner schnellsten Sticks, neuere SanDisk welche ich vor Kurzem gekauft habe, sind meist langsamer.

Btw. bei meinen sog. 3.0 Sticks ist ein Verbatim dabei der gar nicht geht mit eCS. Alle anderen, auch Verbatim sind dabei im gleichen Gehäuse, funktionieren.

Zusammengefasst - die eCS Treiber sind noch immer schneller beim Schreiben als alle meine Sticks. Wenn man allerdings FAT32 verwenden muss, wird ein Stick oder Festplatte noch mal zusätzlich deutlich gebremst. Da wird dann erst der Unterschied zu Win merkbar.

User avatar
Frank Wochatz
Posts: 1053
Joined: Sun 22. Dec 2013, 22:04
Location: Berlin

Post by Frank Wochatz »

Ich habe FAT 32 formatierte Sticks. An FAT32 kommt man ja kaum vorbei, wenn man den Stick auch zum Datenaustausch mit anderen Systemen benutzten will. An unterschiedlichen eCS Rechnern habe ich mit dem jeweils gleichen Stick dramatisch unterschiedliche Schreibgeschwindigkeiten. Auf den Rechnern befinden sich unterschiedliche USB Versionen. Der FAT Treiber ist immer der gleiche. Kurioserweise läuft USB auf einer älteren USB Version dabei deutlich schneller. Den allerneusten USB Stack habe ich allerdings auch noch nicht probiert - werde ich mal machen.

D.h. jedoch, dass auch die USB Treiber eine Rolle spielen. Letzendlich kann ich aber auch mit langsamen Geschwindigkeiten ganz gut leben. :)

Werner.S
Posts: 104
Joined: Mon 23. Dec 2013, 11:29
Location: Nürnberg

Post by Werner.S »

Ich hab jetzt auch mal getestet:
mit diesen Einstellungen auf zwei verschiedene Sticks kopiert.
IFS=G:\ECS\BOOT\FAT32.IFS /CACHE:2048 /H /Q
CALL=G:\ECS\BIN\CACHEF32.EXE /CP:850 /S /F

24 MB Firefox.zip

Die Geschwindigkeit:
8 GB Stick mit 460
32 GB Stick mit 1200