Firefox kennt keine Videos mehr

(DE) Anwendungen für Office, Multimedia und Spiele, Werkzeuge, Hilfsprogramme, etc
(EN) Applications for Office, Multimedia or Games, Tools, Utilities, e.g.
User avatar
DonLucio
Posts: 755
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Firefox kennt keine Videos mehr

Post by DonLucio »

Bisher konnte mein FF (45.9.0) Videos prima abspielen. MP4, MPG und auch WEBM, mit Ton.
Es wurde ein Vorschaubild angezeigt und bei Klick auf "play video" wurde das Video direkt abgespielt.

Seitdem ich ffmpeg upgedatet habe (von ecsoft2.org) geht das nicht mehr. Statt Vorschaubild sehe ich nur ein weißes Kästchen und der Klick auf "play Video" startet einen Download der mp4-Datei.

Dummerweise habe ich den ffmpeg-Update mittels YUM gemacht (so wie auf ecsoft.org angegeben: yum install ffmpeg), folglich kann ich nicht sagen, was genau für Dateien / DLLs installiert / überschrieben wurden.

Offenbar hat dieser yum auch in den Firefox-Einstellungen etwas bewirkt. Aber was? Ich habe versucht, im Firefox: "Tools" -> "Options" -> "Applications" bei MP4 den mplayer (Bestandteil des ffmpeg-Pakets) anzugeben. Das hat nur halb geklappt: Das Video-Vorschaufenster bleibt weiterhin leer und der Klick auf "play Video" startet einen Download und die Datei wird dann von meinem lokalen mplayer.exe abgespielt. Das ist nicht, wie es vorher war, nämlich ein nahtlos eingebettetes Abspielen des Videos.

Jeder Rat ist willkommen.

Danke,
Lutz W.

_diver
Posts: 277
Joined: Fri 27. Jun 2014, 10:57

Post by _diver »

DonLucio wrote:
Mon 4. Apr 2022, 11:53
Bisher konnte mein FF (45.9.0) Videos prima abspielen. MP4, MPG und auch WEBM, mit Ton.
Es wurde ein Vorschaubild angezeigt und bei Klick auf "play video" wurde das Video direkt abgespielt.

Seitdem ich ffmpeg upgedatet habe (von ecsoft2.org) geht das nicht mehr. Statt Vorschaubild sehe ich nur ein weißes Kästchen und der Klick auf "play Video" startet einen Download der mp4-Datei.

Dummerweise habe ich den ffmpeg-Update mittels YUM gemacht (so wie auf ecsoft.org angegeben: yum install ffmpeg), folglich kann ich nicht sagen, was genau für Dateien / DLLs installiert / überschrieben wurden.

Offenbar hat dieser yum auch in den Firefox-Einstellungen etwas bewirkt. Aber was? Ich habe versucht, im Firefox: "Tools" -> "Options" -> "Applications" bei MP4 den mplayer (Bestandteil des ffmpeg-Pakets) anzugeben. Das hat nur halb geklappt: Das Video-Vorschaufenster bleibt weiterhin leer und der Klick auf "play Video" startet einen Download und die Datei wird dann von meinem lokalen mplayer.exe abgespielt. Das ist nicht, wie es vorher war, nämlich ein nahtlos eingebettetes Abspielen des Videos.

Jeder Rat ist willkommen.

Danke,
Lutz W.
das ist imho schon mehrfach erwähnt worden. Ob hier oder in os2world.com weiss ich nicht.
ffmpeg-legacy oder und libvpx-legacy braucht es.

User avatar
DonLucio
Posts: 755
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

_diver wrote:
Mon 4. Apr 2022, 14:31
das ist imho schon mehrfach erwähnt worden. Ob hier oder in os2world.com weiss ich nicht.
Ja, das war hier. Mein eigener Post Anfang Januar 2021. Hatte ich ganz vergessen :roll:

_diver wrote:
Mon 4. Apr 2022, 14:31
ffmpeg-legacy oder und libvpx-legacy braucht es.
Mit "yum install ffmpeg-legacy-56" war das Problem dann beseitigt. Videos gehen jetzt wieder wie vorher.

Danke!

Lutz W.

User avatar
ThomasOF
Posts: 240
Joined: Mon 20. Jan 2014, 19:26
Location: Offenbach

Post by ThomasOF »

Hallo,

@silvan: Besten Dank für die Informationen. Hat bei mir auch gleich funktioniert.

Trotzdem frage ich mich, wie man solche Dinge von alleine wissen soll, da müßte es schon bessere Möglichkeiten geben als nur im Forum zu fragen. Zum Beispiel könnte man die genannten rpm's vielleicht auch irgendwie mit dem Vorgängerstand verlinken? Selbsterschließend ist es jedenfalls noch nicht.

Thomas

User avatar
DonLucio
Posts: 755
Joined: Sun 29. Dec 2013, 01:14
Location: Hamburg

Post by DonLucio »

ThomasOF wrote:
Wed 6. Apr 2022, 20:05
Trotzdem frage ich mich, wie man solche Dinge von alleine wissen soll
Geht mir genauso.

Andererseits: Solange man hier im Forum auf solche Fragen ein gute Antwort erhält und nicht als nervender DAU abgestempelt wird, kann ich damit leben.

Wenn ich mir andere Foren (außerhalb OS/2) anschaue, dann herrschen bei uns noch echt paradiesische Zustände.

Gruß,
Lutz W.

_diver
Posts: 277
Joined: Fri 27. Jun 2014, 10:57

Post by _diver »

ThomasOF wrote:
Wed 6. Apr 2022, 20:05
Hallo,

@silvan: Besten Dank für die Informationen. Hat bei mir auch gleich funktioniert.

Trotzdem frage ich mich, wie man solche Dinge von alleine wissen soll, da müßte es schon bessere Möglichkeiten geben als nur im Forum zu fragen. Zum Beispiel könnte man die genannten rpm's vielleicht auch irgendwie mit dem Vorgängerstand verlinken? Selbsterschließend ist es jedenfalls noch nicht.

Thomas
Die rpm's verlinken wäre fatal. Das Problem ist, dass FFox nicht als rpm vorhanden ist. Weil sonst die Abhängigkeiten automatisch aufgelöst würden.
Das ist ja eigentlich genau das was rpm gut kann und tut.