eCS 2.2 auf XEN-Server als VM

(DE) System, Installation, Konfiguration, Hardware, Treiber, Netzwerk, Virtualisierung, etc.
(EN) System, Installation, Configuration, Hardware, Drivers, Network, Virtualisation, etc.
kmb
Posts: 24
Joined: Fri 3. Jan 2014, 12:40

eCS 2.2 auf XEN-Server als VM

Post by kmb »

Hallo,

hat wer obiges schon mal versucht?

Auf Anhieb bin ich bei der Installation bis zur Eingabe der Registriernummer gekommen - jetzt kann ich natürlich keinen USB-Stick mit der Nummer einstecken.

Wie kann ich denn diese in die ISO einbauen? (Frank hatte da glaub ich mal einen Patch für eine ältere Version gemacht)

Weder Panorama noch SNAP gehen, aber GRADD.

Wenn man das hinbekommt, wäre es was für die Zukunft, da HW-unabhängig.

Gruß, KlausB
klaus
Posts: 37
Joined: Wed 1. Jan 2014, 21:01
Location: Bonn

Post by klaus »

Hallo Klaus,

um den Key in die ISO einzufügen, gibt es das Tool reg2iso.exe. Das hat bei mir mit der eCS beta 2 wunderbar geklappt.
Reg2iso.exe gibt es m.W. nur bei Mensys.


Replace eCS key in ISO file.

If key file supplied, it will replace any keys found in ISO.
If key file omitted, keys found in ISO will be replaced with an invalid key.

Usage: reg2iso [-d] [-h] [-v] [-V] [-?] isofile [keyfile]

-d Enable debug logic, repeat for more verbosity
-h -? Display this message
-v Enable verbose output
-V Display version

isofile Required ISO file name
keyfile Optional key file name


example: reg2iso ecs21_cd1_en_us.iso regkey.txt


Der reg.key muss nur richtig in einer Textdatei stehen in der Form

<USERNAME>
Dein User Name
</USERNAME>

<REGKEY>
xxxxxxxxxxxxxx - xxxxxxxxxxxxx
xxxxxxxxxxxxxx - xxxxxxxxxxxxx
xxxxxxxxxxxxxx - xxxxxxxxxxxxx
xxxxxxxxxxxxxx - xxxxxxxxxxxxx
</REGKEY>


Gruß
Klaus
Yellow
Posts: 6
Joined: Thu 9. Oct 2014, 21:39

Post by Yellow »

Hallo,

hat wer obiges schon mal versucht?
Mit der 1.2r aber ohne grossen Erfolg. Die Installation bleibt schon ziemlich am Anfang haengen und lastet die VM zu 100% aus
kmb
Posts: 24
Joined: Fri 3. Jan 2014, 12:40

Post by kmb »

Danke für dier Antworten.

Damit bin ich schon ein Stück weiter:

Phase 1 der Installation läuft jetzt komplett durch, bei Neustart von der Platte vor Phase 2 hängt er nach Installation des Realtek-Treibers.

Danach müßte der Bildschirmtreiber kommen.

Ich hatte VGA bei der Installation angewählt - schien mir das unkritischste.

Immerhin 2 Beobachtungen:

1. von der ISO bootet die GUI immerhin mit GRADD und VGA - warum soll es also nicht auch von der Platte gehen?

2. zur Kommandozeile hin kann ich schon frei booten - aber ohne Netz bzw. USB habe ich da keine Perspektive.

ABER:

Wäre doch Klasse, wenn wir da eine hardwareunabhängige Zukunftsperspektive hätten!

Yellow, magst Du nicht auf Deinem XEN-Server mal die eCs 2.2 ausprobieren?

Bei der 1.2r gab es m.W. den Punkt "Virtual Machine Installation" noch nicht.

Mein XEN-Server ist übrigens 6.2.
User avatar
thorolf
Posts: 555
Joined: Wed 25. Dec 2013, 16:14
Location: Rhein-Main

Post by thorolf »

kmb » Do 27. Nov 2014, 17:49 wrote:Damit bin ich schon ein Stück weiter:
Phase 1 der Installation läuft jetzt komplett durch, bei Neustart von der Platte vor Phase 2 hängt er nach Installation des Realtek-Treibers.
Danach müßte der Bildschirmtreiber kommen.
Ich hatte VGA bei der Installation angewählt - schien mir das unkritischste.

Immerhin 2 Beobachtungen:
1. von der ISO bootet die GUI immerhin mit GRADD und VGA - warum soll es also nicht auch von der Platte gehen?
2. zur Kommandozeile hin kann ich schon frei booten - aber ohne Netz bzw. USB habe ich da keine Perspektive.
Damit bist Du viel weiter, als ich mit Xen 4.0.3 jemals gekommen bin, da bootete überhaupt nichts was irgendwie mit OS/2 zu tun hatte und das lag seinerzeit definitiv an Xen!

Ich habe dann einfach auf einem zweiten System (auch unter Linux) VirtualBox installiert, da läuft mein ACP2R völlig problemlos und performant, der Zugriff geht über RDP in die VirtualBox und damit auch besser als mit einem VNC-Server direkt auf den OS/2-Server.
Wäre doch Klasse, wenn wir da eine hardwareunabhängige Zukunftsperspektive hätten!
Sicher, aber dafür gibt es ja die Desktop-Virtualisierung wie z.B. VirtualBox. Xen ist viel mehr auf die Server-Virtualisierung getrimmt, die Anzeige von grafischen Oberflächen ist da zum Arbeiten nicht wirklich toll, außerdem hat Xen vor allem bei para-virtualisierten Gästen große Vorteile gegenüber den meisten anderen Lösungen, das geht aber (praktisch) nur mit Linux.

Und während man auf installierte Windows-Gäste recht gut mit RDP drauf kommt, gibt es für OS/2 nur ziemlich veraltete VNC-Server, damit zu arbeiten macht mir keinen Spass.
Yellow, magst Du nicht auf Deinem XEN-Server mal die eCs 2.2 ausprobieren?
Bei der 1.2r gab es m.W. den Punkt "Virtual Machine Installation" noch nicht.
Der spielt aber auch keine wirkliche Rolle, hier wird nur ein bestimmter PM-Treiber, Grafik-Treiber und Maus-Treiber voreingestellt (ich weiß nicht mehr welcher, bei mir laufen OS/2-Gäste aber mit den alten Treibern wie IBM-APM, GRADD und SMouse am besten).
Mein XEN-Server ist übrigens 6.2.
Daran könnte es eher liegen, vielleicht haben die "zufällig" den/die Probleme behoben, die OS/2 bislang daran gehindert haben auf Xen überhaupt zu starten. Aber das glaube ich erst, wenn OS/2 komplett mit GUI und Netzwerk läuft.
Grüße,

Thorolf
kmb
Posts: 24
Joined: Fri 3. Jan 2014, 12:40

Post by kmb »

(gelöscht)
Wäre doch Klasse, wenn wir da eine hardwareunabhängige Zukunftsperspektive hätten!
Sicher, aber dafür gibt es ja die Desktop-Virtualisierung wie z.B. VirtualBox. Xen ist viel mehr auf die Server-Virtualisierung getrimmt, die Anzeige von grafischen Oberflächen ist da zum Arbeiten nicht wirklich toll, außerdem hat Xen vor allem bei para-virtualisierten Gästen große Vorteile gegenüber den meisten anderen Lösungen, das geht aber (praktisch) nur mit Linux.

Da hast Du sicher recht, aber mir geht es ja gerade um den Server, wollte den doch in die Jahre gekommenen IBM-Server virtualisieren.

Auf dem Server braucht man natürlich kein Grafik-Schnickschnack, aber GUI ist natürlich nicht schlecht..

Apropos:

Immerhin bin ich bis zur GUI, alles außer dem Netzwerktreiber geht.

Der ist natürlich ein Kernpunkt.
Und während man auf installierte Windows-Gäste recht gut mit RDP drauf kommt, gibt es für OS/2 nur ziemlich veraltete VNC-Server, damit zu arbeiten macht mir keinen Spass.
VNC: Ist für uns ja fast das einzige, oder?

Habe gerade mal jrdesktop 3.1 probiert, das läuft immerhin über die 1507-JVM (Acrobat) als RDP-Ersatz-Java-Programm.

Yellow, magst Du nicht auf Deinem XEN-Server mal die eCs 2.2 ausprobieren?

Bei der 1.2r gab es m.W. den Punkt "Virtual Machine Installation" noch nicht.

Der spielt aber auch keine wirkliche Rolle, hier wird nur ein bestimmter PM-Treiber, Grafik-Treiber und Maus-Treiber voreingestellt (ich weiß nicht mehr welcher, bei mir laufen OS/2-Gäste aber mit den alten Treibern wie IBM-APM, GRADD und SMouse am besten).
Ja, aber, wenn ich den Punkt nicht nehme, meckert er sofort - also vor dem Start - wegen Interrupts mit Adressen im Nirvana (oder so was)

also, das mit den Interrupts kann beim Netzwerktreiber aber nicht alles sein. Habe mal NOIRQ eingestellt, geht auch nicht.

Probiere dann nochmal andere Versionen durch.
Mein XEN-Server ist übrigens 6.2.

Daran könnte es eher liegen, vielleicht haben die "zufällig" den/die Probleme behoben, die OS/2 bislang daran gehindert haben auf Xen überhaupt zu starten. Aber das glaube ich erst, wenn OS/2 komplett mit GUI und Netzwerk läuft.
GUI geht - Schönheitsfehler ist eine etwas nachhängende Maus - , wenn man so weit schon ist, wäre es schade, wenn es an einem einzigen Treiber scheitert. ...

KlausB
User avatar
thorolf
Posts: 555
Joined: Wed 25. Dec 2013, 16:14
Location: Rhein-Main

Post by thorolf »

kmb » Di 2. Dez 2014, 13:29 wrote:Auf dem Server braucht man natürlich kein Grafik-Schnickschnack, aber GUI ist natürlich nicht schlecht..
bei OS/2 (oder auch WIndows) kommt man bloß ohne GUI nicht aus, bei Linux mache ich praktisch alles über SSH, aber auch das funktioniert als SSHD unter OS/2 nur mit Einschränkungen.
GUI geht - Schönheitsfehler ist eine etwas nachhängende Maus - , wenn man so weit schon ist, wäre es schade, wenn es an einem einzigen Treiber scheitert. ...
Ich stand vor wenige Jahren vor dem gleichen Problem.

Ich hatte einen alten (stromfressenden) OS/2-Server der nicht mehr so recht wollte und ein schlanken ThinkCenter mit C2D auf dem Linux mit einer Reihe von Xen-VMs lief. Da ich OS/2 trotz Voll-Virtualisierung nicht zum Laufen bekommen habe und Xen keine andere Virtualisierungs-Lösung neben sich "duldet", habe ich mir kurzerhand einen identischen Rechner gekauft (<200 EUR inkl. 8 GB RAM), dort Linux und VirtualBox installiert und zwei VMs angelegt, eine mit ACP2R sowie eine mit Win7 für "alle Fälle".

Und wenn ich Zeit "finde" wird dieser OS/2-Server hoffentlich auch mal wieder als Web-Server arbeiten, bislang verbraucht der nur Strom, weil ich noch nicht zum Einrichten gekommen bin ...
Grüße,

Thorolf
Peter_Meter

Post by Peter_Meter »

Gibt es hier irgendwelche News? Hat jemand OS/2 auf einem Xenserver zum laufen gebracht?
User avatar
thorolf
Posts: 555
Joined: Wed 25. Dec 2013, 16:14
Location: Rhein-Main

Post by thorolf »

Aus meiner Sicht gibt es da nichts neues, der Stand ist aber auch schon wieder ein paar Monate alt.

Allerdings gibt es außer OS/2 auch kein System was derart weitreichend den Prozessor nutzt und daher glaube ich nicht, das sich da jemals was ändern wird. Als voll-virtualisierte Gäste laufen ja alle halbwegs relevanten Betriebssysteme unter Xen (bzw. QEMU).

PS: Mein ACP2R läuft übrigens immer noch mit VirtualBox und der LAN-Server eines Kunden mit ca. 20 Arbeitsplätzen ebenso ..
Grüße,

Thorolf
kmb
Posts: 24
Joined: Fri 3. Jan 2014, 12:40

Post by kmb »

Hallo,

bin auch noch nicht weiter, vielleicht hilft bei wem der auf pfsense(dot)org erläuterte Workaround:

NW-Schnittstelle E1000 anstelle Realtek emulieren.

Wenn es einer schafft, bitte Details.

Schöne Grüße

kmb